Loading ...
Sorry, an error occurred while loading the content.
 

Re: GUI in Vim V7.2 for Windows is translated to local language

Expand Messages
  • Tony Mechelynck
    ... Both are relevant. To get Vim messages and menus in English regardless of the OS language setting, just add the following near the top of your vimrc: if
    Message 1 of 3 , Nov 1, 2008
      On 01/11/08 22:58, maalobs wrote:
      > Hi there,
      > I just installed windows on a new office computer and a new home
      > computer, one with English Windows XP Pro and and one with English
      > Windows Vista x64.
      > I have used Vim for many years, and I think the "latest" version I had
      > installed on the old machines was 6.1.
      > Now to my horror I discovered that the UI in Vim V7.2 was translated to
      > Swedish, without me being asked about it during the installation.
      > My regional setting in Windows is Swedish on both machines, but that's
      > because I want ISO8601-formatting, not because I like being subjected to
      > the travesty of svengelska (= "swenglish").
      > Surely this can be rectified by issuing some command to ignore
      > translation-attempts of the UI, but unfortunately I have not found it.
      > I searched the docs, but the best I could find was :language and :help
      > locale, and neither of them were relevant.
      > Is there a way to acquire an English GUI in Windows Vim in spite of
      > having a non-English regional setting in Windows?

      Both are relevant. To get Vim messages and menus in English regardless
      of the OS language setting, just add the following near the top of your
      vimrc:

      if has('unix')
      language messages C
      else
      language messages en
      endif

      None of the following (which are normally not all present) should
      precede it:

      source $VIMRUNTIME/vimrc_example.vim
      runtime vimrc_example.vim
      filetype on
      filetype plugin on
      filetype indent on
      filetype plugin indent on
      syntax enable
      syntax on

      Best regards,
      Tony.
      --
      hundred-and-one symptoms of being an internet addict:
      241. You try to look for Net Search even when you're in File Manager.

      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_use" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • maalobs
      2008/11/1 Tony Mechelynck ... Yes, that was the solution! Thank you for your kind help!
      Message 2 of 3 , Nov 2, 2008
        2008/11/1 Tony Mechelynck <antoine.mechelynck@...>

        > On 01/11/08 22:58, maalobs wrote:
        >> Is there a way to acquire an English GUI in Windows Vim in spite
        >> of having a non-English regional setting in Windows?

        > To get Vim messages and menus in English regardless of the OS
        > language setting, just add the following near the top of your vimrc:

        > if has('unix')
        > language messages C
        > else
        > language messages en
        > endif

        > None of the following (which are normally not all present) should
        > precede it:

        > source $VIMRUNTIME/vimrc_example.vim
        > runtime vimrc_example.vim
        > filetype on
        > filetype plugin on
        > filetype indent on
        > filetype plugin indent on
        > syntax enable
        > syntax on

        Yes, that was the solution!

        Thank you for your kind help!

        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_use" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      Your message has been successfully submitted and would be delivered to recipients shortly.