Loading ...
Sorry, an error occurred while loading the content.
 

Re: How to configure dbext profile to use Windows user account?

Expand Messages
  • Daren Thomas
    Oops! Sorry to have wasted your Time, Dave. It seems I am still on an old version of dbext (could not find the let g:dbext_default_profile = usual in
    Message 1 of 8 , Oct 31, 2008
      Oops! Sorry to have wasted your Time, Dave. It seems I am still on an
      old version of dbext (could not find the "let g:dbext_default_profile
      = 'usual'" in Version 6.01 of dbext-tutorial help).

      I will of course upgrade before asking any more silly questions!

      Thank you,

      Daren

      On Wed, Oct 29, 2008 at 6:00 PM, David Fishburn <dfishburn.vim@...> wrote:
      >
      > On Wed, Oct 29, 2008 at 12:26 PM, Daren Thomas <dthomas.ch@...> wrote:
      >>
      >> Thanks, that did the trick! I could not really find a way to load a
      >> profile on startup (I guess I'm missing some vim script knowledge
      >> here...)
      >>
      >> What would you put in your .vimrc to execute 'DBSetOption
      >> profile=MyProfile'? (sure, this *is* very newby...)
      >>
      >> I tried:
      >>
      >> :DBSetOption profile=MyProfile
      >> DBSetOption profile=MyProfile
      >> call DBSetOption('profile=MyProfile')
      >>
      >> and some other similar combinations - am I missing something?
      >
      > Under :h dbext-tutorial when it references the Connection Profiles it
      > indicates you can do this:
      >
      > let g:dbext_default_profile_usual = 'type=ASA:user=DBA:passwd=SQL'
      >
      > let g:dbext_default_profile = 'usual'
      >
      > By default, all buffers will use 'usual' unless otherwise stated.
      >
      > Dave
      >
      > >
      >

      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_use" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • qihua wu
      ... Hi Dave, To connect to sql server, we need to know the hostname, instance name and database name. But in your example of
      Message 2 of 8 , Oct 22, 2013
        On Wednesday, October 29, 2008 4:40:08 AM UTC+8, David Fishburn wrote:
        > > I'm trying to configure a profile for dbext that uses my windows login
        > > to log into a SQL Server installation. Dropping the "user=" and
        > > "password=" fields does not help, as I just get an error message
        > > saying I'm not logged in. The documentation does not mention how to do
        > > this. Any tips?
        >
        > I have updated the docs for the next release, thanks for the note.
        >
        > let g:dbext_default_profile_mySQLServer =
        > 'type=SQLSRV:integratedlogin=1:dbname=myDB'
        >
        >
        > Dave

        Hi Dave,
        To connect to sql server, we need to know the hostname, instance name and database name. But in your example of 'type=SQLSRV:integratedlogin=1:dbname=myDB'. There is only databasename. How to provide hostname/instancename?

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      • qihua wu
        ... Hi Dave, To connect to sql server we need to know hostname, instance name and db name. but your example type=SQLSRV:integratedlogin=1:dbname=myDB only
        Message 3 of 8 , Oct 22, 2013
          On Wednesday, October 29, 2008 4:40:08 AM UTC+8, David Fishburn wrote:
          > > I'm trying to configure a profile for dbext that uses my windows login
          > > to log into a SQL Server installation. Dropping the "user=" and
          > > "password=" fields does not help, as I just get an error message
          > > saying I'm not logged in. The documentation does not mention how to do
          > > this. Any tips?
          >
          > I have updated the docs for the next release, thanks for the note.
          >
          > let g:dbext_default_profile_mySQLServer =
          > 'type=SQLSRV:integratedlogin=1:dbname=myDB'
          >
          >
          > Dave
          Hi Dave,
          To connect to sql server we need to know hostname, instance name and db name. but your example 'type=SQLSRV:integratedlogin=1:dbname=myDB' only show dbname. So how to set hostname and instance name?

          --
          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php

          ---
          You received this message because you are subscribed to the Google Groups "vim_use" group.
          To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
          For more options, visit https://groups.google.com/groups/opt_out.
        Your message has been successfully submitted and would be delivered to recipients shortly.