Loading ...
Sorry, an error occurred while loading the content.

Re: ini syntax?

Expand Messages
  • 703designs
    Oh, the problem I had before was when trying to set the filetype for the file (not a .ini). I was entering :set ft=ini , but dosini works fine. ...
    Message 1 of 6 , Oct 30, 2008
    • 0 Attachment
      Oh, the problem I had before was when trying to set the filetype for
      the file (not a .ini). I was entering ":set ft=ini", but dosini works
      fine.



      On Oct 30, 6:38 pm, Gary Johnson <garyj...@...> wrote:
      > On 2008-10-30, 703designs <thomasmal...@...> wrote:
      >
      > > On Oct 30, 3:40 pm, Jean-Rene David <jrdavid...@...> wrote:
      > > > * 703designs [2008.10.30 14:10]:
      >
      > > > > I could develop this myself, but does anyone
      > > > > know of a way to get INI file syntax
      > > > > highlighting? It's a nice to have section
      > > > > headings and comments highlighted.
      >
      > > > :set ft=dosini
      > > > :syntax on
      > > So Vi doesn't recognize a .ini file as dosini? I guess I'll have to
      > > autocomd it. Thanks for the help!
      >
      > Did you not read Erik's reply?  There is no need to "autocmd it".
      > It should work already as long as you have filetype detection
      > enabled and syntax highlighting turned on.  Do you?
      >
      > Regards,
      > Gary
      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_use" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    Your message has been successfully submitted and would be delivered to recipients shortly.