Loading ...
Sorry, an error occurred while loading the content.

Re: disable syntax for all but select file types?

Expand Messages
  • Michael B Allen
    ... That worked. Thanks. Mike --~--~---------~--~----~------------~-------~--~----~ You received this message from the vim_use maillist. For more
    Message 1 of 4 , Oct 29, 2008
    • 0 Attachment
      On Oct 29, 1:54 am, Gary Johnson <garyj...@...> wrote:
      > On 2008-10-28, John Little <John.B.Lit...@...> wrote:
      >
      > > Hi
      >
      > > On Oct 29, 4:10 pm, Michael B Allen <iop...@...> wrote:
      >
      > > > Is there a broad way to disable syntax highlighting for everything
      > > > *except* a few specific file types?
      >
      > > :syntax manual
      >
      > > may be what you want.  Look at :help syntax-loading.
      >
      > That's what I use.  I have this in my ~/.vimrc,
      >
      >    syn manual
      >
      > and this in a ~/.vim/after/ftplugin/<filetype>.vim file for each
      > filetype for which I want to enable syntax highlighting:
      >
      >    setlocal syntax=ON

      That worked. Thanks.

      Mike
      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_use" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    Your message has been successfully submitted and would be delivered to recipients shortly.