Loading ...
Sorry, an error occurred while loading the content.

Stopping automatic outdent with colon in C comment

Expand Messages
  • Michael Henry
    All, When editing C files, I like the automatic re-indentation which occurs when I enter a label (an identifier followed by a colon). But inside of a C
    Message 1 of 1 , Oct 10, 2008
    • 0 Attachment
      All,

      When editing C files, I like the automatic re-indentation which occurs
      when I enter a label (an identifier followed by a colon). But inside of
      a C comment, I'd like to disable this behavior. I can't find anything
      relevant in the help.

      In my setup, I have cinkeys set to:

      0{,0},0),:,0#,!^F,o,O,e

      As I understand it, the ':' in cinkeys causes a re-indentation to occur
      when ':' is pressed. In :help C-indenting, the description of the ':'
      flag is:
      """
      : Reindent a line when a ':' is typed which is after a label or case
      statement. Don't reindent for a ":" in "class::method" for C++. To
      Reindent for any ":", use "<:>".
      """

      But I can't find anything mentioning an exception for C comments. Does
      anyone know how to disable indentation on ':' within comments?

      Thanks,
      Michael Henry


      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_use" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    Your message has been successfully submitted and would be delivered to recipients shortly.