Loading ...
Sorry, an error occurred while loading the content.
 

Re: cygwin-vim and txtfmt

Expand Messages
  • Dan Sharp
    ... Maybe ... ? Dan --~--~---------~--~----~------------~-------~--~----~ You received this message from the vim_use maillist. For more information, visit
    Message 1 of 6 , Oct 2 9:47 PM
      On Thu, Oct 2, 2008 at 7:55 PM, r <r.trev_@...> wrote:
      >
      > Does anyone knows how to change colours from dull to brilliant in
      > consolle ?

      Maybe
      :set background=dark
      ?

      Dan

      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_use" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • r
      ... My background is already dark, it is not a contrast problem. Colours are dull, light, in anyway. Rob --~--~---------~--~----~------------~-------~--~----~
      Message 2 of 6 , Oct 3 2:13 AM
        On 3 Ott, 06:47, "Dan Sharp" <dwsh...@...> wrote:
        > On Thu, Oct 2, 2008 at 7:55 PM, r <r.tr...@...> wrote:
        >
        > > Does anyone knows how to change colours from dull to brilliant in
        > > consolle ?
        >
        > Maybe
        > :set background=dark

        My background is already dark, it is not a contrast problem.
        Colours are dull, light, in anyway.

        Rob
        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_use" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      • r
        Brett Stahlman, the txtfmt author, solved the problem, coping the txtfmt colour scheme let g:txtfmtColor{1} = ^ %(k |bla %[ck] )$,c:Black,g:#000000 let
        Message 3 of 6 , Oct 3 9:59 AM
          Brett Stahlman, the txtfmt author, solved the problem, coping the
          txtfmt colour scheme

          let g:txtfmtColor{1} = '^\\%(k\\|bla\\%[ck]\\)$,c:Black,g:#000000'
          let g:txtfmtColor{2} = '^b\\%[lue]$,c:DarkBlue,g:#0000FF'
          let g:txtfmtColor{3} = '^g\\%[reen]$,c:DarkGreen,g:#00FF00'
          let g:txtfmtColor{4} = '^t\\%[urquoise]$,c:LightGreen,g:#00FFFF'
          let g:txtfmtColor{5} = '^r\\%[ed]$,c:DarkRed,g:#FF0000'
          let g:txtfmtColor{6} = '^v\\%[iolet]$,c:DarkMagenta,g:#FF00FF'
          let g:txtfmtColor{7} = '^y\\%[ellow]$,c:DarkYellow,g:#FFFF00'
          let g:txtfmtColor{8} = '^w\\%[hite]$,c:White,g:#FFFFFF'

          in ~/.vimrc and changing the colour name with the corresponding colour
          number found executing in vim " :hi ".

          let g:txtfmtColor{1} = '^\\%(k\\|bla\\%[ck]\\)$,c:Black,g:#000000'
          let g:txtfmtColor{2} = '^b\\%[lue]$,c:4,g:#0000FF'
          let g:txtfmtColor{3} = '^g\\%[reen]$,c:2,g:#00FF00'
          let g:txtfmtColor{4} = '^t\\%[urquoise]$,c:6,g:#00FFFF'
          let g:txtfmtColor{5} = '^r\\%[ed]$,c:1,g:#FF0000'
          let g:txtfmtColor{6} = '^v\\%[iolet]$,c:5,g:#FF00FF'
          let g:txtfmtColor{7} = '^y\\%[ellow]$,c:3,g:#FFFF00'
          let g:txtfmtColor{8} = '^w\\%[hite]$,c:White,g:#FFFFFF'

          this solved the problem. Bright colours are visible with the " fb "
          txtfmt command


          --~--~---------~--~----~------------~-------~--~----~
          You received this message from the "vim_use" maillist.
          For more information, visit http://www.vim.org/maillist.php
          -~----------~----~----~----~------~----~------~--~---
        • Dan Sharp
          ... Read the help for the background option at :help background since I think the first paragraph explains it all: When set to dark , Vim will try to use
          Message 4 of 6 , Oct 3 10:29 AM
            On Fri, Oct 3, 2008 at 5:13 AM, r <r.trev_@...> wrote:
            > On 3 Ott, 06:47, "Dan Sharp" <dwsh...@...> wrote:
            >> On Thu, Oct 2, 2008 at 7:55 PM, r <r.tr...@...> wrote:
            >>
            >> > Does anyone knows how to change colours from dull to brilliant in
            >> > consolle ?
            >>
            >> Maybe
            >> :set background=dark
            >
            > My background is already dark, it is not a contrast problem.
            > Colours are dull, light, in anyway.
            >

            Read the help for the background option at :help 'background' since I
            think the first paragraph explains it all:

            When set to "dark", Vim will try to use colors that look good on a
            dark background. When set to "light", Vim will try to use colors that
            look good on a light background. Any other value is illegal.
            Vim tries to set the default value according to the terminal used.
            This will not always be correct.
            Setting this option does not change the background color, it tells Vim
            what the background color looks like.

            For example, if you run Vim in a terminal with a black background and
            the colors are dull (often the dark blue is hard to read against the
            black background), then you can give the command :set background=dark
            to tell Vim that it has a dark background and needs to use the
            brighter colors, such as changing the dark blue font to the brighter
            cyan color.

            Anyway, your subsequent post says you found an answer, though I
            believe it just 'brute forces' the same effect as the command I
            mentioned.

            Dan

            --~--~---------~--~----~------------~-------~--~----~
            You received this message from the "vim_use" maillist.
            For more information, visit http://www.vim.org/maillist.php
            -~----------~----~----~----~------~----~------~--~---
          • Brett Stahlman
            ... The txtfmt plugin doesn t consider background when setting the defaults. It simply uses a safe set, and expects users who don t like the defaults to
            Message 5 of 6 , Oct 3 10:56 AM
              On Oct 3, 12:29 pm, "Dan Sharp" <dwsh...@...> wrote:
              > On Fri, Oct 3, 2008 at 5:13 AM, r <r.tr...@...> wrote:
              > > On 3 Ott, 06:47, "Dan Sharp" <dwsh...@...> wrote:
              > >> On Thu, Oct 2, 2008 at 7:55 PM, r <r.tr...@...> wrote:
              >
              > >> > Does anyone knows how to change colours from dull to brilliant in
              > >> > consolle ?
              >
              > >> Maybe
              > >> :set background=dark
              >
              > > My background is already dark, it is not a contrast problem.
              > > Colours are dull, light, in anyway.
              >
              > Read the help for the background option at :help 'background' since I
              > think the first paragraph explains it all:
              >
              >     When set to "dark", Vim will try to use colors that look good on a
              >     dark background.  When set to "light", Vim will try to use colors that
              >     look good on a light background.  Any other value is illegal.
              >     Vim tries to set the default value according to the terminal used.
              >     This will not always be correct.
              >     Setting this option does not change the background color, it tells Vim
              >     what the background color looks like.
              >
              > For example, if you run Vim in a terminal with a black background and
              > the colors are dull (often the dark blue is hard to read against the
              > black background), then you can give the command :set background=dark
              > to tell Vim that it has a dark background and needs to use the
              > brighter colors, such as changing the dark blue font to the brighter
              > cyan color.
              >
              > Anyway, your subsequent post says you found an answer, though I
              > believe it just 'brute forces' the same effect as the command I
              > mentioned.

              The txtfmt plugin doesn't consider background when setting the
              defaults. It simply uses a "safe" set, and expects users who don't
              like the defaults to reconfigure with the txtfmtColor{} array option.
              Note that it is possible for the user to define the colors differently
              according to things like 'background', terminal, operating system, and
              even the current colorscheme. The fix Roberto mentioned was changing
              the default for color terminals from the "Dark" versions of the colors
              (e.g. DarkRed, DarkYellow) to the corresponding color number (e.g., 1,
              3).
              :help cterm-colors

              The advantage of this approach is that it permits both normal and
              bright colors to be used. The normal color is used by default; the
              bright color is used only when the bold format attribute is active.

              Thanks,
              Brett Stahlman
              >
              > Dan
              --~--~---------~--~----~------------~-------~--~----~
              You received this message from the "vim_use" maillist.
              For more information, visit http://www.vim.org/maillist.php
              -~----------~----~----~----~------~----~------~--~---
            Your message has been successfully submitted and would be delivered to recipients shortly.