Loading ...
Sorry, an error occurred while loading the content.
 

Re: Change options

Expand Messages
  • Mr_D
    Sorry for confusion and thanks for answers :) @Tony Mechelynck : Best Answer :) Worked like a charm. @Gary Johnson It works ? You mean for current session ?
    Message 1 of 5 , Sep 9, 2008
      Sorry for confusion and thanks for answers :)

      @Tony Mechelynck :

      Best Answer :) Worked like a charm.

      @Gary Johnson

      It works ? You mean for current session ? That's not what I want.
      Thanks for help links - I used another part of help and there I was
      setting dirs in the option window and then closing and reopening Gvim
      just to see nothing was set. And the help file were

      :help set
      :help bdir
      :help dir

      And there is no mentioning of _vimrc, it's taken for granted.

      @John Beckett

      No, it doesn't set the dir. See tip #20. I have write perm, folder
      exists, bcup is created unfortunately in very same dir (the issue #20
      is addressing).

      A pity vim documentation is not clear at that point - not clear at
      all. When set settings most of the time one wants to change them once
      and for all. Like in tip #20, meant for tidying up the working dir,
      how should I guess its meant for current session ? I spent hours, I
      even opened the _vimrc but it didn't click. No sub for human to human
      communication I guess ::sigh::.

      Is there a way to do this from inside (g)vim ?

      Thanks

      George D.

      PS XP SP3, omg.

      On Sep 9, 3:31 am, "John Beckett" <johnb.beck...@...> wrote:
      > Mr_D wrote:
      > > set backupdir=$VIMRUNTIME\\temp\\
      > > set directory=$VIMRUNTIME\\temp\\
      >
      > > wont set anything
      >
      > Let's just work on one thing for now.
      >
      > You say that 'set backupdir=$VIMRUNTIME\\temp\\' won't set anything.
      >
      > It's not clear what you mean. It certainly should change the 'backupdir' option
      > which you could confirm with:
      >
      > :set backupdir?
      >
      > Perhaps your command DOES set 'backupdir', but you don't get a backup file created?
      >
      > Does the directory name displayed with ':set backupdir?' exist? Do you have write
      > permission to that directory?
      >
      > Assuming "yes", but no backup is created, perhaps it has something to do with a
      > space in the directory name?
      >
      > BTW storing your backups under Vim runtime is rather "unusual". The runtime is
      > generally for Vim stuff only (and is files that don't change in normal use).
      >
      > Also, other users probably have read permission and can see your backups. If you
      > don't care about that, you could try this:
      >
      > :set backupdir=/temp,c:/temp,.
      >
      > which will try directory \temp on the current drive, or C:\temp if problem, or the
      > current directory if problem. The temp directory would need to exist, with suitable
      > permission.
      >
      > The forward slash should work on Windows.
      >
      > John
      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_use" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    Your message has been successfully submitted and would be delivered to recipients shortly.