Loading ...
Sorry, an error occurred while loading the content.
 

Re: key do not erase char in insert mode with putty on HP

Expand Messages
  • PoWah Wong
    ... I downloaded and installed the latest vim, so I am using vim 7.1 on HP. This problem is intermittent (bill lam s email suggested that timeout may be the
    Message 1 of 31 , Jul 2, 2008
      --- On Mon, 6/30/08, Tony Mechelynck <antoine.mechelynck@...> wrote:

      > From: Tony Mechelynck <antoine.mechelynck@...>
      > Subject: Re: <Delete> key do not erase char in insert mode with putty on HP
      > To: vim_use@...
      > Received: Monday, June 30, 2008, 6:00 PM
      > On 30/06/08 23:33, PoWah Wong wrote:
      > >
      > >
      > >
      > > --- On Mon, 6/30/08, Gary
      > Johnson<garyjohn@...> wrote:
      > >
      > >> From: Gary Johnson<garyjohn@...>
      > >> Subject: Re:<Delete> key do not erase char
      > in insert mode with putty on HP
      > >> To: vim_use@...
      > >> Received: Monday, June 30, 2008, 4:49 PM
      > >> On 2008-06-30, PoWah
      > Wong<wong_powah@...> wrote:
      > >>> --- On Mon, 6/30/08, Benjamin Fritz
      > >> <fritzophrenic@...> wrote:
      > >>>> From: Benjamin Fritz
      > >> <fritzophrenic@...>
      > >>>> Subject: Re:<Delete> key do not
      > erase char
      > >> in insert mode with putty on HP
      > >>>> To: vim_use@...
      > >>>> Received: Monday, June 30, 2008, 1:57 PM
      > >>>> On 6/30/08, PoWah Wong
      > >> <wong_powah@...> wrote:
      > >>>>> I ssh to a HP computer with putty
      > running
      > >> on windows.
      > >>>>> The<Delete> key do not erase
      > a
      > >> single char in
      > >>>> insert mode. Instead it change the char
      > from
      > >> upper case to
      > >>>> lower case or vice versa.
      > >>>>> How to fix this?
      > >>>>> I read
      > >>>>> "Mapping keys in Vim -
      > Tutorial"
      > >>>>>
      > >>
      > http://vim.wikia.com/wiki/Mapping_keys_in_Vim_-_Tutorial_%28Part_1%29
      > >>>>> but still do not know what to do.
      > >>>>>
      > >>>>> HP-UX B.11.00 U 9000/785 2003725330
      > >>>>>
      > >>>> First, check what gets inserted when you
      > type, in
      > >> insert
      > >>>> mode:
      > >>>> CTRL-V<Delete>
      > >>>>
      > >>>> It looks like your terminal may be sending
      > >> something like
      > >>>> <ESC>~,
      > >>>> which would show up as ^[~ after you do
      > the
      > >> above, causing
      > >>>> Vim to
      > >>>> leave insert mode (<esc>) and toggle
      > the
      > >> case of the
      > >>>> character under
      > >>>> the cursor (~).
      > >>>>
      > >>>> There are a few ways to fix this; one of
      > them is
      > >> to :set
      > >>>> <Del>=(type,
      > >>>> CTRL-V<Del> as above).
      > >>>>
      > >>>> There may, of course, be better ways to do
      > this.
      > >>>>
      > >>>>
      > >>> CTRL-V<Delete>
      > >>> displays
      > >>> ^[[3~
      > >>>
      > >>> Then what should I do?
      > >>> This does not work:
      > >>> :set<Del>=[[3
      > >>> <Del: No such option - 'set all'
      > gives all
      > >> option values
      > >>
      > >> That should be
      > >>
      > >> :set t_kD=^[[3~
      > >>
      > >> where the ^[ means<Esc>. The easiest way to
      > insert
      > >> that sequence
      > >> after the = is to type Ctrl-v Delete as you did
      > above. See
      > >>
      > >> :help termcap
      > >>
      > >> As someone else wrote, this is really a symptom of
      > a larger
      > >>
      > >> problem--that the terminfo database that vim is
      > using is
      > >> not
      > >> matching the terminal that you are using--that is
      > likely to
      > >> bite you
      > >> again if you don't fix it properly.
      > >>
      > >> Regards,
      > >> Gary
      > >>
      > >>
      > >>
      > > Both failed:
      > > :set t_kD= CTRL-V<Esc>[3~
      > > :set&t_kD= CTRL-V<Esc>[3~
      > >
      > > i.e. for the first one, I typed
      > > ":set t_kD=",
      > > press CTRL-V together,
      > > press<Esc>,
      > > typed "[3~",
      > > press<Enter>.
      > >
      > > for the second one, I typed
      > > ":set&t_kD=",
      > > press CTRL-V together,
      > > press<Esc>,
      > > typed "[3~",
      > > press<Enter>.
      >
      > Again: ARE YOU SURE YOU'RE USING VIM?
      >
      > "Error: "help" not an editor command"
      >
      > in reply to
      >
      >

      >
      > makes me believe you aren't.
      >
      >
      > Best regards,
      > Tony.
      > --
      > If mathematically you end up with the wrong answer, try
      > multiplying by
      > the page number.
      >
      >
      I downloaded and installed the latest vim, so I am using vim 7.1 on HP.
      This problem is intermittent (bill lam's email suggested that timeout may be the cause).
      Another question is that the <Backspace> key behave like a "normal" <Delete> key.
      i.e. Pressing the <Backspace> key erase the current char.
      How to change its behavior to "erase the char before the current char"?



      __________________________________________________________________
      Connect with friends from any web browser - no download required. Try the new Yahoo! Canada Messenger for the Web BETA at http://ca.messenger.yahoo.com/webmessengerpromo.php

      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_use" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • bill lam
      ... It does not need a mouse. press alt-ctrl-f1 to alt-ctrl-f6 to login again. However since x-window is not running, try running vim without x server. eg, vim
      Message 31 of 31 , Jul 4, 2008
        PoWah Wong wrote:
        > The HP had a mouse problem even after replacing with a another mouse so I cannot open a console to use vim.

        It does not need a mouse. press alt-ctrl-f1 to alt-ctrl-f6 to login
        again. However since x-window is not running, try running vim
        without x server. eg,
        vim - X

        regards,

        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_use" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      Your message has been successfully submitted and would be delivered to recipients shortly.