Loading ...
Sorry, an error occurred while loading the content.

Re: vim 7.0

Expand Messages
  • Tony Mechelynck
    ... Your batch file should pass its arguments to gvim. Here is a new version: @echo off set HOME=C: gvim %1 %2 %3 %4 %5 %6 %7 %8 %9 If your gvim.exe is not in
    Message 1 of 36 , Jul 1, 2008
    • 0 Attachment
      On 01/07/08 21:28, awb wrote:
      > The batch file needs the full path name, but my full path name:
      >
      > C:\Program Files\vim\vim70\gvim.exe
      >
      > was problematic due to the space in the path name.
      >
      > Since I needed to upgrade to vim 7.1 anyway, I uninstalled vim 7.0 and
      > installed vim 7.1 in:
      >
      > C:\vim
      >
      > instead of in:
      >
      > C:\Program Files\vim
      >
      > A right mouse click start of vim now runs my batch file, which opens
      > vim, but the file I want to edit doesn't open. I just get the
      > standard vim welcome screen.

      Your batch file should pass its arguments to gvim. Here is a new version:

      @echo off
      set HOME=C:\
      gvim %1 %2 %3 %4 %5 %6 %7 %8 %9


      If your gvim.exe is not in the PATH, add its full path, and if that
      includes spaces, quote it, as in

      "C:\Program Files\Vim\vim71\gvim.exe" %1 %2 %3 %4 %5 %6 %7 %8 %9


      Best regards,
      Tony.
      --
      I am not now, nor have I ever been, a member of the demigodic party.
      -- Dennis Ritchie

      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_use" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • awb
      ... Makes sense. Thanks. --~--~---------~--~----~------------~-------~--~----~ You received this message from the vim_use maillist. For more information,
      Message 36 of 36 , Jul 2, 2008
      • 0 Attachment
        On Jul 2, 8:20 am, "Benjamin Fritz" <fritzophre...@...> wrote:
        > On 7/2/08,awb<awbues...@...> wrote:
        >
        >
        >
        >
        >
        >
        >
        > >  On Jul 1, 2:30 pm, Tony Mechelynck <antoine.mechely...@...>
        > >  wrote:
        >
        > > > On 01/07/08 18:13,awbwrote:
        >
        > >  > > I like this idea.  But ....
        >
        > >  > > I changed the registry entry so that the path is now:
        >
        > >  > > C:\Program Files\Vim\vim70\run_gvim.bat
        >
        > >  > > instead of:
        >
        > >  > > C:\Program Files\Vim\vim70\gvim.exe
        >
        > >  > > run_gvim.bat contains the following:
        > >  > > set HOME=c:\
        > >  > > gvim.exe
        >
        > >  > > When I double click on run_gvim.bat, it works great, but changing the
        > >  > > registry entry and trying to open a vim session using a right mouse
        > >  > > click results in a quick flash of a command prompt window (can't read
        > >  > > what, if anything, is in the window) and nothing else.
        >
        > >  > > Any ideas on how to get this to work?
        >
        > >  > Your run_gvim.bat maybe?
        >
        > >  > Try adding
        >
        > >  >         @echo off
        >
        > >  > (with the @ sign) as its first line.
        >
        > >  > Best regards,
        > >  > Tony.
        > >  > --
        > >  > Higgeldy Piggeldy,
        > >  > Hamlet of Elsinore
        > >  > Ruffled the critics by
        > >  > Dropping this bomb:
        > >  > "Phooey on Freud and his
        > >  > Psychoanalysis --
        > >  > Oedipus, Shmoedipus,
        >
        > > > I just love Mom."- Hide quoted text -
        >
        > >  > - Show quoted text -
        >
        > >  Thanks to everyone for putting up with me learning posting etiquette
        > >  and relatively simple programming.
        >
        > >  I now have a modified registry entry that points to a batch file and
        > >  does exactly what I want.
        >
        > >  The batch file reads:
        > >  @echo off
        > >  set HOME=c:\vim
        > >  c:\vim\vim71\gvim.exe %*
        >
        > >  Writing the last line as:
        > >  c:\vim\vim71\gvim.exe %1 %2 %3 %4 %5 %6 %7 %8 %9
        > >  also worked.
        >
        > >  I didn't have luck with the quotes around the argument identifiers
        > >  though.  I don't seem to be having trouble reading in file names with
        > >  spaces without the quotes so I think I'm good to go.
        >
        > >  This will save me a lot of headaches when undocking my laptop and
        > >  trying to get some work done on the bus on the way home or when I'm
        > >  VPN'd.  Again, thank you all very much!!!!
        >
        > One additional item:
        >
        > $HOME is meant to be a place for user-specific settings. You probably
        > want to put it somewhere appropriate in "C:\Documents and
        > Settings\{your user name}" so that you can place user-specific stuff
        > there.
        >
        > Also, so your customizations won't get blown away by a new install.
        >
        > Since I assume you're the only person using this computer, you could
        > certainly put it elsewhere, but you probably don't want it in the Vim
        > install directory.- Hide quoted text -
        >
        > - Show quoted text -

        Makes sense. Thanks.
        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_use" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      Your message has been successfully submitted and would be delivered to recipients shortly.