Loading ...
Sorry, an error occurred while loading the content.
 

Re: vim 7.0

Expand Messages
  • awb
    The batch file needs the full path name, but my full path name: C: Program Files vim vim70 gvim.exe was problematic due to the space in the path name. Since I
    Message 1 of 36 , Jul 1, 2008
      The batch file needs the full path name, but my full path name:

      C:\Program Files\vim\vim70\gvim.exe

      was problematic due to the space in the path name.

      Since I needed to upgrade to vim 7.1 anyway, I uninstalled vim 7.0 and
      installed vim 7.1 in:

      C:\vim

      instead of in:

      C:\Program Files\vim

      A right mouse click start of vim now runs my batch file, which opens
      vim, but the file I want to edit doesn't open. I just get the
      standard vim welcome screen.



      On Jul 1, 12:22 pm, awb <awbues...@...> wrote:
      > It seems like there's something else going on.
      >
      > I added SLEEP 10 to the end of my batch file and even cleaned out
      > everything but SLEEP 10.
      > I get the 10 second pause when I double click on the batch file, but I
      > dont' when I perform a right click to access this batch file.  I see
      > that there are many other references to gvim.exe in the registry.  Are
      > there more modifications that need to be made in addition to the one
      > mentioned already?
      >
      > On Jul 1, 11:35 am, "Benjamin Fritz" <fritzophre...@...> wrote:
      >
      >
      >
      > > On 7/1/08, Benjamin Fritz <fritzophre...@...> wrote:
      >
      > > > On 7/1/08, awb <awbues...@...> wrote:
      >
      > > >  >  I like this idea.  But ....
      >
      > > >  >  I changed the registry entry so that the path is now:
      >
      > > >  >  C:\Program Files\Vim\vim70\run_gvim.bat
      >
      > > >  >  instead of:
      >
      > > >  >  C:\Program Files\Vim\vim70\gvim.exe
      >
      > > >  >  run_gvim.bat contains the following:
      > > >  >  set HOME=c:\
      > > >  >  gvim.exe
      >
      > > >  >  When I double click on run_gvim.bat, it works great, but changing the
      > > >  >  registry entry and trying to open a vim session using a right mouse
      > > >  >  click results in a quick flash of a command prompt window (can't read
      > > >  >  what, if anything, is in the window) and nothing else.
      >
      > > >  >  Any ideas on how to get this to work?
      >
      > > > General tip for debugging batch files that run and exit like this:
      >
      > > >  Temporarily put a "pause" at the end of the batch file.
      >
      > > >  Or, temporarily put a -f argument to Vim.
      >
      > > >  The particular cause in your case is probably that gvim.exe is not in
      > > >  your path. The default windows installer creates batch files for
      > > >  calling Vim in your path, so you could call those. Or, you could use
      > > >  the full path to Vim. Or, you could put a "cd" to the directory
      > > >  containing Vim at the beginning of your batch file.
      >
      > > Come to think of it, the "-f" won't work if gvim isn't in your path.
      > > I'd try the pause to verify this is the problem (it should be) and
      > > then use one of the suggested methods to fix it.- Hide quoted text -
      >
      > > - Show quoted text -- Hide quoted text -
      >
      > - Show quoted text -
      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_use" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • awb
      ... Makes sense. Thanks. --~--~---------~--~----~------------~-------~--~----~ You received this message from the vim_use maillist. For more information,
      Message 36 of 36 , Jul 2, 2008
        On Jul 2, 8:20 am, "Benjamin Fritz" <fritzophre...@...> wrote:
        > On 7/2/08,awb<awbues...@...> wrote:
        >
        >
        >
        >
        >
        >
        >
        > >  On Jul 1, 2:30 pm, Tony Mechelynck <antoine.mechely...@...>
        > >  wrote:
        >
        > > > On 01/07/08 18:13,awbwrote:
        >
        > >  > > I like this idea.  But ....
        >
        > >  > > I changed the registry entry so that the path is now:
        >
        > >  > > C:\Program Files\Vim\vim70\run_gvim.bat
        >
        > >  > > instead of:
        >
        > >  > > C:\Program Files\Vim\vim70\gvim.exe
        >
        > >  > > run_gvim.bat contains the following:
        > >  > > set HOME=c:\
        > >  > > gvim.exe
        >
        > >  > > When I double click on run_gvim.bat, it works great, but changing the
        > >  > > registry entry and trying to open a vim session using a right mouse
        > >  > > click results in a quick flash of a command prompt window (can't read
        > >  > > what, if anything, is in the window) and nothing else.
        >
        > >  > > Any ideas on how to get this to work?
        >
        > >  > Your run_gvim.bat maybe?
        >
        > >  > Try adding
        >
        > >  >         @echo off
        >
        > >  > (with the @ sign) as its first line.
        >
        > >  > Best regards,
        > >  > Tony.
        > >  > --
        > >  > Higgeldy Piggeldy,
        > >  > Hamlet of Elsinore
        > >  > Ruffled the critics by
        > >  > Dropping this bomb:
        > >  > "Phooey on Freud and his
        > >  > Psychoanalysis --
        > >  > Oedipus, Shmoedipus,
        >
        > > > I just love Mom."- Hide quoted text -
        >
        > >  > - Show quoted text -
        >
        > >  Thanks to everyone for putting up with me learning posting etiquette
        > >  and relatively simple programming.
        >
        > >  I now have a modified registry entry that points to a batch file and
        > >  does exactly what I want.
        >
        > >  The batch file reads:
        > >  @echo off
        > >  set HOME=c:\vim
        > >  c:\vim\vim71\gvim.exe %*
        >
        > >  Writing the last line as:
        > >  c:\vim\vim71\gvim.exe %1 %2 %3 %4 %5 %6 %7 %8 %9
        > >  also worked.
        >
        > >  I didn't have luck with the quotes around the argument identifiers
        > >  though.  I don't seem to be having trouble reading in file names with
        > >  spaces without the quotes so I think I'm good to go.
        >
        > >  This will save me a lot of headaches when undocking my laptop and
        > >  trying to get some work done on the bus on the way home or when I'm
        > >  VPN'd.  Again, thank you all very much!!!!
        >
        > One additional item:
        >
        > $HOME is meant to be a place for user-specific settings. You probably
        > want to put it somewhere appropriate in "C:\Documents and
        > Settings\{your user name}" so that you can place user-specific stuff
        > there.
        >
        > Also, so your customizations won't get blown away by a new install.
        >
        > Since I assume you're the only person using this computer, you could
        > certainly put it elsewhere, but you probably don't want it in the Vim
        > install directory.- Hide quoted text -
        >
        > - Show quoted text -

        Makes sense. Thanks.
        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_use" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      Your message has been successfully submitted and would be delivered to recipients shortly.