Loading ...
Sorry, an error occurred while loading the content.

Re: Problem using fonts

Expand Messages
  • Hossein Movahhedian
    ... No it does not appear anywhere. ... No I can not set it this way. ... Dear Tony, inspired by your replies I could fix the problem for the moment. I have
    Message 1 of 7 , Jun 28, 2008
    • 0 Attachment
      --- On Sat, 6/28/08, Tony Mechelynck <antoine.mechelynck@...> wrote:

      > From: Tony Mechelynck <antoine.mechelynck@...>
      > Subject: Re: Problem using fonts
      > To: vim_use@...
      > Date: Saturday, June 28, 2008, 6:21 AM
      > On 28/06/08 03:37, Hossein Movahhedian wrote:
      > >
      > >
      > >
      > > --- On Sat, 6/28/08, Tony
      > Mechelynck<antoine.mechelynck@...> wrote:
      > >
      > >> From: Tony
      > Mechelynck<antoine.mechelynck@...>
      > >> Subject: Re: Problem using fonts
      > >> To: vim_use@...
      > >> Date: Saturday, June 28, 2008, 5:18 AM
      > >> On 28/06/08 02:17, Hossein Movahhedian wrote:
      > >>> On 26/06/08 18:11, Hossein Movahhedian wrote:
      > >>>>> Hi all,
      > >>>>>
      > >>>>> Recently I downloaded
      > vim-7.1-.tar.bz2,
      > >> vim-7.1-lang.tar.gz,
      > >>>>> vim-7.1-extra.tar.gz and installed
      > Vim-7.1
      > >> successfully. My
      > >>>>> laptop and OS are Dell Inspiron
      > 6400/E1505
      > >> and Slackware 12.1
      > >>>>> (kernel upgraded to 2.6.25.7)
      > respectively.
      > >> Now everything works
      > >>>>> fine except that I can not use my
      > favourite
      > >> fonts. To be
      > >>>>> specific the command `vim -g -fn
      > 6x13
      > >> test.txt&' does not work.
      > >>>>> The file `bugreport.txt' is too
      > large to
      > >> include it here
      > >>>>> (about 100 kB). However below I
      > have listed
      > >> the commands that I
      > >>>>> used to install Vim and the output
      > of
      > >> `:version' command.
      > >>>>> I would gratefully appreciate it if
      > you send
      > >> me a copy of your
      > >>>>> reply.
      > >>>>>
      > >>>>> Thanks
      > >>> On 26/06/08 12:38 AM, Tony Mechelynck wrote:
      > >>>> Gvim should be used with monospace fonts.
      > In the
      > >> GTK2 version only,
      > >>>> setting a non-monospace font is accepted
      > but the
      > >> result is usually ugly.
      > >>>> There are five incompatible formats for
      > the
      > >> 'guifont' option:
      > >>>> - GTK2
      > >>>> - kvim (obsolete)
      > >>>> - Photon
      > >>>> - Other with X11 (such as GTK1, Motif,
      > etc.)
      > >>>> - Other without X11 (such as Windows)
      > >>>>
      > >>>> On some GUIs including Windows, GTK1,
      > GTK2, Mac
      > >> and Photon,
      > >>>> :set guifont=*
      > >>>>
      > >>>> brings up a popup menu where you can
      > select your
      > >> font. You'll see all
      > >>>> the fonts which Vim will accept to set,
      > and that
      > >> sometimes means> quite a
      > >>>> lot!
      > >>>>
      > >>>>
      > >>>> See
      > >>
      > http://vim.wikia.com/wiki/Setting_the_font_in_the_GUI for
      > >> more details.
      > >>> Many thanks for your reply. The above link
      > was very
      > >> useful to me.
      > >>> But I couldn't fix the problem. The
      > problem is
      > >> that the following
      > >>> commands work fine in Vim-6.3 on RedHat-8.0
      > but none
      > >> of them
      > >>> work in Vim-7.1 on Slackware-12.1.
      > >>>
      > >>> vim -g -fn 6x13&
      > >>> vim -g -fn far-a01 test.txt&
      > >>> vim -g -fn far-a01 -F "+set fk"
      > >> test.txt&
      > >>> The above commands did not work on Slackware
      > 12.1 even
      > >> when I
      > >>> downgraded to 6.3.
      > >>>
      > >>> For your information I have listed below
      > some
      > >> variables on Slackware-12.1
      > >>> and RedHat-8.0 when invoking the command
      > `vim -g -fn
      > >> 6x13&'.
      > >>> Slackware-12.1
      > RedHat-8.0
      > >>> :version
      > >>> -xfontset
      > +xfontset
      > >>>
      > >>> :set guioptions=aegimLtTl
      > >> guioptions=agimLtTl
      > >>> termencoding=utf-8
      > >> fileencodings=ucs-bom,utf-8,latin1
      > >>>
      > >>> Yours - Hossein
      > >> Which GUI are you using? What I'm interested
      > in appears
      > >> somewhere near
      > >> the top of the ":version" output,
      > usually in the
      > >> first five lines, in
      > >> any case not later than the words "Features
      > included
      > >> (+) or not (-):".
      > >>
      > >> If your gvim 6.3 was compiled with GTK1 and your
      > gvim 7.1
      > >> with GTK2, the
      > >> format of their 'guifont' is totally
      > different. I
      > >> recommend not setting
      > >> the font on the command-line but in the vimrc, or
      > at the
      > >> keyboard after
      > >> starting gvim; and you'll find in that wiki
      > article a
      > >> code snippet which
      > >> sets 'guifont' according to the GUI
      > flavour in use.
      > >> You may have to
      > >> slightly alter the values if you want a different
      > font face
      > >> or a
      > >> different font size, but at least, if you respect
      > the
      > >> overall 'guifont'
      > >> format which is different for each GUI flavour,
      > you
      > >> won't set something
      > >> invalid.
      > >>
      > >> BTW, on my system, "gvim -fn 6x13&"
      > (without
      > >> the quotes) works at the
      > >> shell prompt. (I find that font face abominably
      > ugly but
      > >> that's a
      > >> different problem.) Here are the first lines of my
      > >> ":version" output:
      > >>
      > >> VIM - Vi IMproved 7.2a BETA (2008 Jun 24, compiled
      > Jun 27
      > >> 2008 22:14:32)
      > >> Included patches: 1-5
      > >> Compiled by antoine.mechelynck@...
      > >> Huge version with GTK2-GNOME GUI. Features
      > included (+) or
      > >> not (-):
      > >>
      > >> Oh, a last thought. On the Slackware system, what
      > does gvim
      > >> answer to
      > >>
      > >> :verbose set guifont?
      > >>
      > > The first four lines of `:version' output for
      > Vim-6.3 on Redhat-8.0 are:
      > >
      > > VIM - Vi IMproved 6.3 (2004 June 7, compiled Mar 17
      > 2005 23:21:52)
      > > Modified by Hossein Movahhedian
      > > Compiled by hossein@localhost
      > > Huge version with GTK GUI. Features included (+) or
      > not (-):
      >
      > GTK1
      >
      > >
      > > The first four lines of `:version' output for
      > Vim-6.3 and Vim-7.1 on
      > > Slackware 12.1 are:
      > > VIM - Vi IMproved 6.3 (2004 June 7, compiled Jun 24
      > 2008 22:27:18)
      > > Modified by Hossein Movahhedian
      > > Compiled by hossein@localhost
      > > Huge version with GTK2 GUI. Features included (+) or
      > not (-):
      > >
      > > Vim-7.1 on Slackware 12.1:
      > > VIM - Vi IMproved 7.1 (2007 May 12, compiled Jun 25
      > 2008 04:26:44)
      > > Modified by Hossein
      > > Compiled by hossein@localhost
      > > Huge version with GTK2 GUI. Features included (+) or
      > not (-):
      >
      > both GTK2
      >
      > All three apparently include changes by you.
      >
      > >
      > >
      > > For the command `vim -g -fn far-a01 -F "+set
      > fk" test.txt&' the answer to
      > > `:verbose set guifont?' is `guifont=far-a01'
      > >
      > > Also for ASCII codes greater than 127 instead of the
      > corresponding character
      > > only a box appears on the screen.
      > >
      > > Yours - Hossein
      >
      > Hm. Does that font appear in the list (probably near the
      > end, since
      No it does not appear anywhere.
      > lowercase letters sort after all uppercase letters
      > including Z)? Can you
      > set it by means of
      >
      > :set guifont=*
      >
      > ?
      No I can not set it this way.
      > Maybe you should add a font size? In GTK2, the font size
      > comes after
      > the name, separated by a backslash-escaped space, like
      > this:
      >
      > :set guifont=Courier\ New\ 10
      >
      > Or maybe that font really doesn't include the glyphs
      > for characters
      > above 127?

      Dear Tony, inspired by your replies I could fix the problem for the moment.
      I have added `--enable-gui=gtk' option to `configure' command. Now
      everything works fine. I am indebted to you for this.
      Thanks a milion for your help.

      Yours - Hossein





      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_use" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    Your message has been successfully submitted and would be delivered to recipients shortly.