Loading ...
Sorry, an error occurred while loading the content.

Re: Persian in Vim

Expand Messages
  • Ali Majdzadeh
    Hello Ben Thanks for your mail. I have checked the :set tenc? option. For Windows it says: termencoding=cp720 Should I try to change it to utf-8? Kind Regards
    Message 1 of 3 , May 4, 2008
    • 0 Attachment
      Hello Ben
      Thanks for your mail. I have checked the :set tenc? option. For Windows it says:
      termencoding=cp720
      Should I try to change it to utf-8?

      Kind Regards
      Ali Majdzadeh Kohbanani

      2008/5/4 Ben Schmidt <mail_ben_schmidt@...>:

      Ali Majdzadeh wrote:
      > Hello All
      > I use Vim in console mode. (Both Linux and Windows) When I want to type
      > in Persian, I just see some junk characters. I have set the following
      > configurations:
      > :set keymap=persian
      > :set encoding=utf-8
      > :set rightleft

      They look good. The problem is most likely that your terminal does not support
      utf-8, or isn't in a utf-8 mode, or Vim's tenc option is wrong. Check what

      :set tenc?

      says, and check the settings/read the docs/check your locale for the terminal you
      are using. If you can do 'cat somefile' of a utf-8 file and have it print
      correctly, that is probably a fairly good indication that your terminal is
      correctly set up.

      Of course, you don't necessarily need to use the terminal in utf-8--you could use
      some other encoding that supports Persian. But these days utf-8 is usually easier.

      Cheers,

      Ben.








      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_use" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---

    Your message has been successfully submitted and would be delivered to recipients shortly.