Loading ...
Sorry, an error occurred while loading the content.

Vim on Vista: right-click 'Edit with Vim' problem

Expand Messages
  • Simon
    Hi all, I m using Gvim on Windows Vista. I originally had Vim installed in C: Program Files Vim but after getting annoyed with Vista not allowing me to
    Message 1 of 14 , Apr 12, 2008
    • 0 Attachment
      Hi all,

      I'm using Gvim on Windows Vista. I originally had Vim installed in 'C:
      \Program Files\Vim' but after getting annoyed with Vista not allowing
      me to change the _vimrc file without moving it to the 'virtual store',
      I decided to uninstall and reinstall in 'C:\Vim'.

      But since doing that, when I try to open a file by right-clicking and
      selecting 'Edit with Vim', I get:
      "gvimext.dll error Error creating process: Check if gvim is in your
      path!"

      I do have "C:\Vim\vim71\" in my path.

      Anyone have any suggestions?

      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_use" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • Tony Mechelynck
      ... On Vista, logging in to an admin account doesn t automatically give you admin privileges. You have to get these in addition. Maybe that s why you couldn t
      Message 2 of 14 , Apr 12, 2008
      • 0 Attachment
        On 12/04/08 11:40, Simon wrote:
        > Hi all,
        >
        > I'm using Gvim on Windows Vista. I originally had Vim installed in 'C:
        > \Program Files\Vim' but after getting annoyed with Vista not allowing
        > me to change the _vimrc file without moving it to the 'virtual store',
        > I decided to uninstall and reinstall in 'C:\Vim'.
        >
        > But since doing that, when I try to open a file by right-clicking and
        > selecting 'Edit with Vim', I get:
        > "gvimext.dll error Error creating process: Check if gvim is in your
        > path!"
        >
        > I do have "C:\Vim\vim71\" in my path.
        >
        > Anyone have any suggestions?

        On Vista, logging in to an admin account doesn't automatically give you
        admin privileges. You have to get these in addition. Maybe that's why
        you couldn't install to Program Files.

        Best regards,
        Tony.
        --
        One of my less pleasant chores when I was young was to read the Bible
        from one end to the other. Reading the Bible straight through is at
        least 70 percent discipline, like learning Latin. But the good parts
        are, of course, simply amazing. God is an extremely uneven writer, but
        when He's good, nobody can touch Him.
        -- John Gardner, NYT Book Review, Jan 1983

        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_use" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      • Patrick Texier
        ... And patch 282 had some fixes: Win64: Edit with Vim context menu isn t installed correctly. Compiler warnings and a few other things. . -- Patrick Texier
        Message 3 of 14 , Apr 12, 2008
        • 0 Attachment
          On Sat, 12 Apr 2008 11:50:05 +0200, Tony Mechelynck wrote:

          > > Anyone have any suggestions?
          >
          > On Vista, logging in to an admin account doesn't automatically give you
          > admin privileges. You have to get these in addition. Maybe that's why
          > you couldn't install to Program Files.

          And patch 282 had some fixes: "Win64: Edit with Vim context menu isn't
          installed correctly. Compiler warnings and a few other things.".
          --
          Patrick Texier

          vim:syntax=mail:ai:ts=4:et:tw=72

          --~--~---------~--~----~------------~-------~--~----~
          You received this message from the "vim_use" maillist.
          For more information, visit http://www.vim.org/maillist.php
          -~----------~----~----~----~------~----~------~--~---
        • John Beckett
          ... We have two slightly dodgy tips on Vista: http://vim.wikia.com/wiki/Vim_On_Vista http://vim.wikia.com/wiki/VirtualStore Amazingly, someone just edited the
          Message 4 of 14 , Apr 12, 2008
          • 0 Attachment
            Simon wrote:
            > I'm using Gvim on Windows Vista...
            > I get: "gvimext.dll error Error creating process:
            > Check if gvim is in your path!"

            We have two slightly dodgy tips on Vista:
            http://vim.wikia.com/wiki/Vim_On_Vista
            http://vim.wikia.com/wiki/VirtualStore

            Amazingly, someone just edited the first tip in the section "Shell Extension" which
            discusses exactly your problem.

            We really need some Vista users to clean these tips up because they each recommend
            some truly scary things with no specified reasons (however, the particular issue in
            this thread looks fine).

            John


            --~--~---------~--~----~------------~-------~--~----~
            You received this message from the "vim_use" maillist.
            For more information, visit http://www.vim.org/maillist.php
            -~----------~----~----~----~------~----~------~--~---
          • Simon
            Tony, Patrick, John Thanks for your replies. I came across the wiki shortly after posting (seems always the way). My problem was indeed that I had Run as
            Message 5 of 14 , Apr 13, 2008
            • 0 Attachment
              Tony, Patrick, John

              Thanks for your replies. I came across the wiki shortly after posting
              (seems always the way). My problem was indeed that I had 'Run as
              administrator set' for gvim. (It was me that edited the tip in the
              wiki, btw, to add a bit more info - no big coincidence after all!)

              Thanks for your help, S

              On 12 Apr, 12:26, "John Beckett" <johnb.beck...@...> wrote:
              > Simon wrote:
              > > I'm using Gvim on Windows Vista...
              > > I get: "gvimext.dll error Error creating process:
              > > Check if gvim is in your path!"
              >
              > We have two slightly dodgy tips on Vista:
              > http://vim.wikia.com/wiki/Vim_On_Vista
              > http://vim.wikia.com/wiki/VirtualStore
              >
              > Amazingly, someone just edited the first tip in the section "Shell Extension" which
              > discusses exactly your problem.
              >
              > We really need some Vista users to clean these tips up because they each recommend
              > some truly scary things with no specified reasons (however, the particular issue in
              > this thread looks fine).
              >
              > John
              --~--~---------~--~----~------------~-------~--~----~
              You received this message from the "vim_use" maillist.
              For more information, visit http://www.vim.org/maillist.php
              -~----------~----~----~----~------~----~------~--~---
            • John Beckett
              ... Thanks Simon. Please drop by the wiki some more. John --~--~---------~--~----~------------~-------~--~----~ You received this message from the vim_use
              Message 6 of 14 , Apr 13, 2008
              • 0 Attachment
                Simon wrote:
                > Thanks for your replies. I came across the wiki shortly
                > after posting (seems always the way). My problem was indeed
                > that I had 'Run as administrator set' for gvim. (It was me
                > that edited the tip in the wiki, btw, to add a bit more info
                > - no big coincidence after all!)

                Thanks Simon. Please drop by the wiki some more.

                John


                --~--~---------~--~----~------------~-------~--~----~
                You received this message from the "vim_use" maillist.
                For more information, visit http://www.vim.org/maillist.php
                -~----------~----~----~----~------~----~------~--~---
              • emallove
                ... I ran into the same problem. A workaround is to start a new Vim process and then use Edit with existing Vim (see attached). -Ethan -- You received this
                Message 7 of 14 , Jul 12, 2012
                • 0 Attachment
                  > ... when I try to open a file by right-clicking and
                  > selecting 'Edit with Vim', I get:
                  > "gvimext.dll error Error creating process: Check if gvim is in your
                  > path!"
                  >
                  > I do have "C:\Vim\vim71\" in my path.
                  >
                  > Anyone have any suggestions?

                  I ran into the same problem. A workaround is to start a new Vim process and then use "Edit with existing Vim" (see attached).

                  -Ethan

                  --
                  You received this message from the "vim_use" maillist.
                  Do not top-post! Type your reply below the text you are replying to.
                  For more information, visit http://www.vim.org/maillist.php
                • Leszek Świrski
                  In case anyone else has the same problem, I fixed it by fixing my gvim path in HKLM SOFTWARE Vim Gvim (It was set to vim72, I had vim73) -- You received this
                  Message 8 of 14 , Jul 31, 2012
                  • 0 Attachment
                    In case anyone else has the same problem, I fixed it by fixing my gvim path in
                    HKLM\SOFTWARE\Vim\Gvim
                    (It was set to vim72, I had vim73)

                    --
                    You received this message from the "vim_use" maillist.
                    Do not top-post! Type your reply below the text you are replying to.
                    For more information, visit http://www.vim.org/maillist.php
                  • David Fishburn
                    ... Which installer did you run to install Vim 7.3? -- David Fishburn -- You received this message from the vim_use maillist. Do not top-post! Type your
                    Message 9 of 14 , Jul 31, 2012
                    • 0 Attachment
                      On Jul 31, 2012, at 6:16 AM, Leszek Świrski <leszek.swirski@...> wrote:

                      > In case anyone else has the same problem, I fixed it by fixing my gvim path in
                      > HKLM\SOFTWARE\Vim\Gvim
                      > (It was set to vim72, I had vim73)
                      >

                      Which installer did you run to install Vim 7.3?

                      --
                      David Fishburn

                      --
                      You received this message from the "vim_use" maillist.
                      Do not top-post! Type your reply below the text you are replying to.
                      For more information, visit http://www.vim.org/maillist.php
                    • Leszek Świrski
                      ... Cream without Vim, although I can t recall if I was upgrading from 7.2 or not. -- You received this message from the vim_use maillist. Do not top-post!
                      Message 10 of 14 , Aug 1, 2012
                      • 0 Attachment
                        > Which installer did you run to install Vim 7.3?

                        Cream without Vim, although I can't recall if I was upgrading from 7.2 or not.

                        --
                        You received this message from the "vim_use" maillist.
                        Do not top-post! Type your reply below the text you are replying to.
                        For more information, visit http://www.vim.org/maillist.php
                      • Steve Hall
                        ... The Cream installer writes the new install path to that registry location, not sure how the old one could have not been revised unless the Nullsoft
                        Message 11 of 14 , Aug 1, 2012
                        • 0 Attachment
                          On Wed, Aug 1, 2012 at 6:48 AM, Leszek Swirski <leszek.swirski@...> wrote:
                          > > Which installer did you run to install Vim 7.3?
                          >
                          > Cream without Vim, although I can't recall if I was upgrading from 7.2 or not.

                          The Cream installer writes the new install path to that registry
                          location, not sure how the old one could have not been revised unless
                          the Nullsoft WriteRegStr instruction doesn't do this?

                          --
                          Steve Hall [ digitect dancingpaper com ]
                          :: Cream for Vim (http://cream.sourceforge.net)

                          --
                          You received this message from the "vim_use" maillist.
                          Do not top-post! Type your reply below the text you are replying to.
                          For more information, visit http://www.vim.org/maillist.php
                        • David Fishburn
                          ... Steve, sorry for not posting this earlier. When I setup my new Windows 7 64bit I used the Cream installer for basic Vim. I did a pile of searching trying
                          Message 12 of 14 , Aug 1, 2012
                          • 0 Attachment
                            On Aug 1, 2012, at 8:52 AM, Steve Hall <digitect@...> wrote:

                            > On Wed, Aug 1, 2012 at 6:48 AM, Leszek Swirski <leszek.swirski@...> wrote:
                            >>> Which installer did you run to install Vim 7.3?
                            >>
                            >> Cream without Vim, although I can't recall if I was upgrading from 7.2 or not.
                            >
                            > The Cream installer writes the new install path to that registry
                            > location, not sure how the old one could have not been revised unless
                            > the Nullsoft WriteRegStr instruction doesn't do this?
                            >
                            > --
                            > Steve Hall [ digitect dancingpaper com ]
                            > :: Cream for Vim (http://cream.sourceforge.net)
                            >

                            Steve, sorry for not posting this earlier.

                            When I setup my new Windows 7 64bit I used the Cream installer for basic Vim.

                            I did a pile of searching trying to determine why since the registry looked correct.

                            Anyway, as a different test I ran the Vim installer and everything worked correctly. Then I re-ran the Cream installer to get an updated version and everything has worked fine since.

                            --
                            David Fishburn

                            --
                            You received this message from the "vim_use" maillist.
                            Do not top-post! Type your reply below the text you are replying to.
                            For more information, visit http://www.vim.org/maillist.php
                          • Gary Johnson
                            ... I use the Cream without Cream version of Vim on my Windows XP machine at work and usually keep it updated to the latest release on the Cream site. I
                            Message 13 of 14 , Aug 1, 2012
                            • 0 Attachment
                              On 2012-08-01, David Fishburn wrote:
                              > On Aug 1, 2012, at 8:52 AM, Steve Hall wrote:
                              >
                              > > On Wed, Aug 1, 2012 at 6:48 AM, Leszek Swirski wrote:
                              > >>> Which installer did you run to install Vim 7.3?
                              > >>
                              > >> Cream without Vim, although I can't recall if I was upgrading from 7.2 or not.
                              > >
                              > > The Cream installer writes the new install path to that registry
                              > > location, not sure how the old one could have not been revised unless
                              > > the Nullsoft WriteRegStr instruction doesn't do this?
                              > >
                              > > --
                              > > Steve Hall [ digitect dancingpaper com ]
                              > > :: Cream for Vim (http://cream.sourceforge.net)
                              > >
                              >
                              > Steve, sorry for not posting this earlier.
                              >
                              > When I setup my new Windows 7 64bit I used the Cream installer for
                              > basic Vim.
                              >
                              > I did a pile of searching trying to determine why since the
                              > registry looked correct.
                              >
                              > Anyway, as a different test I ran the Vim installer and everything
                              > worked correctly. Then I re-ran the Cream installer to get an
                              > updated version and everything has worked fine since.

                              I use the Cream without Cream version of Vim on my Windows XP
                              machine at work and usually keep it updated to the latest release on
                              the Cream site. I haven't kept careful track, but it seems that
                              after every maybe third installation, the Vim commands disappear
                              from the Windows Explorer context menu. Running the installer again
                              has always fixed the problem.

                              Regards,
                              Gary

                              --
                              You received this message from the "vim_use" maillist.
                              Do not top-post! Type your reply below the text you are replying to.
                              For more information, visit http://www.vim.org/maillist.php
                            • emallove
                              ... My workaround is to start a gvim.exe process, then use the right click menu option Edit with existing Vim . This way Windows isn t tasked with finding my
                              Message 14 of 14 , Jun 3, 2013
                              • 0 Attachment
                                On Saturday, April 12, 2008 5:40:13 AM UTC-4, Simon wrote:
                                > Hi all,
                                >
                                >
                                >
                                > I'm using Gvim on Windows Vista. I originally had Vim installed in 'C:
                                >
                                > \Program Files\Vim' but after getting annoyed with Vista not allowing
                                >
                                > me to change the _vimrc file without moving it to the 'virtual store',
                                >
                                > I decided to uninstall and reinstall in 'C:\Vim'.
                                >
                                >
                                >
                                > But since doing that, when I try to open a file by right-clicking and
                                >
                                > selecting 'Edit with Vim', I get:
                                >
                                > "gvimext.dll error Error creating process: Check if gvim is in your
                                >
                                > path!"
                                >
                                >
                                >
                                > I do have "C:\Vim\vim71\" in my path.
                                >
                                >
                                >
                                > Anyone have any suggestions?

                                My workaround is to start a gvim.exe process, then use the right click menu option "Edit with existing Vim". This way Windows isn't tasked with finding my gvim.exe executable.

                                -Ethan

                                --
                                --
                                You received this message from the "vim_use" maillist.
                                Do not top-post! Type your reply below the text you are replying to.
                                For more information, visit http://www.vim.org/maillist.php

                                ---
                                You received this message because you are subscribed to the Google Groups "vim_use" group.
                                To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
                                For more options, visit https://groups.google.com/groups/opt_out.
                              Your message has been successfully submitted and would be delivered to recipients shortly.