Loading ...
Sorry, an error occurred while loading the content.

Omnicompletion

Expand Messages
  • epanda
    Is is mentionned in the help and I have set my variable of omnicompletion like that n my vimrc but it fails to complete :
    Message 1 of 4 , Apr 1, 2008
    • 0 Attachment
      Is is mentionned in the help and I have set my variable of
      omnicompletion like that n my vimrc but it fails to complete :

      """"""""""""""""""""""""""""""""""""""""""""""""""""
      "
      " OmniCpp
      "
      """"""""""""""""""""""""""""""""""""""""""""""""""""
      let OmniCpp_GlobalScopeSearch = 1
      let OmniCpp_NamespaceSearch = 0
      let OmniCpp_DisplayMode = 0
      let OmniCpp_ShowScopeInAbbr = 0
      let OmniCpp_ShowPrototypeInAbbr = 0

      Here is my directory de D:\Dev
      31/03/2008 23:05 1 356 688 ID
      31/03/2008 23:15 13 344 120 tags <<<< My
      database tags is good


      When I do a tselect it displays only concstructor and destructor and
      fogot a method of the class.
      That's why, I suppose the completion fails after.
      Any Idea.

      Thanks epanda



      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_use" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • Vissale NEANG
      Hi epanda, If the function does not appear in the tag file, the completion of this function won t work. ...
      Message 2 of 4 , Apr 1, 2008
      • 0 Attachment
        Hi epanda,

        If the function does not appear in the tag file, the completion of
        this function won't work.

        2008/4/1, epanda <callingelvis@...>:
        >
        > Is is mentionned in the help and I have set my variable of
        > omnicompletion like that n my vimrc but it fails to complete :
        >
        > """"""""""""""""""""""""""""""""""""""""""""""""""""
        > "
        > " OmniCpp
        > "
        > """"""""""""""""""""""""""""""""""""""""""""""""""""
        > let OmniCpp_GlobalScopeSearch = 1
        > let OmniCpp_NamespaceSearch = 0
        > let OmniCpp_DisplayMode = 0
        > let OmniCpp_ShowScopeInAbbr = 0
        > let OmniCpp_ShowPrototypeInAbbr = 0
        >
        > Here is my directory de D:\Dev
        > 31/03/2008 23:05 1 356 688 ID
        > 31/03/2008 23:15 13 344 120 tags <<<< My
        > database tags is good
        >
        >
        > When I do a tselect it displays only concstructor and destructor and
        > fogot a method of the class.
        > That's why, I suppose the completion fails after.
        > Any Idea.
        >
        > Thanks epanda
        >
        >
        >
        > >
        >

        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_use" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      • Guy Rutenberg
        Hi epanda, ... Every time you add new function you need to regenerate you tags file. Are you sure the tag file is updated? Regards, Guy ...
        Message 3 of 4 , Apr 1, 2008
        • 0 Attachment
          Hi epanda,

          > 2008/4/1, epanda <callingel...@...>:

          > > 31/03/2008 23:15 13 344 120 tags <<<< My
          > > database tags is good

          Every time you add new function you need to regenerate you tags file.
          Are you sure the tag file is updated?

          Regards,
          Guy

          ----
          http://www.guyrutenberg.com/
          --~--~---------~--~----~------------~-------~--~----~
          You received this message from the "vim_use" maillist.
          For more information, visit http://www.vim.org/maillist.php
          -~----------~----~----~----~------~----~------~--~---
        • epanda
          Yeah I am sure to update the tags base file. There is another problem. Anyone of you can send me his hotmail in order to work directly with messenger. Thanks.
          Message 4 of 4 , Apr 1, 2008
          • 0 Attachment
            Yeah I am sure to update the tags base file.
            There is another problem.

            Anyone of you can send me his hotmail in order to work directly with
            messenger.

            Thanks.

            On 1 avr, 13:48, Guy Rutenberg <guyrutenb...@...> wrote:
            > Hi epanda,
            >
            > > 2008/4/1, epanda <callingel...@...>:
            > > >  31/03/2008  23:15        13 344 120 tags                    <<<< My
            > > >  database tags is good
            >
            > Every time you add new function you need to regenerate you tags file.
            > Are you sure the tag file is updated?
            >
            > Regards,
            > Guy
            >
            > ----http://www.guyrutenberg.com/
            --~--~---------~--~----~------------~-------~--~----~
            You received this message from the "vim_use" maillist.
            For more information, visit http://www.vim.org/maillist.php
            -~----------~----~----~----~------~----~------~--~---
          Your message has been successfully submitted and would be delivered to recipients shortly.