Loading ...
Sorry, an error occurred while loading the content.

Re: Changing cursor color in (non-GUI) vim

Expand Messages
  • Bernhard Walle
    Hello Mika, ... I think this is not possible. You have to change the cursor color in the terminal application. Which terminal do you use? For example it s
    Message 1 of 2 , Feb 2, 2008
    • 0 Attachment
      Hello Mika,

      * Mika Fischer <mf+vim@...> [2008-02-02 23:16]:
      >
      > is it possible to change vim's cursor color when using the terminal
      > version of vim?

      I think this is not possible. You have to change the cursor color in
      the terminal application. Which terminal do you use? For example it's
      simple to change the cursor color in xterm by setting a X
      ressource (in the file ~/.Xdefaults or ~/.Xresources):

      XTerm*cursorColor: #FFFF42

      Or for rxvt-unicode:

      URxvt.cursorColor: darkblue

      GNOME and KDE should have GUI settings.


      Bernhard
      --
      "Der Mensch erfand die Atombombe, doch keine Maus der Welt w├╝rde eine
      Mausefalle konstruieren."
      -- Albert Einstein

      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_use" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • Mika Fischer
      ... Ah, thanks for the hint. This almost works, in that it works for every cursor color except Black (I m using a black on white terminal). When I set
      Message 2 of 2 , Feb 3, 2008
      • 0 Attachment
        * Bernhard Walle <bernhard.walle@...> [2008-02-02 23:29]:
        > * Mika Fischer <mf+vim@...> [2008-02-02 23:16]:
        > > is it possible to change vim's cursor color when using the terminal
        > > version of vim?
        >
        > I think this is not possible. You have to change the cursor color in
        > the terminal application. Which terminal do you use? For example it's
        > simple to change the cursor color in xterm by setting a X
        > ressource (in the file ~/.Xdefaults or ~/.Xresources):
        >
        > XTerm*cursorColor: #FFFF42

        Ah, thanks for the hint. This almost works, in that it works for every
        cursor color except Black (I'm using a black on white terminal). When I
        set cursorColor to Black, it behaves just as before, always reversing
        foreground and background. A simple workaround is to use Gray1, which is
        almost black.

        > GNOME and KDE should have GUI settings.

        Actually I'm using gnome-terminal, but the cursor color is not
        configurable there. Maybe I'll switch to xterm. The one thing that keeps
        me using gnome-terminal is that I can right-click on links and open them
        in my browser, which I use extensively and would miss in xterm.

        I guess you just can't have everything...

        Thanks a lot for the info!

        Best regards,
        Mika

        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_use" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      Your message has been successfully submitted and would be delivered to recipients shortly.