Loading ...
Sorry, an error occurred while loading the content.

vim7 xml/docbook spellcheck : comments only ?

Expand Messages
  • haron
    Hi All, Using :setlocal spell spellang=en_US (as advised from :help spell- quickstart) I get with following example docbook: ... (A)sistem is
    Message 1 of 3 , Feb 1 4:17 AM
    • 0 Attachment
      Hi All,

      Using ":setlocal spell spellang=en_US" (as advised from :help spell-
      quickstart) I get with following example docbook:
      ...
      <!-- <para> (A)sistem is wrong, system is right <para> -->
      <para> (B)sistem is wrong, system is right <para>
      ...
      (A) highlighted as spelling error, but not (B).

      Settings are:
      :set filetype syntax
      filetype=xml
      syntax=docbk

      I have tried with ":set filetype=text", (after that syntax is set to
      "syntax=text" automatically), but in this case I obviously loose
      syntax highlighting and closing tag matching for DocBook / XML.

      Anybody knows how to keep docbk + xml syntax features enabled, still
      having (A) and (B) recognized as spell errors ?
      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_use" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • A.Politz
      ... Try ... -ap -- Ich hab geträumt, der Krieg wär vorbei. --~--~---------~--~----~------------~-------~--~----~ You received this message from the vim_use
      Message 2 of 3 , Feb 1 6:15 AM
      • 0 Attachment
        haron wrote:

        >Hi All,
        >
        >Using ":setlocal spell spellang=en_US" (as advised from :help spell-
        >quickstart) I get with following example docbook:
        >...
        > <!-- <para> (A)sistem is wrong, system is right <para> -->
        > <para> (B)sistem is wrong, system is right <para>
        >...
        >(A) highlighted as spelling error, but not (B).
        >
        >Settings are:
        >:set filetype syntax
        > filetype=xml
        > syntax=docbk
        >
        >I have tried with ":set filetype=text", (after that syntax is set to
        >"syntax=text" automatically), but in this case I obviously loose
        >syntax highlighting and closing tag matching for DocBook / XML.
        >
        >Anybody knows how to keep docbk + xml syntax features enabled, still
        >having (A) and (B) recognized as spell errors ?
        >
        >
        Try
        :syn spell toplevel
        :redraw

        -ap



        --
        Ich hab geträumt, der Krieg wär vorbei.


        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_use" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      • A.Politz
        ... works for me and is what I was actually going to suggest. -ap -- Ich hab geträumt, der Krieg wär vorbei.
        Message 3 of 3 , Feb 1 12:02 PM
        • 0 Attachment
          haron wrote:

          >Aha ":redraw" - thats were missing part !
          >
          >I have tried ":syn spell toplevel" already before, really !
          >
          >BTW, on both my windows / linux boxes ":redraw" seams not to work
          >(both are running gvim 7.1, linux is huge GTK2 version), but 2<C-F>2<C-
          >B> does the magic - so your main idea were completely correct :)
          >
          >Thanks !
          >>
          >
          >
          <C-L> works for me and is what I was actually going to suggest.

          -ap

          --
          Ich hab geträumt, der Krieg wär vorbei.


          --~--~---------~--~----~------------~-------~--~----~
          You received this message from the "vim_use" maillist.
          For more information, visit http://www.vim.org/maillist.php
          -~----------~----~----~----~------~----~------~--~---
        Your message has been successfully submitted and would be delivered to recipients shortly.