Loading ...
Sorry, an error occurred while loading the content.

thesaurus completion

Expand Messages
  • Manu Hack
    Hi, I ve set the tsr to a file but I still couldn t use the completion function via control x control t in insert mode. Just make it simple I have made a test
    Message 1 of 6 , Dec 2, 2007
    • 0 Attachment
      Hi,

      I've set the tsr to a file but I still couldn't use the completion
      function via control x control t in insert mode.

      Just make it simple I have made a test file

      testth.txt
      with one line

      hi hello

      Then in other file I have

      :set tsr=/path/to/testth.txt

      After typing hi and control x, I couldn't find the ^t option. What am
      I missing there? And I think I couldn't find the FAQ in the website
      listed in :h tsr --- the link seems to be broken.

      Thanks,
      Manu

      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_use" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • Bill McCarthy
      ... I agree that there is no ^t after typing ^x. Nonetheless, hitting ^x^t after ihi produced two choices: hi and hello. ... The line to
      Message 2 of 6 , Dec 2, 2007
      • 0 Attachment
        On Sun 2-Dec-07 4:49am -0600, Manu Hack wrote:

        > I've set the tsr to a file but I still couldn't use the completion
        > function via control x control t in insert mode.
        >
        > Just make it simple I have made a test file
        >
        > testth.txt
        > with one line
        >
        > hi hello
        >
        > Then in other file I have
        >
        > :set tsr=/path/to/testth.txt
        >
        > After typing hi and control x, I couldn't find the ^t option. What am
        > I missing there?

        I agree that there is no ^t after typing ^x. Nonetheless,
        hitting ^x^t after ihi produced two choices: hi and hello.

        > And I think I couldn't find the FAQ in the website
        > listed in :h tsr --- the link seems to be broken.

        The line to http://www.hyphenologist.co.uk worked fine here.

        --
        Best regards,
        Bill


        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_use" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      • Manu Hack
        ... I can only get it work on gvim but not vim. Still trying to figure out why. ... But can you go to the wordlist FAQ as suggested in the help doc? Manu
        Message 3 of 6 , Dec 2, 2007
        • 0 Attachment
          On Dec 2, 2007 12:21 PM, Bill McCarthy <WJMc@...> wrote:
          >
          > On Sun 2-Dec-07 4:49am -0600, Manu Hack wrote:
          >
          > > I've set the tsr to a file but I still couldn't use the completion
          > > function via control x control t in insert mode.
          > >
          > > Just make it simple I have made a test file
          > >
          > > testth.txt
          > > with one line
          > >
          > > hi hello
          > >
          > > Then in other file I have
          > >
          > > :set tsr=/path/to/testth.txt
          > >
          > > After typing hi and control x, I couldn't find the ^t option. What am
          > > I missing there?
          >
          > I agree that there is no ^t after typing ^x. Nonetheless,
          > hitting ^x^t after ihi produced two choices: hi and hello.

          I can only get it work on gvim but not vim. Still trying to figure out why.

          >
          > > And I think I couldn't find the FAQ in the website
          > > listed in :h tsr --- the link seems to be broken.
          >
          > The line to http://www.hyphenologist.co.uk worked fine here.

          But can you go to the wordlist FAQ as suggested in the help doc?

          Manu

          --~--~---------~--~----~------------~-------~--~----~
          You received this message from the "vim_use" maillist.
          For more information, visit http://www.vim.org/maillist.php
          -~----------~----~----~----~------~----~------~--~---
        • Tony Mechelynck
          ... Maybe your Console vim doesn t support thesaurus? Check the output of :version for both (and see :help :redir about how to save that output for e.g.
          Message 4 of 6 , Dec 2, 2007
          • 0 Attachment
            Manu Hack wrote:
            > On Dec 2, 2007 12:21 PM, Bill McCarthy <WJMc@...> wrote:
            >> On Sun 2-Dec-07 4:49am -0600, Manu Hack wrote:
            >>
            >>> I've set the tsr to a file but I still couldn't use the completion
            >>> function via control x control t in insert mode.
            >>>
            >>> Just make it simple I have made a test file
            >>>
            >>> testth.txt
            >>> with one line
            >>>
            >>> hi hello
            >>>
            >>> Then in other file I have
            >>>
            >>> :set tsr=/path/to/testth.txt
            >>>
            >>> After typing hi and control x, I couldn't find the ^t option. What am
            >>> I missing there?
            >> I agree that there is no ^t after typing ^x. Nonetheless,
            >> hitting ^x^t after ihi produced two choices: hi and hello.
            >
            > I can only get it work on gvim but not vim. Still trying to figure out why.
            >

            Maybe your Console vim doesn't support thesaurus? Check the output of
            ":version" for both (and see ":help :redir" about how to save that output for
            e.g. pasting into an email).

            Best regards,
            Tony.
            --
            "He's just a politician trying to save both his faces ..."


            --~--~---------~--~----~------------~-------~--~----~
            You received this message from the "vim_use" maillist.
            For more information, visit http://www.vim.org/maillist.php
            -~----------~----~----~----~------~----~------~--~---
          • Manu Hack
            ... Thanks, I finally figured out the problem was the key binding conflict with screen. Sorry for the noise. By the way, is there an easy way to find a word
            Message 5 of 6 , Dec 2, 2007
            • 0 Attachment
              On Dec 2, 2007 6:01 PM, Tony Mechelynck <antoine.mechelynck@...> wrote:
              >
              > Manu Hack wrote:
              > > On Dec 2, 2007 12:21 PM, Bill McCarthy <WJMc@...> wrote:
              > >> On Sun 2-Dec-07 4:49am -0600, Manu Hack wrote:
              > >>
              > >>> I've set the tsr to a file but I still couldn't use the completion
              > >>> function via control x control t in insert mode.
              > >>>
              > >>> Just make it simple I have made a test file
              > >>>
              > >>> testth.txt
              > >>> with one line
              > >>>
              > >>> hi hello
              > >>>
              > >>> Then in other file I have
              > >>>
              > >>> :set tsr=/path/to/testth.txt
              > >>>
              > >>> After typing hi and control x, I couldn't find the ^t option. What am
              > >>> I missing there?
              > >> I agree that there is no ^t after typing ^x. Nonetheless,
              > >> hitting ^x^t after ihi produced two choices: hi and hello.
              > >
              > > I can only get it work on gvim but not vim. Still trying to figure out why.
              > >
              >
              > Maybe your Console vim doesn't support thesaurus? Check the output of
              > ":version" for both (and see ":help :redir" about how to save that output for
              > e.g. pasting into an email).

              Thanks, I finally figured out the problem was the key binding conflict
              with screen. Sorry for the noise.

              By the way, is there an easy way to find a word file online?

              Manu

              --~--~---------~--~----~------------~-------~--~----~
              You received this message from the "vim_use" maillist.
              For more information, visit http://www.vim.org/maillist.php
              -~----------~----~----~----~------~----~------~--~---
            • sc
              ... i got mine at http://www.dcs.shef.ac.uk/research/ilash/Moby/ sc ... --~--~---------~--~----~------------~-------~--~----~ You received this message from
              Message 6 of 6 , Dec 2, 2007
              • 0 Attachment
                On Sunday 02 December 2007 18:19, Manu Hack wrote:
                > On Dec 2, 2007 6:01 PM, Tony Mechelynck
                <antoine.mechelynck@...> wrote:
                > > Manu Hack wrote:
                > > > On Dec 2, 2007 12:21 PM, Bill McCarthy <WJMc@...>
                wrote:
                > > >> On Sun 2-Dec-07 4:49am -0600, Manu Hack wrote:
                > > >>> I've set the tsr to a file but I still couldn't use
                > > >>> the completion function via control x control t in
                > > >>> insert mode.
                > > >>>
                > > >>> Just make it simple I have made a test file
                > > >>>
                > > >>> testth.txt
                > > >>> with one line
                > > >>>
                > > >>> hi hello
                > > >>>
                > > >>> Then in other file I have
                > > >>>
                > > >>> :set tsr=/path/to/testth.txt
                > > >>>
                > > >>> After typing hi and control x, I couldn't find the ^t
                > > >>> option. What am I missing there?
                > > >>
                > > >> I agree that there is no ^t after typing ^x.
                > > >> Nonetheless, hitting ^x^t after ihi produced two
                > > >> choices: hi and hello.
                > > >
                > > > I can only get it work on gvim but not vim. Still
                > > > trying to figure out why.
                > >
                > > Maybe your Console vim doesn't support thesaurus? Check
                > > the output of ":version" for both (and see ":help :redir"
                > > about how to save that output for e.g. pasting into an
                > > email).
                >
                > Thanks, I finally figured out the problem was the key
                > binding conflict with screen. Sorry for the noise.
                >
                > By the way, is there an easy way to find a word file
                > online?

                i got mine at

                http://www.dcs.shef.ac.uk/research/ilash/Moby/

                sc

                > Manu
                >
                >

                --~--~---------~--~----~------------~-------~--~----~
                You received this message from the "vim_use" maillist.
                For more information, visit http://www.vim.org/maillist.php
                -~----------~----~----~----~------~----~------~--~---
              Your message has been successfully submitted and would be delivered to recipients shortly.