Loading ...
Sorry, an error occurred while loading the content.

Vim not resizing to match terminal size

Expand Messages
  • Kamil Kisiel
    I m having an issue whereas on some systems Vim will not resize to match the size of the terminal window I use to ssh to those systems. Does anyone have any
    Message 1 of 2 , Nov 1, 2007
    • 0 Attachment
      I'm having an issue whereas on some systems Vim will not resize to
      match the size of the terminal window I use to ssh to those systems.
      Does anyone have any idea what would cause this?

      More specifically (although most of you will likely not be familiar
      with these details):
      The systems in question are PBS / torque compute nodes. If I ssh to
      the nodes via normal means, Vim resizes as expected when resizing the
      terminal. If I connect to the nodes through the cluster scheduler
      using the qsub -I command, then I get the erroneous behavior.


      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_use" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • Ben Schmidt
      ... Mmm. That ll be the problem. It s to do with the terminal settings. Control codes get sent by the terminal when the window is resized. Ordinarily ssh just
      Message 2 of 2 , Nov 1, 2007
      • 0 Attachment
        > I'm having an issue whereas on some systems Vim will not resize to
        > match the size of the terminal window I use to ssh to those systems.
        > Does anyone have any idea what would cause this?
        >
        > More specifically (although most of you will likely not be familiar
        > with these details):
        > The systems in question are PBS / torque compute nodes. If I ssh to
        > the nodes via normal means, Vim resizes as expected when resizing the
        > terminal. If I connect to the nodes through the cluster scheduler
        > using the qsub -I command, then I get the erroneous behavior.

        Mmm. That'll be the problem. It's to do with the terminal settings. Control codes
        get sent by the terminal when the window is resized. Ordinarily ssh just passes
        them through the channel to the other end where Vim picks them up (well, I think
        vim asks for them too). At any rate, whatever these 'qsub' things are, it looks
        like they are getting in the way, obscuring the communication Vim has with the
        terminal. Fiddling with terminal modes at one or both ends of the connection might
        be able to make it work, but I wouldn't hold your breath! I imagine it could be
        quite tricky to track down, too, and unfortunately, I know nothing more about it
        really than what I've written here, so will really be no further use!

        Smiles,

        Ben.




        Send instant messages to your online friends http://au.messenger.yahoo.com


        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_use" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      Your message has been successfully submitted and would be delivered to recipients shortly.