Loading ...
Sorry, an error occurred while loading the content.

Latex-suite command completion

Expand Messages
  • Robert Cussons
    Hi, I ve been using some of latex-suite s command completion capability, which is wonderful, so for example, if I type: ( then hit: L I get:
    Message 1 of 19 , Oct 12, 2007
    • 0 Attachment
      Hi, I've been using some of latex-suite's command completion capability,
      which is wonderful, so for example, if I type:

      (

      then hit:

      <Alt> L

      I get:

      \left(\right)<++>

      I then want to enter a fraction in side the brackets so I type:

      \left(frac\right)<++>

      then hit <F7> with the cursor after the 'c' of frac, normally, this
      would expand to:

      \left(\frac{<+n+>}{<+d+>}<++>\right)<++>

      with the <+n+> highlighted, however in the above case all I get is:

      \left(frac0\right)<++>

      can others reproduce this?

      Many thanks,
      Rob.

      P.S. all the above is performed inside the equation environment,
      achieved by entering EEQ in insert mode :-)

      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_use" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • Manu Hack
      ... I can t reproduce your bug under my machine (vim 7.1 on debian). And I think you don t have to use ALT L to get left( right) , just type (( it will
      Message 2 of 19 , Oct 12, 2007
      • 0 Attachment
        On 10/12/07, Robert Cussons <r.cussons@...> wrote:
        >
        > Hi, I've been using some of latex-suite's command completion capability,
        > which is wonderful, so for example, if I type:
        >
        > (
        >
        > then hit:
        >
        > <Alt> L
        >
        > I get:
        >
        > \left(\right)<++>
        >
        > I then want to enter a fraction in side the brackets so I type:
        >
        > \left(frac\right)<++>
        >
        > then hit <F7> with the cursor after the 'c' of frac, normally, this
        > would expand to:
        >
        > \left(\frac{<+n+>}{<+d+>}<++>\right)<++>
        >
        > with the <+n+> highlighted, however in the above case all I get is:
        >
        > \left(frac0\right)<++>
        >
        > can others reproduce this?
        >
        > Many thanks,
        > Rob.
        >
        > P.S. all the above is performed inside the equation environment,
        > achieved by entering EEQ in insert mode :-)
        >

        I can't reproduce your bug under my machine (vim 7.1 on debian). And
        I think you don't have to use ALT L to get \left(\right)<++>, just
        type (( it will expand to that. Also for frac + F7 you may use `/.

        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_use" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      • Szabolcs
        ... Neither can I, with Vim 7.1 on Windows. ... That s good to know! I learned about Alt+L from this post (I m new to latex-suite), but I had to turn off the
        Message 3 of 19 , Oct 12, 2007
        • 0 Attachment
          On Oct 12, 4:45 pm, "Manu Hack" <manuh...@...> wrote:
          > On 10/12/07, Robert Cussons <r.cuss...@...> wrote:
          >
          >
          >
          >
          >
          > > Hi, I've been using some of latex-suite's command completion capability,
          > > which is wonderful, so for example, if I type:
          >
          > > (
          >
          > > then hit:
          >
          > > <Alt> L
          >
          > > I get:
          >
          > > \left(\right)<++>
          >
          > > I then want to enter a fraction in side the brackets so I type:
          >
          > > \left(frac\right)<++>
          >
          > > then hit <F7> with the cursor after the 'c' of frac, normally, this
          > > would expand to:
          >
          > > \left(\frac{<+n+>}{<+d+>}<++>\right)<++>
          >
          > > with the <+n+> highlighted, however in the above case all I get is:
          >
          > > \left(frac0\right)<++>
          >
          > > can others reproduce this?
          >
          > > Many thanks,
          > > Rob.
          >
          > > P.S. all the above is performed inside the equation environment,
          > > achieved by entering EEQ in insert mode :-)
          >
          > I can't reproduce your bug under my machine (vim 7.1 on debian).

          Neither can I, with Vim 7.1 on Windows.

          > And
          > I think you don't have to use ALT L to get \left(\right)<++>, just
          > type (( it will expand to that.

          That's good to know! I learned about Alt+L from this post (I'm new to
          latex-suite), but I had to turn off the Alt+key menu shortcuts to make
          it work!

          Is there a similar alternative for Alt+B (wrapping a single char in
          \mathbf{})?

          > Also for frac + F7 you may use `/.


          --~--~---------~--~----~------------~-------~--~----~
          You received this message from the "vim_use" maillist.
          For more information, visit http://www.vim.org/maillist.php
          -~----------~----~----~----~------~----~------~--~---
        • Robert Cussons
          ... I am using ... VIM - Vi IMproved 7.1 (2007 May 12, compiled Oct 13 2007 13:28:30) Included patches: 1-138 just updated now, under Debian Etch. Problem
          Message 4 of 19 , Oct 13, 2007
          • 0 Attachment
            Manu Hack wrote:
            > On 10/12/07, Robert Cussons <r.cussons@...> wrote:
            >> Hi, I've been using some of latex-suite's command completion capability,
            >> which is wonderful, so for example, if I type:
            >>
            >> (
            >>
            >> then hit:
            >>
            >> <Alt> L
            >>
            >> I get:
            >>
            >> \left(\right)<++>
            >>
            >> I then want to enter a fraction in side the brackets so I type:
            >>
            >> \left(frac\right)<++>
            >>
            >> then hit <F7> with the cursor after the 'c' of frac, normally, this
            >> would expand to:
            >>
            >> \left(\frac{<+n+>}{<+d+>}<++>\right)<++>
            >>
            >> with the <+n+> highlighted, however in the above case all I get is:
            >>
            >> \left(frac0\right)<++>
            >>
            >> can others reproduce this?
            >>
            >> Many thanks,
            >> Rob.
            >>
            >> P.S. all the above is performed inside the equation environment,
            >> achieved by entering EEQ in insert mode :-)
            >>
            >
            > I can't reproduce your bug under my machine (vim 7.1 on debian).

            I am using
            :version
            VIM - Vi IMproved 7.1 (2007 May 12, compiled Oct 13 2007 13:28:30)
            Included patches: 1-138

            just updated now, under Debian Etch. Problem still exists.

            > And I think you don't have to use ALT L to get \left(\right)<++>, just
            > type (( it will expand to that. Also for frac + F7 you may use `/.


            Thanks, these are very useful tips, even faster now ;-). In fact they
            even work inside brackets which for some reason the F7 method doesn't,
            however there are other functions like sum that I still need the F7
            method for and they just produce a zero as explained above when
            performed inside brackets, anyone any idea how I can track down the
            problem?
            Thanks
            Rob.

            --~--~---------~--~----~------------~-------~--~----~
            You received this message from the "vim_use" maillist.
            For more information, visit http://www.vim.org/maillist.php
            -~----------~----~----~----~------~----~------~--~---
          • gaubitzer
            I am experiencing that many things in vim latex-suite are broken in vim 7.x (latexing of selected parts, jump to error...). Also try a look at vim-latex-devel
            Message 5 of 19 , Oct 31, 2007
            • 0 Attachment
              I am experiencing that many things in vim latex-suite are broken in
              vim 7.x
              (latexing of selected parts, jump to error...).
              Also try a look at vim-latex-devel mailing list.

              Can others confirm or suggest solutions?


              --~--~---------~--~----~------------~-------~--~----~
              You received this message from the "vim_use" maillist.
              For more information, visit http://www.vim.org/maillist.php
              -~----------~----~----~----~------~----~------~--~---
            • Szabolcs
              ... Yes, I agree. ... I haven t tried latexing parts, but jumping to errors does not work for me. ... It seems to be dead, and the contact form does not work:
              Message 6 of 19 , Oct 31, 2007
              • 0 Attachment
                On Oct 31, 12:03 pm, gaubitzer <erwin.gaubit...@...> wrote:
                > I am experiencing that many things in vim latex-suite are broken in
                > vim 7.x

                Yes, I agree.

                > (latexing of selected parts, jump to error...).

                I haven't tried latexing parts, but jumping to errors does not work
                for me.

                > Also try a look at vim-latex-devel mailing list.

                It seems to be dead, and the contact form does not work:
                http://vim-latex.sourceforge.net/index.php?subject=contact&title=Contact

                > Can others confirm or suggest solutions?

                I don't have solutions for the above-mentioned specific issues. If
                you have trouble with named templates (e.g. <+class+>) not being
                selected on Windows after F5 completion, then try making the window
                wider or increasing 'cmdheight'.


                --~--~---------~--~----~------------~-------~--~----~
                You received this message from the "vim_use" maillist.
                For more information, visit http://www.vim.org/maillist.php
                -~----------~----~----~----~------~----~------~--~---
              • Manu Hack
                ... Yes, the development of vim-latex has been slowed down for a while. In fact, I think it s really a very good plugin and many people are willing to
                Message 7 of 19 , Oct 31, 2007
                • 0 Attachment
                  On 10/31/07, Szabolcs <szhorvat@...> wrote:
                  >
                  >
                  >
                  > On Oct 31, 12:03 pm, gaubitzer <erwin.gaubit...@...> wrote:
                  > > I am experiencing that many things in vim latex-suite are broken in
                  > > vim 7.x
                  >
                  > Yes, I agree.
                  >
                  > > (latexing of selected parts, jump to error...).
                  >
                  > I haven't tried latexing parts, but jumping to errors does not work
                  > for me.
                  >
                  > > Also try a look at vim-latex-devel mailing list.
                  >
                  > It seems to be dead, and the contact form does not work:
                  > http://vim-latex.sourceforge.net/index.php?subject=contact&title=Contact

                  Yes, the development of vim-latex has been slowed down for a while.
                  In fact, I think it's really a very good plugin and many people are
                  willing to contribute to it. What can be done here?

                  Manu

                  --~--~---------~--~----~------------~-------~--~----~
                  You received this message from the "vim_use" maillist.
                  For more information, visit http://www.vim.org/maillist.php
                  -~----------~----~----~----~------~----~------~--~---
                • A.Politz
                  ... Do this : let g:Imap_Debug=1 let g:Tex_Debug=1 let g:Tex_DebugLog= /tmp/tex.log or any other nonexistant file ... frac
                  Message 8 of 19 , Oct 31, 2007
                  • 0 Attachment
                    Robert Cussons wrote:

                    >Manu Hack wrote:
                    >
                    >
                    >>On 10/12/07, Robert Cussons <r.cussons@...> wrote:
                    >>
                    >>
                    >>>Hi, I've been using some of latex-suite's command completion capability,
                    >>>which is wonderful, so for example, if I type:
                    >>>
                    >>>(
                    >>>
                    >>>then hit:
                    >>>
                    >>><Alt> L
                    >>>
                    >>>I get:
                    >>>
                    >>>\left(\right)<++>
                    >>>
                    >>>I then want to enter a fraction in side the brackets so I type:
                    >>>
                    >>>\left(frac\right)<++>
                    >>>
                    >>>then hit <F7> with the cursor after the 'c' of frac, normally, this
                    >>>would expand to:
                    >>>
                    >>>\left(\frac{<+n+>}{<+d+>}<++>\right)<++>
                    >>>
                    >>>with the <+n+> highlighted, however in the above case all I get is:
                    >>>
                    >>>\left(frac0\right)<++>
                    >>>
                    >>>can others reproduce this?
                    >>>
                    >>>Many thanks,
                    >>>Rob.
                    >>>
                    >>>P.S. all the above is performed inside the equation environment,
                    >>>achieved by entering EEQ in insert mode :-)
                    >>>
                    >>>
                    >>>
                    >>I can't reproduce your bug under my machine (vim 7.1 on debian).
                    >>
                    >>
                    >
                    >I am using
                    >:version
                    >VIM - Vi IMproved 7.1 (2007 May 12, compiled Oct 13 2007 13:28:30)
                    >Included patches: 1-138
                    >
                    >just updated now, under Debian Etch. Problem still exists.
                    >
                    >
                    >
                    >>And I think you don't have to use ALT L to get \left(\right)<++>, just
                    >>type (( it will expand to that. Also for frac + F7 you may use `/.
                    >>
                    >>
                    >
                    >
                    >Thanks, these are very useful tips, even faster now ;-). In fact they
                    >even work inside brackets which for some reason the F7 method doesn't,
                    >however there are other functions like sum that I still need the F7
                    >method for and they just produce a zero as explained above when
                    >performed inside brackets, anyone any idea how I can track down the
                    >problem?
                    >Thanks
                    >Rob.
                    >
                    >>
                    >
                    >
                    Do this :


                    let g:Imap_Debug=1
                    let g:Tex_Debug=1
                    let g:Tex_DebugLog='/tmp/tex.log' " or any other nonexistant file

                    :e newfile.tex
                    <Enter insertmode and type :>
                    frac<f7>

                    Then post the content of the logfile.

                    -ap


                    --
                    Ich hab geträumt, der Krieg wär vorbei.


                    --~--~---------~--~----~------------~-------~--~----~
                    You received this message from the "vim_use" maillist.
                    For more information, visit http://www.vim.org/maillist.php
                    -~----------~----~----~----~------~----~------~--~---
                  • A.Politz
                    ... Jumping to errors works fine for me. What is the content of the quickfix window ? Or what is the value of ... -ap -- Ich hab geträumt, der Krieg wär
                    Message 9 of 19 , Oct 31, 2007
                    • 0 Attachment
                      Szabolcs wrote:

                      >
                      >On Oct 31, 12:03 pm, gaubitzer <erwin.gaubit...@...> wrote:
                      >
                      >
                      >>I am experiencing that many things in vim latex-suite are broken in
                      >>vim 7.x
                      >>
                      >>
                      >
                      >Yes, I agree.
                      >
                      >
                      >
                      >>(latexing of selected parts, jump to error...).
                      >>
                      >>
                      >
                      >I haven't tried latexing parts, but jumping to errors does not work
                      >for me.
                      >
                      >
                      >
                      Jumping to errors works fine for me.
                      What is the content of the quickfix window ?
                      Or what is the value of
                      :echo getqflist()[-1].

                      -ap

                      --
                      Ich hab geträumt, der Krieg wär vorbei.


                      --~--~---------~--~----~------------~-------~--~----~
                      You received this message from the "vim_use" maillist.
                      For more information, visit http://www.vim.org/maillist.php
                      -~----------~----~----~----~------~----~------~--~---
                    • Szabolcs
                      ... I should have been more attentive. As I tried to prepare a test case, I found for the first time ever that jumping to errors does work! Now at least I
                      Message 10 of 19 , Oct 31, 2007
                      • 0 Attachment
                        On Oct 31, 5:41 pm, "A.Politz" <poli...@...> wrote:
                        > Szabolcs wrote:
                        >
                        > >On Oct 31, 12:03 pm, gaubitzer <erwin.gaubit...@...> wrote:
                        >
                        > >>I am experiencing that many things in vim latex-suite are broken in
                        > >>vim 7.x
                        >
                        > >Yes, I agree.
                        >
                        > >>(latexing of selected parts, jump to error...).
                        >
                        > >I haven't tried latexing parts, but jumping to errors does not work
                        > >for me.
                        >
                        > Jumping to errors works fine for me.
                        > What is the content of the quickfix window ?

                        I should have been more attentive. As I tried to prepare a test case,
                        I found for the first time ever that jumping to errors does work! Now
                        at least I know how it is supposed to work. But when I added the line
                        "\usepackage[utf8]{inputenc}", it stopped working :(

                        Here is a test file:

                        --------- begin tst.tex ---------

                        \documentclass{article}
                        \usepackage[utf8]{inputenc}
                        \begin{document}
                        one
                        two
                        error $\su$
                        some
                        more
                        lines
                        \end{document}

                        ---------- end tst.tex ----------

                        After I compile this with \ll, the [Quickfix list] window appears. It
                        contains this line:

                        |6 error| Undefined control sequence. \su error $\su $

                        The cursor is on this line. Pressing enter has no effect. Then I
                        press <Up>:
                        a [preview] window appears with the detailed error message given by
                        TeX. The following line appears in the quickfix window, but the
                        cursor is still on the error line:

                        || (C:\texmf\tex\latex\base\inputenc.sty

                        The enter key still does not do anything.

                        > Or what is the value of
                        > :echo getqflist()[-1].

                        {'lnum': 6, 'bufnr': 0, 'col: 0, 'valid': 1, 'vcol': 0, 'nr': -1,
                        'type': 'E', 'pattern': '', 'text': 'Undefined control sequence.
                        \su

                        error $\su
                        $'}


                        -- Szabolcs

                        P.S. This is on WinXP with MiKTeX 2.6, if it matters.

                        P.P.S. Another problem I had with latex-suite is described here:
                        http://groups.google.com/group/comp.editors/browse_thread/thread/a23093be152fbd43#


                        --~--~---------~--~----~------------~-------~--~----~
                        You received this message from the "vim_use" maillist.
                        For more information, visit http://www.vim.org/maillist.php
                        -~----------~----~----~----~------~----~------~--~---
                      • A.Politz
                        ... I believe the problem is a wrong wdir. ... qfwindow should look like this now : tst.tex|6 error| Undefined control sequence. su error $ su $ -ap -- Ich
                        Message 11 of 19 , Oct 31, 2007
                        • 0 Attachment
                          Szabolcs wrote:

                          >On Oct 31, 5:41 pm, "A.Politz" <poli...@...> wrote:
                          >
                          >
                          >>Szabolcs wrote:
                          >>
                          >>
                          >>
                          >>>On Oct 31, 12:03 pm, gaubitzer <erwin.gaubit...@...> wrote:
                          >>>
                          >>>
                          >>>>I am experiencing that many things in vim latex-suite are broken in
                          >>>>vim 7.x
                          >>>>
                          >>>>
                          >>>Yes, I agree.
                          >>>
                          >>>
                          >>>>(latexing of selected parts, jump to error...).
                          >>>>
                          >>>>
                          >>>I haven't tried latexing parts, but jumping to errors does not work
                          >>>for me.
                          >>>
                          >>>
                          >>Jumping to errors works fine for me.
                          >>What is the content of the quickfix window ?
                          >>
                          >>
                          >
                          >I should have been more attentive. As I tried to prepare a test case,
                          >I found for the first time ever that jumping to errors does work! Now
                          >at least I know how it is supposed to work. But when I added the line
                          >"\usepackage[utf8]{inputenc}", it stopped working :(
                          >
                          >Here is a test file:
                          >
                          >--------- begin tst.tex ---------
                          >
                          >\documentclass{article}
                          >\usepackage[utf8]{inputenc}
                          >\begin{document}
                          >one
                          >two
                          >error $\su$
                          >some
                          >more
                          >lines
                          >\end{document}
                          >
                          >---------- end tst.tex ----------
                          >
                          >After I compile this with \ll, the [Quickfix list] window appears. It
                          >contains this line:
                          >
                          >|6 error| Undefined control sequence. \su error $\su $
                          >
                          >The cursor is on this line. Pressing enter has no effect. Then I
                          >press <Up>:
                          >a [preview] window appears with the detailed error message given by
                          >TeX. The following line appears in the quickfix window, but the
                          >cursor is still on the error line:
                          >
                          >|| (C:\texmf\tex\latex\base\inputenc.sty
                          >
                          >The enter key still does not do anything.
                          >
                          >
                          >
                          >>Or what is the value of
                          >>:echo getqflist()[-1].
                          >>
                          >>
                          >
                          >{'lnum': 6, 'bufnr': 0, 'col: 0, 'valid': 1, 'vcol': 0, 'nr': -1,
                          >'type': 'E', 'pattern': '', 'text': 'Undefined control sequence.
                          > \su
                          >
                          >error $\su
                          > $'}
                          >
                          >
                          >-- Szabolcs
                          >
                          >P.S. This is on WinXP with MiKTeX 2.6, if it matters.
                          >
                          >P.P.S. Another problem I had with latex-suite is described here:
                          >http://groups.google.com/group/comp.editors/browse_thread/thread/a23093be152fbd43#
                          >
                          >
                          >>
                          >
                          >
                          I believe the problem is a wrong wdir.
                          Try this after compiling :

                          :cd dir_of_tst.tex
                          :cfile tst.log

                          qfwindow should look like this now :

                          tst.tex|6 error| Undefined control sequence. \su error $\su $

                          -ap


                          --
                          Ich hab geträumt, der Krieg wär vorbei.


                          --~--~---------~--~----~------------~-------~--~----~
                          You received this message from the "vim_use" maillist.
                          For more information, visit http://www.vim.org/maillist.php
                          -~----------~----~----~----~------~----~------~--~---
                        • Szabolcs
                          ... Thank you for looking into this problem! But unfortunately this suggestion does not work. :pwd tells me that vim is in the correct directory (the
                          Message 12 of 19 , Nov 1, 2007
                          • 0 Attachment
                            On Oct 31, 10:14 pm, "A.Politz" <poli...@...> wrote:
                            >
                            > I believe the problem is a wrong wdir.
                            > Try this after compiling :
                            >
                            > :cd dir_of_tst.tex
                            > :cfile tst.log
                            >
                            > qfwindow should look like this now :
                            >
                            > tst.tex|6 error| Undefined control sequence. \su error $\su $
                            >

                            Thank you for looking into this problem! But unfortunately this
                            suggestion does not work. :pwd tells me that vim is in the correct
                            directory (the directory of tst.tex). :cfile tst.log has no effect at
                            all.

                            Meanwhile I got the chance to try this out on a Linux computer, and it
                            seems to be working there. So this is a Windows-only problem. I do
                            have the settings recommended for win32 users on this page:
                            http://vim-latex.sourceforge.net/documentation/latex-suite/recommended-settings.html
                            ... though I have no idea if these might have anything to do with the
                            problem.

                            It is sad that there are so many things in vim-latex not working
                            correctly on win32. The "enter prompt" problem is win32-only too.
                            But all the screenshots on http://vim-latex.sourceforge.net/ were made
                            on Windows, so the developers of latex-suite must have tested it on
                            win32!


                            --~--~---------~--~----~------------~-------~--~----~
                            You received this message from the "vim_use" maillist.
                            For more information, visit http://www.vim.org/maillist.php
                            -~----------~----~----~----~------~----~------~--~---
                          • Szabolcs
                            I turned on logging as you suggested in a previous message in this thread. These are the contents of the log file. The lines beginning with % describe what I
                            Message 13 of 19 , Nov 1, 2007
                            • 0 Attachment
                              I turned on logging as you suggested in a previous message in this
                              thread. These are the contents of the log file. The lines beginning
                              with % describe what I did at that point.

                              % :let g:Imap_Debug=1
                              % :let g:Tex_Debug=1
                              % :let g:Tex_DebugLog='tdbg.log'
                              % :e tst.tex

                              proj : texproject.vim: catching LatexSuiteFileType event
                              env : envmacros.vim: Catching LatexSuiteFileType event
                              comp : compiler.vim: Catching LatexSuiteFileType event
                              fold : folding.vim: catching LatexSuiteFileType
                              view : texviewer.vim: Catching LatexSuiteFileType event
                              main : main.vim: Catching LatexSuiteFileType event
                              main : SetTeXOptions: sourcing maps
                              comp : +Tex_SetTeXCompilerTarget: setting target to [dvi] for Compiler
                              comp : +Tex_SetTeXCompilerTarget: setting target to [dvi] for Viewr
                              comp : compiler/tex.vim: sourcing this file
                              pack : packages.vim: Catching LatexSuiteFileType event
                              pack : +Tex_pack_updateall
                              pack : :Tex_pack_updateall: split
                              pack : +Tex_ScanForPackages
                              pack : :Tex_ScanForPackages: Begining scans in [tst.tex], beginline =
                              3
                              pack : :Tex_ScanForPackages: beginning scan for \usepackage lines
                              pack : :Tex_ScanForPackages: found package(s) ["inputenc"] on line 2
                              pack : :Tex_ScanForPackages: End scan \usepackage, detected packages
                              = ,inputenc
                              pack : :Tex_ScanForPackages: Beginning scan for \newcommand's
                              pack : :Tex_ScanForPackages: Beginning scan for \newenvironment's
                              pack : -Tex_ScanForPackages
                              pack : :Tex_pack_updateall: detected [inputenc] in first run
                              pack : :Tex_pack_updateall: scanning package inputenc
                              pack : :Tex_pack_updateall: silent! find inputenc.sty
                              pack : :Tex_pack_updateall: present file = tst.tex
                              pack : :Tex_pack_updateall: inputenc not found anywhere
                              pack : Tex_pack_check: searching for inputenc in dictionaries/ in &rtp
                              imap : IMAP_PutTextWithMovement: text = [\usepackage[X^\^N:call
                              IMAP_Mark('set')
                              "_s<++>]{inputenc}<++>^\^N:call IMAP_Mark('go')
                              i^R=IMAP_Jumpfunc('', 1)
                              ]
                              pack : :Tex_pack_updateall: throwing LatexSuiteScannedPackages event
                              pack : -Tex_pack_updateall

                              % \ll

                              comp : +Tex_RunLaTeX, b:fragmentFile = 0
                              comp : Tex_RunLaTeX: compiling to target [dvi]
                              comp : Tex_RunLaTeX: getting dependency chain = [dvi]
                              comp : +Tex_SetTeXCompilerTarget: setting target to [dvi] for Compiler
                              comp : Tex_RunLaTeX: setting target to dvi
                              comp : Tex_RunLaTeX: compiling file multiple times via
                              Tex_CompileMultipleTimes
                              comp : Tex_CompileMultipleTimes: latex run number : 1
                              comp : Tex_CompileLatex: getting mainfname = [tst.tex] from
                              Tex_GetMainFileName
                              comp : Tex_CompileLatex: execing [make! tst.tex]
                              comp : Tex_CompileMultipleTimes: errors = [
                              2:6 error: Undefined control sequence. \su error $\su $]
                              comp : Tex_RunLaTeX: errlist = [
                              2:6 error: Undefined control sequence. \su error $\su $]
                              comp : Tex_RunLaTeX: There were errors in compiling, breaking chain...
                              comp : Tex_SetupErrorWindow: mfnlog = tst.log
                              comp : not finding error pattern anywhere in quickfix window :tst.log
                              comp : -Tex_RunLaTeX

                              %%% now the cursor is in the quickfix window, on the error line
                              % <CR>

                              comp : not finding error pattern anywhere in quickfix window :tst.tex

                              % <Up><CR>
                              %%% the preview window appears, the cursor jumps back to the same
                              %%% error line in the quickfix window

                              comp : not finding error pattern anywhere in quickfix window :tst.log

                              % <CR>
                              %%% the preview window disappears, the cursor stays on the same
                              %%% error line in the qf window

                              comp : not finding error pattern anywhere in quickfix window :tst.tex


                              --~--~---------~--~----~------------~-------~--~----~
                              You received this message from the "vim_use" maillist.
                              For more information, visit http://www.vim.org/maillist.php
                              -~----------~----~----~----~------~----~------~--~---
                            • A.Politz
                              I have no win32, so I can only guess... ... This is the output of clist . I don t know if vim sometimes uses bufnr instead of filenames ,in which case the
                              Message 14 of 19 , Nov 1, 2007
                              • 0 Attachment
                                I have no win32, so I can only guess...

                                Szabolcs wrote:

                                >I turned on logging as you suggested in a previous message in this
                                >thread. These are the contents of the log file. The lines beginning
                                >with % describe what I did at that point.
                                >
                                >% :let g:Imap_Debug=1
                                >% :let g:Tex_Debug=1
                                >% :let g:Tex_DebugLog='tdbg.log'
                                >% :e tst.tex
                                >
                                >...
                                >% \ll
                                >
                                >...
                                >comp : Tex_CompileMultipleTimes: errors = [
                                > 2:6 error: Undefined control sequence. \su error $\su $]
                                >
                                >
                                >
                                This is the output of 'clist' . I don't know if vim sometimes
                                uses 'bufnr' instead of 'filenames',in which case the '2' in '2:6'
                                could point to bufnr 2.
                                In case it is not the bufnr, it would appear that the
                                'errformat' option wrongly parses the output of miktex.
                                You can verify that by trying a
                                :make %
                                in the tst.tex window. Or verifying, that the number is
                                _not_ always the number of the buffer.

                                -ap

                                --
                                Ich hab geträumt, der Krieg wär vorbei.


                                --~--~---------~--~----~------------~-------~--~----~
                                You received this message from the "vim_use" maillist.
                                For more information, visit http://www.vim.org/maillist.php
                                -~----------~----~----~----~------~----~------~--~---
                              • Szabolcs
                                ... What does bufnr mean exactly (I know very little about this)? The command :echo bufnr( % ) returns 1 for the window with tst.tex, 2 for the quickfix
                                Message 15 of 19 , Nov 1, 2007
                                • 0 Attachment
                                  On Nov 1, 11:12 pm, "A.Politz" <poli...@...> wrote:
                                  > I have no win32, so I can only guess...
                                  >
                                  >
                                  >
                                  > Szabolcs wrote:
                                  > >I turned on logging as you suggested in a previous message in this
                                  > >thread. These are the contents of the log file. The lines beginning
                                  > >with % describe what I did at that point.
                                  >
                                  > >% :let g:Imap_Debug=1
                                  > >% :let g:Tex_Debug=1
                                  > >% :let g:Tex_DebugLog='tdbg.log'
                                  > >% :e tst.tex
                                  >
                                  > >...
                                  > >% \ll
                                  >
                                  > >...
                                  > >comp : Tex_CompileMultipleTimes: errors = [
                                  > > 2:6 error: Undefined control sequence. \su error $\su $]
                                  >
                                  > This is the output of 'clist' . I don't know if vim sometimes
                                  > uses 'bufnr' instead of 'filenames',in which case the '2' in '2:6'
                                  > could point to bufnr 2.
                                  > In case it is not the bufnr, it would appear that the
                                  > 'errformat' option wrongly parses the output of miktex.
                                  > You can verify that by trying a
                                  > :make %
                                  > in the tst.tex window. Or verifying, that the number is
                                  > _not_ always the number of the buffer.

                                  What does bufnr mean exactly (I know very little about this)? The
                                  command :echo bufnr("%") returns 1 for the window with tst.tex, 2 for
                                  the quickfix window and 3 for the preview window (when visible after
                                  an <Up>).

                                  I tried moving tst.log from a linux computer (where this was working)
                                  to windows, and doing :cfile tst.log and :cwindow, but it does not
                                  work (the filename is missing from the error line). When I try the
                                  reverse, i.e. moving the windows tst.log to linux, it doesn't work
                                  either (the line endings were changes during transfer). There are
                                  only minor differences between the two files, like paths and version
                                  numbers, so I don't know what is happening.

                                  How exactly does Vim decide where to look for the file where with the
                                  errors? Does it take the file name from tst.log?


                                  --~--~---------~--~----~------------~-------~--~----~
                                  You received this message from the "vim_use" maillist.
                                  For more information, visit http://www.vim.org/maillist.php
                                  -~----------~----~----~----~------~----~------~--~---
                                • Szabolcs Horvát
                                  I attached the two tst.log files. They are nearly identical. --~--~---------~--~----~------------~-------~--~----~ You received this message from the
                                  Message 16 of 19 , Nov 1, 2007
                                  • 0 Attachment
                                    I attached the two tst.log files. They are nearly identical.

                                    --~--~---------~--~----~------------~-------~--~----~
                                    You received this message from the "vim_use" maillist.
                                    For more information, visit http://www.vim.org/maillist.php
                                    -~----------~----~----~----~------~----~------~--~---
                                  • Szabolcs
                                    Sorry for the spamming ... just one more question: What does that ... line mean in the quickfix window? This is the first line in the qf window when things
                                    Message 17 of 19 , Nov 1, 2007
                                    • 0 Attachment
                                      Sorry for the spamming ... just one more question:

                                      What does that
                                      || (tst.aux)
                                      line mean in the quickfix window?

                                      This is the first line in the qf window when things *are* working
                                      correctly, both on win and linux. (Without \usepackage{inputenc}
                                      everything is OK on windows). When it is not working correctly, I see
                                      the following line instead (after pressing <Up>):

                                      || (c:\texmf\tex\latex\base\inputenc.sty

                                      Does this mean that "(tst.aux)" is what tells Vim which file contains
                                      the errors, and that it is misparsing the output of MiKTeX?


                                      --~--~---------~--~----~------------~-------~--~----~
                                      You received this message from the "vim_use" maillist.
                                      For more information, visit http://www.vim.org/maillist.php
                                      -~----------~----~----~----~------~----~------~--~---
                                    • A.Politz
                                      ... I have little experience with writing errorformats , but I am fairly shure, that it is the problem. errorformat contains a list of pattern, which are
                                      Message 18 of 19 , Nov 2, 2007
                                      • 0 Attachment
                                        Szabolcs wrote:

                                        >Sorry for the spamming ... just one more question:
                                        >
                                        >What does that
                                        >|| (tst.aux)
                                        >line mean in the quickfix window?
                                        >
                                        >This is the first line in the qf window when things *are* working
                                        >correctly, both on win and linux. (Without \usepackage{inputenc}
                                        >everything is OK on windows). When it is not working correctly, I see
                                        >the following line instead (after pressing <Up>):
                                        >
                                        >|| (c:\texmf\tex\latex\base\inputenc.sty
                                        >
                                        >Does this mean that "(tst.aux)" is what tells Vim which file contains
                                        >the errors, and that it is misparsing the output of MiKTeX?
                                        >
                                        >
                                        >>
                                        >
                                        >
                                        I have little experience with writing 'errorformats',
                                        but I am fairly shure, that it is the problem.
                                        'errorformat' contains a list of pattern, which
                                        are matched against the compiler output.
                                        This doesn't seem to work in every case.
                                        If you look at the differences in your files, you
                                        notice that the braces differ. Braces are used in the
                                        errorformat to help recognizing filenames.

                                        The lines you are referring to are simply matches
                                        against one of the errorformats as text.In other
                                        words 'it' is configured (via errorformat)
                                        to display this filename, no other meaning implied.

                                        Maybe the plugin, the way it configured errorformat,
                                        believes that the error is in file 'inputenc.sty',
                                        but vim can't open it for some reason.

                                        tst.log contains the errros, which latex-suite uses.

                                        -ap


                                        --
                                        Ich hab geträumt, der Krieg wär vorbei.


                                        --~--~---------~--~----~------------~-------~--~----~
                                        You received this message from the "vim_use" maillist.
                                        For more information, visit http://www.vim.org/maillist.php
                                        -~----------~----~----~----~------~----~------~--~---
                                      • Robert Cussons
                                        ... Sorry, been away on holiday for a few days and it seems somebody (Szabolcs) has been borrowing my thread, please don t do this as it confuses everybody as
                                        Message 19 of 19 , Nov 5, 2007
                                        • 0 Attachment
                                          A.Politz wrote:
                                          > Robert Cussons wrote:
                                          >
                                          >> Manu Hack wrote:
                                          >>
                                          >>
                                          >>> On 10/12/07, Robert Cussons <r.cussons@...> wrote:
                                          >>>
                                          >>>
                                          >>>> Hi, I've been using some of latex-suite's command completion capability,
                                          >>>> which is wonderful, so for example, if I type:
                                          >>>>
                                          >>>> (
                                          >>>>
                                          >>>> then hit:
                                          >>>>
                                          >>>> <Alt> L
                                          >>>>
                                          >>>> I get:
                                          >>>>
                                          >>>> \left(\right)<++>
                                          >>>>
                                          >>>> I then want to enter a fraction in side the brackets so I type:
                                          >>>>
                                          >>>> \left(frac\right)<++>
                                          >>>>
                                          >>>> then hit <F7> with the cursor after the 'c' of frac, normally, this
                                          >>>> would expand to:
                                          >>>>
                                          >>>> \left(\frac{<+n+>}{<+d+>}<++>\right)<++>
                                          >>>>
                                          >>>> with the <+n+> highlighted, however in the above case all I get is:
                                          >>>>
                                          >>>> \left(frac0\right)<++>
                                          >>>>
                                          >>>> can others reproduce this?
                                          >>>>
                                          >>>> Many thanks,
                                          >>>> Rob.
                                          >>>>
                                          >>>> P.S. all the above is performed inside the equation environment,
                                          >>>> achieved by entering EEQ in insert mode :-)
                                          >>>>
                                          >>>>
                                          >>>>
                                          >>> I can't reproduce your bug under my machine (vim 7.1 on debian).
                                          >>>
                                          >>>
                                          >> I am using
                                          >> :version
                                          >> VIM - Vi IMproved 7.1 (2007 May 12, compiled Oct 13 2007 13:28:30)
                                          >> Included patches: 1-138
                                          >>
                                          >> just updated now, under Debian Etch. Problem still exists.
                                          >>
                                          >>
                                          >>
                                          >>> And I think you don't have to use ALT L to get \left(\right)<++>, just
                                          >>> type (( it will expand to that. Also for frac + F7 you may use `/.
                                          >>>
                                          >>>
                                          >>
                                          >> Thanks, these are very useful tips, even faster now ;-). In fact they
                                          >> even work inside brackets which for some reason the F7 method doesn't,
                                          >> however there are other functions like sum that I still need the F7
                                          >> method for and they just produce a zero as explained above when
                                          >> performed inside brackets, anyone any idea how I can track down the
                                          >> problem?
                                          >> Thanks
                                          >> Rob.
                                          >>
                                          >>
                                          >>
                                          > Do this :
                                          >
                                          >
                                          > let g:Imap_Debug=1
                                          > let g:Tex_Debug=1
                                          > let g:Tex_DebugLog='/tmp/tex.log' " or any other nonexistant file
                                          >
                                          > :e newfile.tex
                                          > <Enter insertmode and type :>
                                          > frac<f7>
                                          >
                                          > Then post the content of the logfile.
                                          >
                                          > -ap
                                          >
                                          >

                                          Sorry, been away on holiday for a few days and it seems somebody
                                          (Szabolcs) has been borrowing my thread, please don't do this as it
                                          confuses everybody as to the exact subject of the thread, I know it was
                                          related to start with but it definitely wasn't by the end.

                                          Anyway, back to the problem at hand, when it works, the log file
                                          contains this:


                                          proj : texproject.vim: catching LatexSuiteFileType event
                                          env : envmacros.vim: Catching LatexSuiteFileType event
                                          comp : compiler.vim: Catching LatexSuiteFileType event
                                          fold : folding.vim: catching LatexSuiteFileType
                                          brak : brackets.vim: Catching LatexSuiteFileType event
                                          view : texviewer.vim: Catching LatexSuiteFileType event
                                          main : main.vim: Catching LatexSuiteFileType event
                                          main : SetTeXOptions: sourcing maps
                                          comp : +Tex_SetTeXCompilerTarget: setting target to [ps] for Compiler
                                          comp : +Tex_SetTeXCompilerTarget: setting target to [ps] for Viewr
                                          comp : compiler/tex.vim: sourcing this file
                                          pack : packages.vim: Catching LatexSuiteFileType event
                                          pack : +Tex_pack_updateall
                                          pack : :Tex_pack_updateall: split
                                          pack : +Tex_ScanForPackages
                                          pack : :Tex_ScanForPackages: Begining scans in [newfile.tex], beginline = 0
                                          pack : :Tex_ScanForPackages: beginning scan for \usepackage lines
                                          pack : :Tex_ScanForPackages: End scan \usepackage, detected packages =
                                          pack : :Tex_ScanForPackages: Beginning scan for \newcommand's
                                          pack : :Tex_ScanForPackages: Beginning scan for \newenvironment's
                                          pack : -Tex_ScanForPackages
                                          pack : :Tex_pack_updateall: detected [] in first run
                                          pack : :Tex_pack_updateall: throwing LatexSuiteScannedPackages event
                                          pack : -Tex_pack_updateall
                                          env : Tex_DoCommand: getting lastword = frac
                                          imap : IMAP_PutTextWithMovement: text = [\frac{X^\^N:call
                                          IMAP_Mark('set') "_s<+n+>}{<+d+>}<++>^\^N:call IMAP_Mark('go')
                                          i^R=IMAP_Jumpfunc('', 1) ]

                                          if I go through the exact same process, but rather than just typing frac
                                          in newfile.tex, I type:

                                          EEQ

                                          that puts me in the equation environment, then I type:

                                          ((

                                          that puts me between a pair of brackets, then I type:

                                          frac<f7>

                                          my output in vim is:

                                          \begin{equation}
                                          \left( frac0 \right)<++>
                                          \label{<++>}
                                          \end{equation}<++>

                                          and /tmp/tex.log reads:

                                          proj : texproject.vim: catching LatexSuiteFileType event
                                          env : envmacros.vim: Catching LatexSuiteFileType event
                                          comp : compiler.vim: Catching LatexSuiteFileType event
                                          fold : folding.vim: catching LatexSuiteFileType
                                          brak : brackets.vim: Catching LatexSuiteFileType event
                                          view : texviewer.vim: Catching LatexSuiteFileType event
                                          main : main.vim: Catching LatexSuiteFileType event
                                          main : SetTeXOptions: sourcing maps
                                          comp : +Tex_SetTeXCompilerTarget: setting target to [ps] for Compiler
                                          comp : +Tex_SetTeXCompilerTarget: setting target to [ps] for Viewr
                                          comp : compiler/tex.vim: sourcing this file
                                          pack : packages.vim: Catching LatexSuiteFileType event
                                          pack : +Tex_pack_updateall
                                          pack : :Tex_pack_updateall: split
                                          pack : +Tex_ScanForPackages
                                          pack : :Tex_ScanForPackages: Begining scans in [newfile.tex], beginline = 0
                                          pack : :Tex_ScanForPackages: beginning scan for \usepackage lines
                                          pack : :Tex_ScanForPackages: End scan \usepackage, detected packages =
                                          pack : :Tex_ScanForPackages: Beginning scan for \newcommand's
                                          pack : :Tex_ScanForPackages: Beginning scan for \newenvironment's
                                          pack : -Tex_ScanForPackages
                                          pack : :Tex_pack_updateall: detected [] in first run
                                          pack : :Tex_pack_updateall: throwing LatexSuiteScannedPackages event
                                          pack : -Tex_pack_updateall
                                          imap : Not getting <+ and +> in ^R=Tex_PutEnvironment('equation')
                                          imap : IMAP_PutTextWithMovement: text = [\begin{equation} X^\^N:call
                                          IMAP_Mark('set') "_s<++> \label{<++>} \end{equation}<++>^\^N:call
                                          IMAP_Mark('go') i^R=IMAP_Jumpfunc('', 1) ]
                                          imap : IMAP_PutTextWithMovement: text = [\left( X^\^N:call
                                          IMAP_Mark('set') "_s<++> \right)<++>^\^N:call IMAP_Mark('go')
                                          i^R=IMAP_Jumpfunc('', 1) ]
                                          env : Tex_DoCommand: getting lastword =


                                          any ideas?

                                          Many thanks,
                                          Rob.

                                          --~--~---------~--~----~------------~-------~--~----~
                                          You received this message from the "vim_use" maillist.
                                          For more information, visit http://www.vim.org/maillist.php
                                          -~----------~----~----~----~------~----~------~--~---
                                        Your message has been successfully submitted and would be delivered to recipients shortly.