Loading ...
Sorry, an error occurred while loading the content.

Re: Comment style keeps changing

Expand Messages
  • Gary Johnson
    ... I think you misunderstood Tony s and my suggestions. We re not asking for the value of the verbose option; we re suggesting that you use the :verbose
    Message 1 of 7 , Sep 28, 2007
    • 0 Attachment
      On 2007-09-28, Kim <buckner@...> wrote:

      > On Sep 28, 1:18 pm, Gary Johnson <garyj...@...> wrote:
      >
      > >
      > > > :verbose set comments? cpoptions?
      > >
      > > > (the results may vary from buffer to buffer)
      > >
      > > I would check
      > >
      > > :verbose set fo?
      > >
      > > as well.

      > verbose is 0 in the file that work an in the ones that don't .

      I think you misunderstood Tony's and my suggestions. We're not
      asking for the value of the 'verbose' option; we're suggesting that
      you use the :verbose command to prefix the :set command in order to
      find out where those other options ('comment', 'cpotions' and
      'formatoptions') were set. We suspect that those options are being
      set in some cases by some filetype plugins or autocommands.

      For example, when I execute

      :verbose set fo?

      while composing an e-mail message I see

      formatoptions=r2tcqlaw
      Last set from ~/.vim/after/ftplugin/mail.vim
      Press ENTER or type command to continue

      Regards,
      Gary

      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_use" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    Your message has been successfully submitted and would be delivered to recipients shortly.