Loading ...
Sorry, an error occurred while loading the content.

How can i comple gvim 7.1 on FC5?

Expand Messages
  • Lazy Fox
    On FC5, I use this config: $ ./config --prefix=/usr/local/vim71/ --with-x --enable-gui=gtk2 -- with-features=huge config and compile are all Ok without error
    Message 1 of 8 , Sep 2 6:48 AM
    • 0 Attachment
      On FC5, I use this config:
      $ ./config --prefix=/usr/local/vim71/ --with-x --enable-gui=gtk2 --
      with-features=huge

      config and compile are all Ok without error

      but when I run
      $ ./vim -g
      the error comes:
      E25: GUI cannot be used: Not enabled at compile time

      why?how can i comple gvim 7.1 on FC5?


      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_use" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • Tony Mechelynck
      ... With the above arguments, you must have gtk2-devel and x11-devel installed, and possibly other development packages too. Non-development packages are
      Message 2 of 8 , Sep 2 7:08 AM
      • 0 Attachment
        Lazy Fox wrote:
        > On FC5, I use this config:
        > $ ./config --prefix=/usr/local/vim71/ --with-x --enable-gui=gtk2 --
        > with-features=huge
        >
        > config and compile are all Ok without error
        >
        > but when I run
        > $ ./vim -g
        > the error comes:
        > E25: GUI cannot be used: Not enabled at compile time
        >
        > why?how can i comple gvim 7.1 on FC5?

        With the above arguments, you must have gtk2-devel and x11-devel installed,
        and possibly other "development" packages too. Non-development packages are
        enough to run the concerned applications, but not to compile them.

        Check your configure log (what configure produced on stdout if you still have
        it, otherwise the more verbose src/auto/config.log) and examine it for
        anything relating to the GUI. You will probably see which packages are missing.

        Note: With neither --enable-gui nor --disable-gui, configure will try any
        possible GUI flavour (starting with GTK2) and use the first one (if any) that
        it finds installed.

        See at http://users.skynet.be/antoine.mechelynck/vim/compunix.htm the
        procedure I use to compile Vim on Linux.


        Your "--prefix" setting looks strange to me. Do you mean you want to set your
        $VIMRUNTIME to /usr/local/vim71/share/vim/vim71 ? I would rather leave that
        setting unset, which would mean:

        - executables in /usr/local/bin/
        - $VIM = /usr/local/share/vim
        - $VIMRUNTIME = /usr/local/share/vim/vim71


        Best regards,
        Tony.
        --
        If you only have a hammer, you tend to see every problem as a nail.
        -- Maslow

        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_use" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      • Lazy Fox
        thank u Is there any way to check which packages of my FC5 is missed? On Sep 2, 10:08 pm, Tony Mechelynck ...
        Message 3 of 8 , Sep 2 7:35 AM
        • 0 Attachment
          thank u
          Is there any way to check which packages of my FC5 is missed?

          On Sep 2, 10:08 pm, Tony Mechelynck <antoine.mechely...@...>
          wrote:
          > Lazy Fox wrote:
          > > On FC5, I use this config:
          > > $ ./config --prefix=/usr/local/vim71/ --with-x --enable-gui=gtk2 --
          > > with-features=huge
          >
          > > config and compile are all Ok without error
          >
          > > but when I run
          > > $ ./vim -g
          > > the error comes:
          > > E25: GUI cannot be used: Not enabled at compile time
          >
          > > why?how can i comple gvim 7.1 on FC5?
          >
          > With the above arguments, you must have gtk2-devel and x11-devel installed,
          > and possibly other "development" packages too. Non-development packages are
          > enough to run the concerned applications, but not to compile them.
          >
          > Check your configure log (what configure produced on stdout if you still have
          > it, otherwise the more verbose src/auto/config.log) and examine it for
          > anything relating to the GUI. You will probably see which packages are missing.
          >
          > Note: With neither --enable-gui nor --disable-gui, configure will try any
          > possible GUI flavour (starting with GTK2) and use the first one (if any) that
          > it finds installed.
          >
          > See athttp://users.skynet.be/antoine.mechelynck/vim/compunix.htmthe
          > procedure I use to compile Vim on Linux.
          >
          > Your "--prefix" setting looks strange to me. Do you mean you want to set your
          > $VIMRUNTIME to /usr/local/vim71/share/vim/vim71 ? I would rather leave that
          > setting unset, which would mean:
          >
          > - executables in /usr/local/bin/
          > - $VIM = /usr/local/share/vim
          > - $VIMRUNTIME = /usr/local/share/vim/vim71
          >
          > Best regards,
          > Tony.
          > --
          > If you only have a hammer, you tend to see every problem as a nail.
          > -- Maslow


          --~--~---------~--~----~------------~-------~--~----~
          You received this message from the "vim_use" maillist.
          For more information, visit http://www.vim.org/maillist.php
          -~----------~----~----~----~------~----~------~--~---
        • Tony Mechelynck
          ... As I said, get your config.log and find out what configure was looking for and didn t find. Then, use grep on the output of rpm -qa to find if a given
          Message 4 of 8 , Sep 2 7:50 AM
          • 0 Attachment
            Lazy Fox wrote:
            > thank u
            > Is there any way to check which packages of my FC5 is missed?

            As I said, get your config.log and find out what configure was looking for and
            didn't find.

            Then, use grep on the output of "rpm -qa" to find if a given package is
            installed. For instance, for GTK2,

            rpm -qa |grep gtk2

            will give you _all_ installed packages whose name includes "gtk2". If you
            haven't got gtk2-devel, that's already one missing package. Similarly for X11
            -- there the name may vary. There are a huge lot of packages with "x11" in
            their name. On SuSE 10.2, I think the relevant one is "xorg-x11-devel-7.2-19".

            Or else you could use

            rpm -qa | grep devel | less

            and check that everything you need to use is listed there. In case of doubt,
            check what config was looking for.


            Best regards,
            Tony.
            --
            Evangelists do it with Him watching.

            --~--~---------~--~----~------------~-------~--~----~
            You received this message from the "vim_use" maillist.
            For more information, visit http://www.vim.org/maillist.php
            -~----------~----~----~----~------~----~------~--~---
          • Lazy Fox
            thanks a lot, i ll try it. On Sep 2, 10:50 pm, Tony Mechelynck ... --~--~---------~--~----~------------~-------~--~----~ You
            Message 5 of 8 , Sep 3 2:23 AM
            • 0 Attachment
              thanks a lot, i'll try it.

              On Sep 2, 10:50 pm, Tony Mechelynck <antoine.mechely...@...>
              wrote:
              > Lazy Fox wrote:
              > > thank u
              > > Is there any way to check which packages of my FC5 is missed?
              >
              > As I said, get your config.log and find out what configure was looking for and
              > didn't find.
              >
              > Then, use grep on the output of "rpm -qa" to find if a given package is
              > installed. For instance, for GTK2,
              >
              > rpm -qa |grep gtk2
              >
              > will give you _all_ installed packages whose name includes "gtk2". If you
              > haven't got gtk2-devel, that's already one missing package. Similarly for X11
              > -- there the name may vary. There are a huge lot of packages with "x11" in
              > their name. On SuSE 10.2, I think the relevant one is "xorg-x11-devel-7.2-19".
              >
              > Or else you could use
              >
              > rpm -qa | grep devel | less
              >
              > and check that everything you need to use is listed there. In case of doubt,
              > check what config was looking for.
              >
              > Best regards,
              > Tony.
              > --
              > Evangelists do it with Him watching.


              --~--~---------~--~----~------------~-------~--~----~
              You received this message from the "vim_use" maillist.
              For more information, visit http://www.vim.org/maillist.php
              -~----------~----~----~----~------~----~------~--~---
            • Lazy Fox
              The following is the information of GTK when I run ./configure in the vim71/ directory. ..... checking --with-gtk-prefix argument... no checking
              Message 6 of 8 , Sep 6 2:51 AM
              • 0 Attachment
                The following is the information of GTK when I run "./configure" in
                the vim71/ directory.

                .....
                checking --with-gtk-prefix argument... no
                checking --with-gtk-exec-prefix argument... no
                checking --disable-gtktest argument... gtk test enabled
                checking for gtk-config... (cached) no
                checking for gtk12-config... (cached) no
                checking for pkg-config... (cached) /usr/bin/pkg-config
                checking for GTK - version >= 2.2.0... no
                checking for GTK - version >= 1.1.16... no
                checking for location of Motif GUI includes... in default path
                .....

                The following is rpm environment of my FC5.

                [root@FOX bin]# rpm -aq | grep "gtk"
                pygtk2-libglade-2.8.4-1.1
                gtk-doc-1.4-1.1
                gtkhtml2-2.6.3-1.2.1
                gtkhtml3-3.10.0-1
                libgtk-java-2.8.3.0.20060301.rh1-0
                libswt3-gtk2-3.1.2-1jpp_13fc
                gtk+1.2.10-50
                gtk2-2.8.15-1
                gtk-sharp2-2.8.2-1
                gtk-sharp-1.0.10-5
                gtk2-engines-2.7.4-3
                gtkspell-2.0.11-1.2.1
                pygtk2-2.8.4-1.1
                gtksourceview-1.6.0-1
                gnome-python2-gtksourceview-2.14.0-1
                gnome-python2-gtkhtml2-2.14.0-1
                gtk-engines-0.12-7.2.1
                gtk2-devel-2.8.15-1
                usermode-gtk-1.85-2.2
                pygtk2-devel-2.8.4-1.1
                gtkhtml-1.1.9-12
                authconfig-gtk-5.2.2-1
                gtk+devel-1.2.10-50

                Can you tell me which package do I miss?
                And how does the "./configure" work?


                On Sep 2, 10:50 pm, Tony Mechelynck <antoine.mechely...@...>
                wrote:
                > Lazy Fox wrote:
                > > thank u
                > > Is there any way to check which packages of my FC5 is missed?
                >
                > As I said, get your config.log and find out what configure was looking for and
                > didn't find.
                >
                > Then, use grep on the output of "rpm -qa" to find if a given package is
                > installed. For instance, for GTK2,
                >
                > rpm -qa |grep gtk2
                >
                > will give you _all_ installed packages whose name includes "gtk2". If you
                > haven't got gtk2-devel, that's already one missing package. Similarly for X11
                > -- there the name may vary. There are a huge lot of packages with "x11" in
                > their name. On SuSE 10.2, I think the relevant one is "xorg-x11-devel-7.2-19".
                >
                > Or else you could use
                >
                > rpm -qa | grep devel | less
                >
                > and check that everything you need to use is listed there. In case of doubt,
                > check what config was looking for.
                >
                > Best regards,
                > Tony.
                > --
                > Evangelists do it with Him watching.


                --~--~---------~--~----~------------~-------~--~----~
                You received this message from the "vim_use" maillist.
                For more information, visit http://www.vim.org/maillist.php
                -~----------~----~----~----~------~----~------~--~---
              • Tony Mechelynck
                ... gtk2 and gtk2-devel are installed, but configure doesn t find them. I don t know why. Maybe the config cache was created before you installed them? Someone
                Message 7 of 8 , Sep 6 7:33 AM
                • 0 Attachment
                  Lazy Fox wrote:
                  > The following is the information of GTK when I run "./configure" in
                  > the vim71/ directory.
                  >
                  > .....
                  > checking --with-gtk-prefix argument... no
                  > checking --with-gtk-exec-prefix argument... no
                  > checking --disable-gtktest argument... gtk test enabled
                  > checking for gtk-config... (cached) no
                  > checking for gtk12-config... (cached) no
                  > checking for pkg-config... (cached) /usr/bin/pkg-config
                  > checking for GTK - version >= 2.2.0... no
                  > checking for GTK - version >= 1.1.16... no
                  > checking for location of Motif GUI includes... in default path
                  > .....
                  >
                  > The following is rpm environment of my FC5.
                  >
                  > [root@FOX bin]# rpm -aq | grep "gtk"
                  > pygtk2-libglade-2.8.4-1.1
                  > gtk-doc-1.4-1.1
                  > gtkhtml2-2.6.3-1.2.1
                  > gtkhtml3-3.10.0-1
                  > libgtk-java-2.8.3.0.20060301.rh1-0
                  > libswt3-gtk2-3.1.2-1jpp_13fc
                  > gtk+1.2.10-50
                  > gtk2-2.8.15-1
                  > gtk-sharp2-2.8.2-1
                  > gtk-sharp-1.0.10-5
                  > gtk2-engines-2.7.4-3
                  > gtkspell-2.0.11-1.2.1
                  > pygtk2-2.8.4-1.1
                  > gtksourceview-1.6.0-1
                  > gnome-python2-gtksourceview-2.14.0-1
                  > gnome-python2-gtkhtml2-2.14.0-1
                  > gtk-engines-0.12-7.2.1
                  > gtk2-devel-2.8.15-1
                  > usermode-gtk-1.85-2.2
                  > pygtk2-devel-2.8.4-1.1
                  > gtkhtml-1.1.9-12
                  > authconfig-gtk-5.2.2-1
                  > gtk+devel-1.2.10-50
                  >
                  > Can you tell me which package do I miss?
                  > And how does the "./configure" work?


                  gtk2 and gtk2-devel are installed, but configure doesn't find them. I don't
                  know why. Maybe the config cache was created before you installed them?
                  Someone else may have to look at the above.

                  Try setting the configure arguments by means of environment variables, as
                  explained at http://users.skynet.be/antoine.mechelynck/vim/compunix.htm (you
                  may need to specify where to look for the gtk2 include files);

                  then either

                  make reconfig 2>&1 |tee config.log

                  (to reconfigure and compile), or

                  make distclean
                  make config 2>&1 |tee config.log

                  (to configure, save the configuration, but not compile). In both cases above,
                  make will call configure with the arguments you'll have "told" it to set. In
                  the latter case, if examination of the output shows that configure did find
                  the GTK2 packages,

                  make 2>&1 |tee make.log

                  compiles, and, if the compile (make or make reconfig) is successful,

                  make install 2>&1 |tee install.log

                  installs Vim to "production" location.


                  Best regards,
                  Tony.
                  --
                  "Life may have no meaning -- or even worse, it may have a meaning of
                  which I disapprove."

                  --~--~---------~--~----~------------~-------~--~----~
                  You received this message from the "vim_use" maillist.
                  For more information, visit http://www.vim.org/maillist.php
                  -~----------~----~----~----~------~----~------~--~---
                • Lazy Fox
                  Thanks for you answer. Do you know how the ./configure detect the GTK or GTK2? Does it Use any scripts or commands? On Sep 6, 10:33 pm, Tony Mechelynck
                  Message 8 of 8 , Sep 10 1:32 AM
                  • 0 Attachment
                    Thanks for you answer.

                    Do you know how the "./configure" detect the GTK or GTK2?
                    Does it Use any scripts or commands?



                    On Sep 6, 10:33 pm, Tony Mechelynck <antoine.mechely...@...>
                    wrote:
                    > Lazy Fox wrote:
                    > > The following is the information of GTK when I run "./configure" in
                    > > the vim71/ directory.
                    >
                    > > .....
                    > > checking --with-gtk-prefix argument... no
                    > > checking --with-gtk-exec-prefix argument... no
                    > > checking --disable-gtktest argument... gtk test enabled
                    > > checking for gtk-config... (cached) no
                    > > checking for gtk12-config... (cached) no
                    > > checking for pkg-config... (cached) /usr/bin/pkg-config
                    > > checking for GTK - version >= 2.2.0... no
                    > > checking for GTK - version >= 1.1.16... no
                    > > checking for location of Motif GUI includes... in default path
                    > > .....
                    >
                    > > The following is rpm environment of my FC5.
                    >
                    > > [root@FOX bin]# rpm -aq | grep "gtk"
                    > > pygtk2-libglade-2.8.4-1.1
                    > > gtk-doc-1.4-1.1
                    > > gtkhtml2-2.6.3-1.2.1
                    > > gtkhtml3-3.10.0-1
                    > > libgtk-java-2.8.3.0.20060301.rh1-0
                    > > libswt3-gtk2-3.1.2-1jpp_13fc
                    > > gtk+1.2.10-50
                    > > gtk2-2.8.15-1
                    > > gtk-sharp2-2.8.2-1
                    > > gtk-sharp-1.0.10-5
                    > > gtk2-engines-2.7.4-3
                    > > gtkspell-2.0.11-1.2.1
                    > > pygtk2-2.8.4-1.1
                    > > gtksourceview-1.6.0-1
                    > > gnome-python2-gtksourceview-2.14.0-1
                    > > gnome-python2-gtkhtml2-2.14.0-1
                    > > gtk-engines-0.12-7.2.1
                    > > gtk2-devel-2.8.15-1
                    > > usermode-gtk-1.85-2.2
                    > > pygtk2-devel-2.8.4-1.1
                    > > gtkhtml-1.1.9-12
                    > > authconfig-gtk-5.2.2-1
                    > > gtk+devel-1.2.10-50
                    >
                    > > Can you tell me which package do I miss?
                    > > And how does the "./configure" work?
                    >
                    > gtk2 and gtk2-devel are installed, but configure doesn't find them. I don't
                    > know why. Maybe the config cache was created before you installed them?
                    > Someone else may have to look at the above.
                    >
                    > Try setting the configure arguments by means of environment variables, as
                    > explained athttp://users.skynet.be/antoine.mechelynck/vim/compunix.htm(you
                    > may need to specify where to look for the gtk2 include files);
                    >
                    > then either
                    >
                    > make reconfig 2>&1 |tee config.log
                    >
                    > (to reconfigure and compile), or
                    >
                    > make distclean
                    > make config 2>&1 |tee config.log
                    >
                    > (to configure, save the configuration, but not compile). In both cases above,
                    > make will call configure with the arguments you'll have "told" it to set. In
                    > the latter case, if examination of the output shows that configure did find
                    > the GTK2 packages,
                    >
                    > make 2>&1 |tee make.log
                    >
                    > compiles, and, if the compile (make or make reconfig) is successful,
                    >
                    > make install 2>&1 |tee install.log
                    >
                    > installs Vim to "production" location.
                    >
                    > Best regards,
                    > Tony.
                    > --
                    > "Life may have no meaning -- or even worse, it may have a meaning of
                    > which I disapprove."- Hide quoted text -
                    >
                    > - Show quoted text -


                    --~--~---------~--~----~------------~-------~--~----~
                    You received this message from the "vim_use" maillist.
                    For more information, visit http://www.vim.org/maillist.php
                    -~----------~----~----~----~------~----~------~--~---
                  Your message has been successfully submitted and would be delivered to recipients shortly.