Loading ...
Sorry, an error occurred while loading the content.

Carbon Gvim sluggish (with latexsuite)

Expand Messages
  • krisse
    Hi, First post here; joined to be able to ask the following question. Been using (g- &) vim on Linux for quite some while, but recently got a mac, and I ve
    Message 1 of 3 , Aug 27, 2007
    • 0 Attachment
      Hi,

      First post here; joined to be able to ask the following question.

      Been using (g- &) vim on Linux for quite some while, but recently got
      a mac, and I've been trying to use my favourite editor there as well.
      However, I've been experiencing some slowdowns when editing a somewhat
      longer latex-file.

      Latexsuite is loaded; syntax highlighting on.
      The file is about 1950 lines.

      I've tried disabling, changing (to something else or back to default)
      the following options, in case it would have had some impact: spell,
      gfn, anti, macatsui, enc, tenc. But nothing was different.

      Running Mac OSX 10.4, using the Tiger binary from macvim.org, version
      7.0.224.

      * When using gvim from fink, everything works fine, no sluggishness.
      * When editing the same file, same options, on linux works fine.

      * In desperation, I also tried checking out from svn (r482; v7.1.87),
      and compiling (in osx).
      Compile worked fine, but I'm getting a lot of errors caused by --
      I'm assuming -- latexsuite. The (very long) listing of errors start
      with "Error detected while processing function IMAP:" and continues
      with a lot of "Illegal variable names", such as "phe_tex_-_164__94_",
      "Map_tex_-_164__47_", to just name a few.
      Additionally, I'm not seeing any scandinavian characters in the menu
      nor "in-file".
      The good news is, that I'm not seeing any of the sluggishness using
      version 7.1.87. But still, as it is, it's unusable due to the lack of
      scandinavian characters.

      The problems with the compiled vim might, for sure, be caused (or
      rather: could be solved) by compilation configuration -- I did none,
      except use what was given by a ./configure. Maybe there's some options
      I'm missing?


      Since v7.1.87 "cured" the sluggishness, making that work sounds like
      the best solution for me, if anyone can help? This said, I guess it
      might be possible that the sluggishness will return when "full
      functionality" is restored (no latexsuite errors; with scand. char.).
      Another option, would be to make it work with the binary version,
      7.0.224 -- but I'm at a loss as to what to try next?

      Every and any ideas are appreciated! Thanks in advance.


      /krisse


      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_use" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • krisse
      Sorry; realized sluggish isn t by itself a very clear description of the problem... What I mean by that is, that I load the file and start editing -- but
      Message 2 of 3 , Aug 27, 2007
      • 0 Attachment
        Sorry; realized "sluggish" isn't by itself a very clear description of
        the problem... What I mean by that is, that I load the file and start
        editing -- but only manage to write about ten characters or so, before
        screen refresh stops: nothing happens. There's a pause for about three
        or four seconds, and then what was written appears. This happens every
        time.

        At first, I thought it was the size of the file that introduced the
        problem, but now, when I tried opening a smaller file (about 230
        lines), the same thing happens! (See above.) Even a simple file with
        only the preamble is enough. Latexsuite loaded; syntax highlighting
        off: sluggish. Syntax highlighting on; latexsuite off: not sluggish.
        It's definitely latexsuite that's causing the hickup, together with
        that particular version(?). (7.0.224)


        /krisse

        On 27 Aug, 15:18, krisse <kristian.ni...@...> wrote:
        > Hi,
        >
        > First post here; joined to be able to ask the following question.
        >
        > Been using (g- &) vim on Linux for quite some while, but recently got
        > a mac, and I've been trying to use my favourite editor there as well.
        > However, I've been experiencing some slowdowns when editing a somewhat
        > longer latex-file.
        >
        > Latexsuite is loaded; syntax highlighting on.
        > The file is about 1950 lines.
        >
        > I've tried disabling, changing (to something else or back to default)
        > the following options, in case it would have had some impact: spell,
        > gfn, anti, macatsui, enc, tenc. But nothing was different.
        >
        > Running Mac OSX 10.4, using the Tiger binary from macvim.org, version
        > 7.0.224.
        >
        > * When using gvim from fink, everything works fine, no sluggishness.
        > * When editing the same file, same options, on linux works fine.
        >
        > * In desperation, I also tried checking out from svn (r482; v7.1.87),
        > and compiling (in osx).
        > Compile worked fine, but I'm getting a lot of errors caused by --
        > I'm assuming -- latexsuite. The (very long) listing of errors start
        > with "Error detected while processing function IMAP:" and continues
        > with a lot of "Illegal variable names", such as "phe_tex_-_164__94_",
        > "Map_tex_-_164__47_", to just name a few.
        > Additionally, I'm not seeing any scandinavian characters in the menu
        > nor "in-file".
        > The good news is, that I'm not seeing any of the sluggishness using
        > version 7.1.87. But still, as it is, it's unusable due to the lack of
        > scandinavian characters.
        >
        > The problems with the compiled vim might, for sure, be caused (or
        > rather: could be solved) by compilation configuration -- I did none,
        > except use what was given by a ./configure. Maybe there's some options
        > I'm missing?
        >
        > Since v7.1.87 "cured" the sluggishness, making that work sounds like
        > the best solution for me, if anyone can help? This said, I guess it
        > might be possible that the sluggishness will return when "full
        > functionality" is restored (no latexsuite errors; with scand. char.).
        > Another option, would be to make it work with the binary version,
        > 7.0.224 -- but I'm at a loss as to what to try next?
        >
        > Every and any ideas are appreciated! Thanks in advance.
        >
        > /krisse


        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_use" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      • krisse
        Nevermind. Got features enabled so that latexsuite works, and scandinavian characters show -- and still no sluggishness in 7.1.87. In other words: problem
        Message 3 of 3 , Aug 27, 2007
        • 0 Attachment
          Nevermind.

          Got features enabled so that latexsuite works, and scandinavian
          characters show -- and still no sluggishness in 7.1.87.

          In other words: problem solved.


          /krisse

          On 27 Aug, 15:18, krisse <kristian.ni...@...> wrote:
          > Hi,
          >
          > First post here; joined to be able to ask the following question.
          >
          > Been using (g- &) vim on Linux for quite some while, but recently got
          > a mac, and I've been trying to use my favourite editor there as well.
          > However, I've been experiencing some slowdowns when editing a somewhat
          > longer latex-file.
          >
          > Latexsuite is loaded; syntax highlighting on.
          > The file is about 1950 lines.
          >
          > I've tried disabling, changing (to something else or back to default)
          > the following options, in case it would have had some impact: spell,
          > gfn, anti, macatsui, enc, tenc. But nothing was different.
          >
          > Running Mac OSX 10.4, using the Tiger binary from macvim.org, version
          > 7.0.224.
          >
          > * When using gvim from fink, everything works fine, no sluggishness.
          > * When editing the same file, same options, on linux works fine.
          >
          > * In desperation, I also tried checking out from svn (r482; v7.1.87),
          > and compiling (in osx).
          > Compile worked fine, but I'm getting a lot of errors caused by --
          > I'm assuming -- latexsuite. The (very long) listing of errors start
          > with "Error detected while processing function IMAP:" and continues
          > with a lot of "Illegal variable names", such as "phe_tex_-_164__94_",
          > "Map_tex_-_164__47_", to just name a few.
          > Additionally, I'm not seeing any scandinavian characters in the menu
          > nor "in-file".
          > The good news is, that I'm not seeing any of the sluggishness using
          > version 7.1.87. But still, as it is, it's unusable due to the lack of
          > scandinavian characters.
          >
          > The problems with the compiled vim might, for sure, be caused (or
          > rather: could be solved) by compilation configuration -- I did none,
          > except use what was given by a ./configure. Maybe there's some options
          > I'm missing?
          >
          > Since v7.1.87 "cured" the sluggishness, making that work sounds like
          > the best solution for me, if anyone can help? This said, I guess it
          > might be possible that the sluggishness will return when "full
          > functionality" is restored (no latexsuite errors; with scand. char.).
          > Another option, would be to make it work with the binary version,
          > 7.0.224 -- but I'm at a loss as to what to try next?
          >
          > Every and any ideas are appreciated! Thanks in advance.
          >
          > /krisse


          --~--~---------~--~----~------------~-------~--~----~
          You received this message from the "vim_use" maillist.
          For more information, visit http://www.vim.org/maillist.php
          -~----------~----~----~----~------~----~------~--~---
        Your message has been successfully submitted and would be delivered to recipients shortly.