Loading ...
Sorry, an error occurred while loading the content.

"Opens With" problem

Expand Messages
  • STEVE KUNDZALA
    Uninstalled 6.2 (which I have used for 2 yrs without problems) and installed 7.1, but I can t get my .asm files to open with vim. I know how to change the
    Message 1 of 5 , Aug 1 10:46 AM
    • 0 Attachment
      Uninstalled 6.2 (which I have used for 2 yrs without problems) and
      installed 7.1, but I can't get my .asm files to "open with" vim. I know
      how to change the setting in Windows, which I did, but when I dbl-clk an
      .asm file to open it I get a black console version of vim. If I just open
      vim and load a file it is OK. Where did I go wrong? Thanks.
      Steve





      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_use" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • Albie Janse van Rensburg
      ... You re probably associating with vim.exe instead of gvim.exe . Gvim should have registered a file association with Windows whereby you should be able to
      Message 2 of 5 , Aug 2 2:23 AM
      • 0 Attachment
        STEVE KUNDZALA wrote:
        > Uninstalled 6.2 (which I have used for 2 yrs without problems) and
        > installed 7.1, but I can't get my .asm files to "open with" vim. I know
        > how to change the setting in Windows, which I did, but when I dbl-clk an
        > .asm file to open it I get a black console version of vim. If I just open
        > vim and load a file it is OK. Where did I go wrong? Thanks.
        > Steve
        >
        You're probably associating with "vim.exe" instead of "gvim.exe".

        Gvim should have registered a file association with Windows whereby you
        should be able to select "Vi Improved - A Text Editor" from the standard
        list in (right-click menu) -> Properties -> "Opens with" change button
        -> "Other Programs" section.

        At least, it does that for me.

        --

        Albie Janse van Rensburg ~ http://morph.telspace.co.za

        Please don't send me any MS Word or Powerpoint attachments
        unless it's absolutely neccessary - send simply text.
        http://www.gnu.org/philosophy/no-word-attachments.html

        We have only two things to worry about: That things will never get
        back to normal, and that they already have.


        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_use" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      • STEVE KUNDZALA
        Thanks, you re right, even after 2 years of using Vim I wasn t aware of a Vim console version! However, the right-click context menu works, but I am unable to
        Message 3 of 5 , Aug 2 3:23 AM
        • 0 Attachment
          Thanks, you're right, even after 2 years of using Vim I wasn't aware of a
          Vim console version!

          However, the right-click context menu works, but I am unable to make the
          setting permanent. When I go into the dialog to set the program name,
          there used to be an entry; "Vi Improved - A Text Editor" under the
          "Recommended Programs" heading, It's not there under my 7.1 So I select
          "Browse" and select gvim and check the "Always use the selected pgm for
          this kind of file" and exit. But it doesn't set Vim permanently, or even
          for the current run!

          I've done this many times for other applications, so I don't know what I'm
          doing wrong now. It's driving me crazy. This probably has nothing to do
          with the Vim program, but I'm hoping you may know what the problem is.
          Thanks.


          > [Original Message]
          > From: Albie Janse van Rensburg <albie.jvr@...>
          > To: <vim_use@...>
          > Date: 8/2/2007 9:25:09 AM
          > Subject: Re: "Opens With" problem
          >
          >
          > STEVE KUNDZALA wrote:
          > > Uninstalled 6.2 (which I have used for 2 yrs without problems) and
          > > installed 7.1, but I can't get my .asm files to "open with" vim. I know
          > > how to change the setting in Windows, which I did, but when I dbl-clk an
          > > .asm file to open it I get a black console version of vim. If I just
          open
          > > vim and load a file it is OK. Where did I go wrong? Thanks.
          > > Steve
          > >
          > You're probably associating with "vim.exe" instead of "gvim.exe".
          >
          > Gvim should have registered a file association with Windows whereby you
          > should be able to select "Vi Improved - A Text Editor" from the standard
          > list in (right-click menu) -> Properties -> "Opens with" change button
          > -> "Other Programs" section.
          >
          > At least, it does that for me.
          >
          > --
          >
          > Albie Janse van Rensburg ~ http://morph.telspace.co.za
          >
          > Please don't send me any MS Word or Powerpoint attachments
          > unless it's absolutely neccessary - send simply text.
          > http://www.gnu.org/philosophy/no-word-attachments.html
          >
          > We have only two things to worry about: That things will never get
          > back to normal, and that they already have.
          >
          >
          >


          --~--~---------~--~----~------------~-------~--~----~
          You received this message from the "vim_use" maillist.
          For more information, visit http://www.vim.org/maillist.php
          -~----------~----~----~----~------~----~------~--~---
        • Albie Janse van Rensburg
          ... I m not sure what would cause this behaviour - if other apps DO work correctly, then it s indicative of some problem with your Vim installation. Have you
          Message 4 of 5 , Aug 2 10:51 AM
          • 0 Attachment
            STEVE KUNDZALA wrote:
            > Thanks, "Vi Improved - A Text Editor" does not appear anywhere in the list.
            > Your suggestion is exactly what I tried, both from the context menu and the
            > properties, but it just won't accept the gvim (which I have to browse to
            > select). It will accept wordpad or notepad from the list, or any OTHER
            > program from "Browse". So, there is a system problem, I wonder if my
            > mistakenly setting the console version as the "opens with" program has
            > caused the problem?
            >
            > I can use vim by choosing "Edit with vim" from the context menu, so it's
            > not a significant problem, just maddening, I'm so used to just
            > double-clicking my files.
            >
            >

            I'm not sure what would cause this behaviour - if other apps DO work
            correctly, then it's indicative of some problem with your Vim
            installation. Have you tried un/reinstalling the application, perhaps
            in a different location (C:\Vim, just as a test), changing some options
            on the install, etc?

            --

            Albie Janse van Rensburg ~ http://morph.telspace.co.za

            Please don't send me any MS Word or Powerpoint attachments
            unless it's absolutely neccessary - send simply text.
            http://www.gnu.org/philosophy/no-word-attachments.html

            It's very inconvenient to be mortal -- you never know when everything may
            suddenly stop happening.


            --~--~---------~--~----~------------~-------~--~----~
            You received this message from the "vim_use" maillist.
            For more information, visit http://www.vim.org/maillist.php
            -~----------~----~----~----~------~----~------~--~---
          • STEVE KUNDZALA
            Thanks, good suggestion. I have tried reinstalling, but not to a different location. I had 6.2 installed in C: Vim (which I uninstalled), but I put 7.1 in
            Message 5 of 5 , Aug 2 12:10 PM
            • 0 Attachment
              Thanks, good suggestion. I have tried reinstalling, but not to a different
              location. I had 6.2 installed in C:\Vim (which I uninstalled), but I put
              7.1 in "Program Files", so I'll try putting 7.1 in C:\Vim, maybe there's a
              lingering setting from 6.2 causing the problem.


              > [Original Message]
              > From: Albie Janse van Rensburg <albie.jvr@...>
              > To: <vim_use@...>
              > Date: 8/2/2007 5:52:27 PM
              > Subject: Re: "Opens With" problem
              >
              >
              > STEVE KUNDZALA wrote:
              > > Thanks, "Vi Improved - A Text Editor" does not appear anywhere in the
              list.
              > > Your suggestion is exactly what I tried, both from the context menu and
              the
              > > properties, but it just won't accept the gvim (which I have to browse to
              > > select). It will accept wordpad or notepad from the list, or any OTHER
              > > program from "Browse". So, there is a system problem, I wonder if my
              > > mistakenly setting the console version as the "opens with" program has
              > > caused the problem?
              > >
              > > I can use vim by choosing "Edit with vim" from the context menu, so it's
              > > not a significant problem, just maddening, I'm so used to just
              > > double-clicking my files.
              > >
              > >
              >
              > I'm not sure what would cause this behaviour - if other apps DO work
              > correctly, then it's indicative of some problem with your Vim
              > installation. Have you tried un/reinstalling the application, perhaps
              > in a different location (C:\Vim, just as a test), changing some options
              > on the install, etc?
              >
              > --
              >
              > Albie Janse van Rensburg ~ http://morph.telspace.co.za
              >
              > Please don't send me any MS Word or Powerpoint attachments
              > unless it's absolutely neccessary - send simply text.
              > http://www.gnu.org/philosophy/no-word-attachments.html
              >
              > It's very inconvenient to be mortal -- you never know when everything may
              > suddenly stop happening.
              >
              >
              >


              --~--~---------~--~----~------------~-------~--~----~
              You received this message from the "vim_use" maillist.
              For more information, visit http://www.vim.org/maillist.php
              -~----------~----~----~----~------~----~------~--~---
            Your message has been successfully submitted and would be delivered to recipients shortly.