Loading ...
Sorry, an error occurred while loading the content.

current selection not working Opções Neste momento, existem muitos tópicos neste grupo que são apresentados primeiro. Para que este tópico apareça primeiro, remova esta opção de outro tópico. Ocorreu um erro ao processar o pedido. Tente novamente. Vista padrão Ver como árvore Texto proporcional Texto fixo [Clique no envelope para receber actualizações por email] Enviar-me actualizações por emailCancelar as minhas actualizações por email current selection not working

Expand Messages
  • luislupe@gmail.com
    Hi, I ve installed Slackware 12 and since then when I try to select some text inside vim, that text is not added to the selection clipboard. I ve been reading
    Message 1 of 6 , Jul 31, 2007
    • 0 Attachment
      Hi,

      I've installed Slackware 12 and since then when I try to select some
      text inside vim, that text is not added to the selection clipboard.

      I've been reading help file usr_09.txt *09.3* but it does not answer
      my problem.

      The exact symptoms are these:
      1- open text file in vim version 7.1.12;
      2- click on the beginning of a word with left button, drag to the end
      of a second word. The text only gets inverted when I release the
      button. Vim mode changes to visual but selected text doesn't show up
      in Klipper and I'm not able to paste it anywhere.
      3- I'm using kde 3.5.7. I try to select text from a vt not running
      vim, everything works fine, so this has to do with some kind of
      configuration.
      4- I tried to use set selectmode=mouse but didn't result
      5- I get this from $ vim --version
      VIM - Vi IMproved 7.1 (2007 May 12, compiled Jun 20 2007 15:33:40)
      Included patches: 1-12
      Compiled by <volke...@...>
      Huge version without GUI. Features included (+) or not (-):
      +arabic +autocmd -balloon_eval -browse ++builtin_terms +byte_offset
      +cindent
      -clientserver -clipboard +cmdline_compl +cmdline_hist +cmdline_info
      +comments
      +cryptv +cscope +cursorshape +dialog_con +diff +digraphs -dnd -ebcdic
      +emacs_tags +eval +ex_extra +extra_search +farsi +file_in_path
      +find_in_path
      +folding -footer +fork() +gettext -hangul_input +iconv +insert_expand
      +jumplist
      +keymap +langmap +libcall +linebreak +lispindent +listcmds +localmap
      +menu
      +mksession +modify_fname +mouse -mouseshape +mouse_dec +mouse_gpm
      -mouse_jsbterm +mouse_netterm +mouse_xterm +multi_byte +multi_lang -
      mzscheme
      -netbeans_intg -osfiletype +path_extra +perl +postscript +printer
      +profile
      +python +quickfix +reltime +rightleft -ruby +scrollbind +signs
      +smartindent
      -sniff +statusline -sun_workshop +syntax +tag_binary +tag_old_static
      -tag_any_white -tcl +terminfo +termresponse +textobjects +title -
      toolbar
      +user_commands +vertsplit +virtualedit +visual +visualextra +viminfo
      +vreplace
      +wildignore +wildmenu +windows +writebackup -X11 -xfontset -xim -xsmp
      -xterm_clipboard -xterm_save
      system vimrc file: "$VIM/vimrc"
      user vimrc file: "$HOME/.vimrc"
      user exrc file: "$HOME/.exrc"
      fall-back for $VIM: "/usr/share/vim"
      Compilation: gcc -c -I. -Iproto -DHAVE_CONFIG_H -O2 -
      D_REENTRANT -D_GNU_SOURCE -DTHREADS_HAVE_PIDS -I/usr/local/include -
      D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I/usr/lib/perl5/5.8.8/
      i486-
      linux-thread-multi/CORE -I/usr/include/python2.5 -pthread
      Linking: gcc -Wl,-E -L/usr/local/lib -o vim -lncurses -lacl
      -
      lgpm -Wl,-E -L/usr/local/lib /usr/lib/perl5/5.8.8/i486-linux-
      thread-
      multi/auto/DynaLoader/DynaLoader.a -L/usr/lib/perl5/5.8.8/i486-linux-
      thread-multi/CORE -lperl -lcrypt -lutil -lc -L/usr/lib/python2.5/
      config -lpython2.5 -lpthread -lutil -lm -Xlinker -export-dynamic

      What should I do to fix this?

      Luis


      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_use" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • Charles E Campbell Jr
      ... One problem with helping you is that you didn t give any settings for the options that I just mentioned. Are you using vim or gvim? Are you using
      Message 2 of 6 , Jul 31, 2007
      • 0 Attachment
        luislupe@... wrote:

        >Hi,
        >
        >I've installed Slackware 12 and since then when I try to select some
        >text inside vim, that text is not added to the selection clipboard.
        >
        >I've been reading help file usr_09.txt *09.3* but it does not answer
        >my problem.
        >
        >
        Have you done your "due diligence" yet? Ie. read the manual:

        :he 'mouse'
        :he 'mousemodel'
        :he 'mouse-using'
        :he 'clipboard'
        :he x11-selection

        One problem with helping you is that you didn't give any settings for
        the options that I just mentioned.
        Are you using vim or gvim? Are you using "behave"? Do you have :set
        nocp in your <.vimrc>?

        Regards,
        Chip Campbell


        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_use" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      • Tony Mechelynck
        ... [...] Here s how Vim is designed to work: First, all the following only works in a clipboard-aware version of Vim (compiled with +clipboard, which shows up
        Message 3 of 6 , Jul 31, 2007
        • 0 Attachment
          luislupe@... wrote:
          > Hi,
          >
          > I've installed Slackware 12 and since then when I try to select some
          > text inside vim, that text is not added to the selection clipboard.
          >
          > I've been reading help file usr_09.txt *09.3* but it does not answer
          > my problem.
          [...]

          Here's how Vim is designed to work:

          First, all the following only works in a clipboard-aware version of Vim
          (compiled with +clipboard, which shows up in the output of ":version" and by a
          nonzero reply to ":echo has('clipboard')" (without the double quotes). If your
          version of Vim is compiled with -clipboard, it plain won't know that your
          system has a clipboard.

          - Yanking or deleting anything into "+ puts it onto the clipboard (where other
          applications can paste it using Edit => Paste).

          - Yanking or deleting anything into "* puts it either into the X selection
          (where other applications can paste it using the middle mouse button), or,
          when using a non-X GUI (e.g. under Windows), same as "+ above.

          - If 'clipboard' includes "autoselect" and/or 'guioptions' includes "a",
          whatever you select in Visual mode is automagically copied into "* (I don't
          know whether it applies to Select mode too).

          - if 'clipboard' includes "unnamed", whatever you yank or delete without
          specifying a register, gets copied to the X-selection (or the clipboard if not
          under X), i.e., register "* mimics register "".

          Personally I find the latter two methods wasteful and "un-Vim-like" (but
          YMMV): I keep 'clipboard' set to the empty string, no a or A in 'guioptions',
          and whenever I want to copy or cut to the clipboard, I use "+ explicitly in a
          delete or yank command (or + in a :del or :yank ex-command). Similarly, to
          paste from the clipboard I use "+p "+P or :put+ explicitly. (Cut, Copy or
          Paste, from the Edit menu, would also work.) I don't use the X selection or
          the middle-mouse paste.

          Using the clipboard is never necessary when moving or copying text within a
          single instance of Vim. You can use the default register instead, or the named
          registers "a to "z if you want to remember it for later, even across sessions.

          See also
          :help registers
          :help 'clipboard'
          :help 'guioptions'
          :help d
          :help x
          :help :d
          :help y
          :help :y
          :help p
          :help P
          :help :put


          Best regards,
          Tony.
          --
          Life is a gift, living is an art. (Bram Moolenaar)

          --~--~---------~--~----~------------~-------~--~----~
          You received this message from the "vim_use" maillist.
          For more information, visit http://www.vim.org/maillist.php
          -~----------~----~----~----~------~----~------~--~---
        • Tony Mechelynck
          ... After replying, I just noticed: it s much simpler than that: he s using a Huge version, yes, but with -clipboard. Clipboard support is not compiled-in. So
          Message 4 of 6 , Jul 31, 2007
          • 0 Attachment
            Charles E Campbell Jr wrote:
            > luislupe@... wrote:
            >
            >> Hi,
            >>
            >> I've installed Slackware 12 and since then when I try to select some
            >> text inside vim, that text is not added to the selection clipboard.
            >>
            >> I've been reading help file usr_09.txt *09.3* but it does not answer
            >> my problem.
            >>
            >>
            > Have you done your "due diligence" yet? Ie. read the manual:
            >
            > :he 'mouse'
            > :he 'mousemodel'
            > :he 'mouse-using'
            > :he 'clipboard'
            > :he x11-selection
            >
            > One problem with helping you is that you didn't give any settings for
            > the options that I just mentioned.
            > Are you using vim or gvim? Are you using "behave"? Do you have :set
            > nocp in your <.vimrc>?
            >
            > Regards,
            > Chip Campbell

            After replying, I just noticed: it's much simpler than that: he's using a Huge
            version, yes, but with -clipboard. Clipboard support is not compiled-in. So
            nothing he does in Vim will affect the clipboard.


            Best regards,
            Tony.
            --
            Feel disillusioned? I've got some great new illusions ...

            --~--~---------~--~----~------------~-------~--~----~
            You received this message from the "vim_use" maillist.
            For more information, visit http://www.vim.org/maillist.php
            -~----------~----~----~----~------~----~------~--~---
          • luislupe@gmail.com
            Hi, ... I would like to thank all of you for your help. I ve already found the cause for this misbehaving . It s not because -clipboard , since this was
            Message 5 of 6 , Aug 2, 2007
            • 0 Attachment
              Hi,

              On 1 Ago, 01:37, Tony Mechelynck <antoine.mechely...@...> wrote:
              > Charles E Campbell Jr wrote:
              >
              >
              >
              > > luisl...@... wrote:
              >
              > >> Hi,
              >
              > >> I've installed Slackware 12 and since then when I try to select some
              > >> text inside vim, that text is not added to the selection clipboard.
              >
              > >> I've been reading help file usr_09.txt *09.3* but it does not answer
              > >> my problem.
              >
              > > Have you done your "due diligence" yet? Ie. read the manual:
              >
              > > :he 'mouse'
              > > :he 'mousemodel'
              > > :he 'mouse-using'
              > > :he 'clipboard'
              > > :he x11-selection
              >
              > > One problem with helping you is that you didn't give any settings for
              > > the options that I just mentioned.
              > > Are you using vim or gvim? Are you using "behave"? Do you have :set
              > > nocp in your <.vimrc>?
              >
              > > Regards,
              > > Chip Campbell
              >
              > After replying, I just noticed: it's much simpler than that: he's using a Huge
              > version, yes, but with -clipboard. Clipboard support is not compiled-in. So
              > nothing he does in Vim will affect the clipboard.
              >

              I would like to thank all of you for your help.

              I've already found the cause for this 'misbehaving'. It's not because
              '-clipboard', since this was also default for the vim version of Slack
              11 which was working as I want.

              In global vimrc and ~/.vimrc, there was an option 'mouse=a' that was
              responsible for this strange (for me) behavior. If I remove it or if
              I set mouse=c I solve the issue.

              Luis


              --~--~---------~--~----~------------~-------~--~----~
              You received this message from the "vim_use" maillist.
              For more information, visit http://www.vim.org/maillist.php
              -~----------~----~----~----~------~----~------~--~---
            • luislupe@gmail.com
              Hi, ... I would like to thank all of you for your help. I ve already found the cause for this misbehaving . It s not because -clipboard , since this was
              Message 6 of 6 , Aug 2, 2007
              • 0 Attachment
                Hi,

                On 1 Ago, 01:37, Tony Mechelynck <antoine.mechely...@...> wrote:
                > Charles E Campbell Jr wrote:
                >
                >
                >
                > > luisl...@... wrote:
                >
                > >> Hi,
                >
                > >> I've installed Slackware 12 and since then when I try to select some
                > >> text inside vim, that text is not added to the selection clipboard.
                >
                > >> I've been reading help file usr_09.txt *09.3* but it does not answer
                > >> my problem.
                >
                > > Have you done your "due diligence" yet? Ie. read the manual:
                >
                > > :he 'mouse'
                > > :he 'mousemodel'
                > > :he 'mouse-using'
                > > :he 'clipboard'
                > > :he x11-selection
                >
                > > One problem with helping you is that you didn't give any settings for
                > > the options that I just mentioned.
                > > Are you using vim or gvim? Are you using "behave"? Do you have :set
                > > nocp in your <.vimrc>?
                >
                > > Regards,
                > > Chip Campbell
                >
                > After replying, I just noticed: it's much simpler than that: he's using a Huge
                > version, yes, but with -clipboard. Clipboard support is not compiled-in. So
                > nothing he does in Vim will affect the clipboard.
                >

                I would like to thank all of you for your help.

                I've already found the cause for this 'misbehaving'. It's not because
                '-clipboard', since this was also default for the vim version of Slack
                11 which was working as I want.

                In global vimrc and ~/.vimrc, there was an option 'mouse=a' that was
                responsible for this strange (for me) behavior. If I remove it or if
                I set mouse=c I solve the issue.

                Luis


                --~--~---------~--~----~------------~-------~--~----~
                You received this message from the "vim_use" maillist.
                For more information, visit http://www.vim.org/maillist.php
                -~----------~----~----~----~------~----~------~--~---
              Your message has been successfully submitted and would be delivered to recipients shortly.