Loading ...
Sorry, an error occurred while loading the content.

how to stop vim highlighting pairs of symbol?

Expand Messages
  • Zhang Weiwu
    Dear all With vim there is a feature that of cursor is on a pair symbol (typically a parentheses), the corresponding pairing symbol is highlighted. This is
    Message 1 of 5 , Jul 21, 2007
    • 0 Attachment
      Dear all

      With vim there is a feature that of cursor is on a pair symbol
      (typically a parentheses), the corresponding pairing symbol is
      highlighted. This is annoying for me because when my cursor is just
      passing by a pair symbol, it slowed down cursor movement and make it
      difficult to stop cursor at wanted place.

      I wish to turn off this behavior but cannot find a clue in help
      documents. I wish to either close it or make highlight happen only after
      certain period of time, e.g. if cursor stop on a pair symbol, highlight
      the corresponding pair symbol only after I paused 1 second (cursor stay
      there 1 second) so I am not getting disturbed if my cursor is just
      passing by a pair symbol

      Thanks!

      --
      锐业软服(国内业务) http://www.realss.cn
      Real SoftService http://www.realss.com
      销售咨询(Sales Department): 0086 592 20 99987 (Chinese, German,
      English)
      国际业务(International Sales): 0086 10 8460 6011 (German and English)
      联系:厦门大学科技园,嘉庚二号楼6楼
      邮政:厦门大学2312号信箱(邮编361005)


      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_use" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • sc
      ... sc --~--~---------~--~----~------------~-------~--~----~ You received this message from the vim_use maillist. For more information, visit
      Message 2 of 5 , Jul 21, 2007
      • 0 Attachment
        On Sun, Jul 22, 2007 at 12:44:17PM +0800, Zhang Weiwu wrote:
        >
        > Dear all
        >
        > With vim there is a feature that of cursor is on a pair symbol
        > (typically a parentheses), the corresponding pairing symbol is
        > highlighted. This is annoying for me because when my cursor is just
        > passing by a pair symbol, it slowed down cursor movement and make it
        > difficult to stop cursor at wanted place.
        >
        > I wish to turn off this behavior but cannot find a clue in help
        > documents. I wish to either close it or make highlight happen only after

        :he showmatch
        :he matchpairs

        sc

        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_use" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      • Gary Johnson
        ... Also ... HTH, Gary --~--~---------~--~----~------------~-------~--~----~ You received this message from the vim_use maillist. For more information, visit
        Message 3 of 5 , Jul 21, 2007
        • 0 Attachment
          On 2007-07-22, sc <toothpik@...> wrote:
          > On Sun, Jul 22, 2007 at 12:44:17PM +0800, Zhang Weiwu wrote:
          > >
          > > Dear all
          > >
          > > With vim there is a feature that of cursor is on a pair symbol
          > > (typically a parentheses), the corresponding pairing symbol is
          > > highlighted. This is annoying for me because when my cursor is just
          > > passing by a pair symbol, it slowed down cursor movement and make it
          > > difficult to stop cursor at wanted place.
          > >
          > > I wish to turn off this behavior but cannot find a clue in help
          > > documents. I wish to either close it or make highlight happen only after
          >
          > :he showmatch
          > :he matchpairs

          Also

          :he matchparen

          HTH,
          Gary

          --~--~---------~--~----~------------~-------~--~----~
          You received this message from the "vim_use" maillist.
          For more information, visit http://www.vim.org/maillist.php
          -~----------~----~----~----~------~----~------~--~---
        • Zhang Weiwu
          ... I ve read he showmatch & matchpairs before posting my question, both seems not related to the issue I am having. As Gray Johnson wrote, matchparen is the
          Message 4 of 5 , Jul 21, 2007
          • 0 Attachment
            On Sat, 2007-07-21 at 22:24 -0700, Gary Johnson wrote:
            > > :he showmatch
            > > :he matchpairs
            >
            > Also
            >
            > :he matchparen

            I've read he showmatch & matchpairs before posting my question, both
            seems not related to the issue I am having. As Gray Johnson wrote,
            matchparen is the right place to look. Thanks.


            --~--~---------~--~----~------------~-------~--~----~
            You received this message from the "vim_use" maillist.
            For more information, visit http://www.vim.org/maillist.php
            -~----------~----~----~----~------~----~------~--~---
          • Tony Mechelynck
            ... see :help :3match Best regards, Tony. -- As you reach for the web, a venomous spider appears. Unable to pull your hand away in time, the spider
            Message 5 of 5 , Jul 22, 2007
            • 0 Attachment
              Zhang Weiwu wrote:
              > Dear all
              >
              > With vim there is a feature that of cursor is on a pair symbol
              > (typically a parentheses), the corresponding pairing symbol is
              > highlighted. This is annoying for me because when my cursor is just
              > passing by a pair symbol, it slowed down cursor movement and make it
              > difficult to stop cursor at wanted place.
              >
              > I wish to turn off this behavior but cannot find a clue in help
              > documents. I wish to either close it or make highlight happen only after
              > certain period of time, e.g. if cursor stop on a pair symbol, highlight
              > the corresponding pair symbol only after I paused 1 second (cursor stay
              > there 1 second) so I am not getting disturbed if my cursor is just
              > passing by a pair symbol
              >
              > Thanks!
              >

              :3match none

              see ":help :3match"


              Best regards,
              Tony.
              --
              As you reach for the web, a venomous spider appears. Unable to pull
              your hand away in time, the spider promptly, but politely, bites you.
              The venom takes affect quickly causing your lips to turn plaid along
              with your complexion. You become dazed, and in your stupor you fall
              from the limbs of the tree. Snap! Your head falls off and rolls all
              over the ground. The instant before you croak, you hear the whoosh of
              a vacuum being filled by the air surrounding your head. Worse yet, the
              spider is suing you for damages.

              --~--~---------~--~----~------------~-------~--~----~
              You received this message from the "vim_use" maillist.
              For more information, visit http://www.vim.org/maillist.php
              -~----------~----~----~----~------~----~------~--~---
            Your message has been successfully submitted and would be delivered to recipients shortly.