Loading ...
Sorry, an error occurred while loading the content.

Re: who actually controls the window size of my gvim?

Expand Messages
  • Zhaojun WU
    Hi, Tony and John, As I posted in my first email, I am also setting the guifont *before* the columns and lines setting. I think I find out where those
    Message 1 of 5 , Apr 30 2:57 AM
    • 0 Attachment
      Hi, Tony and John,

      As I posted in my first email, I am also setting the guifont *before*
      the "columns and lines" setting.

      I think I find out where those strange lines and columns number are
      from after I check the "columns" and "lines"settings in the gvim
      opened from my "urxvt" terminal. It used the same geometry of the
      "urxvt" window as its "lines x columns", no matter what I set them in
      .vimrc.

      I am a bit busy right now so cannot figure it out right now. I will
      get back to this issue in the coming days.

      Thanks,

      Zhaojun

      On 4/30/07, John Orr <john.orr@...> wrote:
      >
      > On Monday 30 April 2007 19:21, A.J.Mechelynck wrote:
      > > John Orr wrote:
      > > > Two cents worth - I've long had problems like this, on Suse Linux, where something, the OS I have assumed, or the X graphics system, takes control of the sizing of my gvim application.
      > > > The size is initially set by my lines and columns settings, but something else resizes it afterwards, making lines and columns no longer valid.
      > > > The only reliable solution I found was to write a function to resize my window, and to install an autocmd using the CursorHold event, with a suitable updatetime set.
      > > > I tried using other autocmds, eg GUIEnter and VIMEnter, but they fired before the OS had its say.
      > > > The idea - let the OS size gvim as it wants, and a second or so afterwards, with no key strokes pressed, the Cursorhold event fires and my function fixes things.
      > > > It's a horrible solution, and wastes time on startup - but it's quicker than me manually resizing, and I've got no better solution.
      > > > I can provide some code if you want (though I'd love someone to resolve it properly).
      > >
      > > I'm on SuSE Linux too, also with a GTK2 GUI, and I don't need that kind of hack.
      > >
      > > Are you sure you set your lines & columns _after_ you set your 'guifont' ?
      > > Changing the font means changing the character cell size, which in turn
      > > changes the maximum character height & width of the editing area.
      >
      > You had my hopes up for a moment there Tony, as I raced to my vimrc... but alas, definitely setting guifont before lines and columns (and winpos).
      > I'm probably doing something else odd, but I've no idea what.
      >
      > Thanks,
      > John
      >
      > >
      > >
      > > Best regards,
      > > Tony.
      > > --
      > > It is not true that life is one damn thing after another -- it's one
      > > damn thing over and over.
      > > -- Edna St. Vincent Millay
      > >
      > >
      >


      --
      Best,
      Zhaojun (Joseph)
    Your message has been successfully submitted and would be delivered to recipients shortly.