Loading ...
Sorry, an error occurred while loading the content.

Re: Monospaced font problem

Expand Messages
  • Tobia
    ... I emailed him too. We share our first language, so maybe he will understand me better. ... I had a look at the TTF file format[1] and it s quite easy. I
    Message 1 of 6 , Apr 1 4:55 AM
    • 0 Attachment
      Pablo Arantes wrote:
      > I contacted the author of Pragmata to share my concerns but he
      > couldn't help me much in this respect. I explained him the problem but
      > I'm not sure he understood it.

      I emailed him too. We share our first language, so maybe he will
      understand me better.


      > I wonder if there is a feasible way to change this specification myself.

      I had a look at the TTF file format[1] and it's quite easy. I have
      attached a small Python script that will query, set or clear the
      monospaced flag on a TTF file. Run it with no arguments to get help.

      Remember to operate on a copy of the font file and to install/uninstall
      the font through Windows's Control Panel. That is: make a copy of the
      font file; set the flag on it; uninstall the currently installed font;
      install the modified version; profit.


      Tobia

      [1]
      http://developer.apple.com/textfonts/TTRefMan/RM06/Chap6.html
      http://developer.apple.com/textfonts/TTRefMan/RM06/Chap6post.html
    • Pablo Arantes
      Tobia, Man, you re a genius! Your script solved the problem. I ran it and now every program (including gvim, of course) recognizes Pragmata as being
      Message 2 of 6 , Apr 2 2:20 PM
      • 0 Attachment
        Tobia,

        Man, you're a genius! Your script solved the problem. I ran it and now
        every program (including gvim, of course) recognizes Pragmata as being
        monospaced.

        Thank you very much.

        --
        Pablo

        ---------- Forwarded message ----------
        From: Tobia <tobia.conforto@...>
        To: 'Vim mailing list' <vim@...>
        Date: Sun, 1 Apr 2007 13:55:46 +0200
        Subject: Re: Monospaced font problem
        Pablo Arantes wrote:
        > I contacted the author of Pragmata to share my concerns but he
        > couldn't help me much in this respect. I explained him the problem but
        > I'm not sure he understood it.

        I emailed him too. We share our first language, so maybe he will
        understand me better.


        > I wonder if there is a feasible way to change this specification myself.

        I had a look at the TTF file format[1] and it's quite easy. I have
        attached a small Python script that will query, set or clear the
        monospaced flag on a TTF file. Run it with no arguments to get help.

        Remember to operate on a copy of the font file and to install/uninstall
        the font through Windows's Control Panel. That is: make a copy of the
        font file; set the flag on it; uninstall the currently installed font;
        install the modified version; profit.


        Tobia

        [1]
        http://developer.apple.com/textfonts/TTRefMan/RM06/Chap6.html
        http://developer.apple.com/textfonts/TTRefMan/RM06/Chap6post.html
      Your message has been successfully submitted and would be delivered to recipients shortly.