Loading ...
Sorry, an error occurred while loading the content.
 

Re: I can't make gvim the default application for .txt files in WinXP

Expand Messages
  • A.J.Mechelynck
    ... [...] I m not sure; I think it s something in the registry. Maybe the install program should do it. Have you installed Vim from Steve Hall s self-installer
    Message 1 of 9 , Dec 1, 2006
      Jeffrey Robertson wrote:
      > No. That's my problem. How does gvim tell Windows to make itself an
      > option in this list?
      [...]


      I'm not sure; I think it's something in the registry. Maybe the install
      program should do it. Have you installed Vim from Steve Hall's self-installer
      https://sourceforge.net/project/showfiles.php?group_id=43866&package_id=39721
      ? If you haven't, try doing it.

      P.S. Please use bottom-posting or inter-posting in the Vim mailing lists.


      Best regards,
      Tony.
    • Bill McCarthy
      ... Like most of you on Win XP, I build my own Vim and Gvim (for Gvim I specify OLE=yes). From Windows Explorer, when I click on a .txt file, Gvim comes up
      Message 2 of 9 , Dec 12, 2006
        On Tue 12-Dec-06 4:43pm -0600, Jeffrey Robertson wrote:

        > A.J.Mechelynck wrote:

        >> I'm not sure; I think it's something in the registry. Maybe the install
        >> program should do it. Have you installed Vim from Steve Hall's
        >> self-installer
        >> https://sourceforge.net/project/showfiles.php?group_id=43866&package_id=
        >> 39721
        >> ? If you haven't, try doing it.

        > I've now done this, and it's improved things but not fixed them.
        >
        > I get the "open with vim" option in my right-click menu, and this
        > launches
        > the file into gvim, so that's good. But if I simply double click, it
        > launches to regular vim. That is, it opens what looks like a shell
        > window and tries to open the file. It gets confused by spaces in the
        > path, so it never actually succeeds in opening the file.
        >
        > If it go to "Open With..." and specify "Vi Improved - A Text Editor",
        > I get the same results. How can I make "Open With" launch to gvim?
        >
        > For those joining the discussion late, I'm using Windows XP.

        Like most of you on Win XP, I build my own Vim and Gvim (for
        Gvim I specify OLE=yes). From Windows Explorer, when I
        click on a .txt file, Gvim comes up for the file.

        I just tried clicking on a .vim file and received a dialog
        (see ONEofTWO.gif) telling me that Windows cannot open the
        file and asking me to search the web or select the program
        from a list. I picked select the program and got a second
        dialog.

        That dialog (see TWOofTWO.gif) let me pick Gvim and check
        the box to use Gvim for all .vim files.

        After performing these two tasks, Windows Explorer now opens
        Gvim whenever I click on a .vim file.

        I created a directory name with spaces and put a file in
        there with spaces in its name and ending with .vim - it
        opened fine from explorer.

        [Without the attached GIFs]

        --
        Best regards,
        Bill
      • Jeffrey Robertson
        ... install ... https://sourceforge.net/project/showfiles.php?group_id=43866&package_id= ... You say it let you pick Gvim. I assume you mean you selected Vi
        Message 3 of 9 , Dec 13, 2006
          > Jeffrey Robertson wrote:
          >> No. That's my problem. How does gvim tell Windows to make itself an
          >> option in this list?
          > [...]
          >
          >
          > A.J.Mechelynck wrote:
          > I'm not sure; I think it's something in the registry. Maybe the
          install
          > program should do it. Have you installed Vim from Steve Hall's
          > self-installer
          >
          https://sourceforge.net/project/showfiles.php?group_id=43866&package_id=
          > 39721
          > ? If you haven't, try doing it.
          >
          >
          > I've now done this, and it's improved things but not fixed them.
          >
          > I get the "open with vim" option in my right-click menu, and this
          > launches
          > the file into gvim, so that's good. But if I simply double click, it
          > launches to regular vim. That is, it opens what looks like a shell
          > window and tries to open the file. It gets confused by spaces in the
          > path, so it never actually succeeds in opening the file.
          >
          > If it go to "Open With..." and specify "Vi Improved - A Text Editor",
          > I get the same results. How can I make "Open With" launch to gvim?
          >
          > For those joining the discussion late, I'm using Windows XP.

          Bill McCarthy wrote:
          > Like most of you on Win XP, I build my own Vim and Gvim (for
          > Gvim I specify OLE=yes). From Windows Explorer, when I
          > click on a .txt file, Gvim comes up for the file.
          >
          > I just tried clicking on a .vim file and received a dialog
          > (see ONEofTWO.gif) telling me that Windows cannot open the
          > file and asking me to search the web or select the program
          > from a list. I picked select the program and got a second
          > dialog.
          >
          > That dialog (see TWOofTWO.gif) let me pick Gvim and check
          > the box to use Gvim for all .vim files.
          >
          > After performing these two tasks, Windows Explorer now opens
          > Gvim whenever I click on a .vim file.
          >
          > I created a directory name with spaces and put a file in
          > there with spaces in its name and ending with .vim - it
          > opened fine from explorer.

          You say it let you pick Gvim. I assume you mean you selected
          "Vi Improved - A Text Editor". I do the same thing, but
          it launches regular vim, not gvim.

          If this is not what you meant, please clarify. If anyone
          can explain my problems, please do so.

          -- Jeff.
        • Bill McCarthy
          ... That s exactly what I mean. ... Looking through my registry tree, Vi Improved - A Text Editor appears exactly 4 times, 2 each as data in:
          Message 4 of 9 , Dec 13, 2006
            On Wed 13-Dec-06 9:26am -0600, you wrote:

            > Bill McCarthy wrote:
            >> Like most of you on Win XP, I build my own Vim and Gvim (for
            >> Gvim I specify OLE=yes). From Windows Explorer, when I
            >> click on a .txt file, Gvim comes up for the file.
            >>
            >> I just tried clicking on a .vim file and received a dialog
            >> (see ONEofTWO.gif) telling me that Windows cannot open the
            >> file and asking me to search the web or select the program
            >> from a list. I picked select the program and got a second
            >> dialog.
            >>
            >> That dialog (see TWOofTWO.gif) let me pick Gvim and check
            >> the box to use Gvim for all .vim files.
            >>
            >> After performing these two tasks, Windows Explorer now opens
            >> Gvim whenever I click on a .vim file.
            >>
            >> I created a directory name with spaces and put a file in
            >> there with spaces in its name and ending with .vim - it
            >> opened fine from explorer.

            > You say it let you pick Gvim. I assume you mean you selected
            > "Vi Improved - A Text Editor". I do the same thing, but
            > it launches regular vim, not gvim.

            That's exactly what I mean.

            > If this is not what you meant, please clarify. If anyone
            > can explain my problems, please do so.

            Looking through my registry tree, "Vi Improved - A Text
            Editor" appears exactly 4 times, 2 each as data in:

            foo\Microsoft\Windows\ShellNoRoam\MUICache

            Where "foo" is either:

            HKEY_CURRENT_USER\Software
            HKEY_USERS\S1-1-5-21-.... (long Key)

            The 2 Values are:

            C:\Vim\vim70\gvim.exe (where I execute from)
            C:\vim\vim70\src\gvim.exe (where make puts it)

            Searching my registry tree for any key, value or date
            containing "vim.exe" I only find things containing gvim.exe.

            Yes, I have and use vim.exe, but there are no references to
            it in the registry.

            --
            Best regards,
            Bill
          Your message has been successfully submitted and would be delivered to recipients shortly.