Loading ...
Sorry, an error occurred while loading the content.

RE: I can't make gvim the default application for .txt files in WinXP

Expand Messages
  • Jeffrey Robertson
    That s just a different way into the same dialog box I used in the first place. It doesn t work for me. Although I can select gvim.exe, it doesn t actually
    Message 1 of 9 , Dec 1, 2006
    View Source
    • 0 Attachment
      That's just a different way into the same dialog box I used in
      the first place. It doesn't work for me. Although I can select
      gvim.exe, it doesn't actually take effect. To be clear:
      1) I click Change It says notepad is the default.
      2) I click browse, and pick gvim.exe, and click Open.
      3) Notepad is still listed as the default.

      Does gvim have to "register" something with Windows to get recognized
      as a valid choice?

      -- Jeff.

      -----Original Message-----
      From: Krall, Ed-P27726 [mailto:Ed.Krall@...]
      Sent: Friday, December 01, 2006 12:45 PM
      To: Robertson, Jeffrey (CAR:QW32); Dudley Fox; vim@...
      Subject: RE: I can't make gvim the default application for .txt files in
      WinXP

      I have many file types mapped into GVIM: .txt, .lst, .cfg, and others.

      Go to Windows explorer ("my computer"), tools --> Folder Options, and
      select the File Types tab. Select the extestion or file type, click
      the Change button, and select or specify the application.


      Ed





      -----Original Message-----
      From: Jeffrey Robertson [mailto:jeffr@...]
      Sent: Friday, December 01, 2006 9:08 AM
      To: Dudley Fox; vim@...
      Subject: RE: I can't make gvim the default application for .txt files in
      WinXP

      Thanks for replying.

      I do this and it doesn't work.

      By "gvim", I assume you mean gvim.exe.

      When I do this, after I select gvim.exe and that dialog closes, the
      "Open with" dialog still shows Notepad selected. I can't get gvim to
      show up as an option in the program chooser list. I can get vim, but I
      want gvim.

      Any idea what's up?


      From: Dudley Fox [mailto:dudley.fox@...]
      Sent: Thursday, November 30, 2006 6:06 PM
      To: Robertson, Jeffrey (CAR:QW32); vim@...
      Subject: Re: I can't make gvim the default application for .txt
      files in WinXP


      Jeffrey,
      Try this:

      1. Right click on a .txt file
      2. Select the "Open With" menu option
      3. Select the "Choose Program..." menu option
      4. Check the "Always use the selected program to open this kind
      of file" checkbox
      5. Select gvim, you may have to browse to it.
      6. Click ok.


      This should work for you, though you will have to do this for
      each file type you want gvim to open. If that does not work please let
      me know. There are other ways to achieve this, but this is the easiest.

      Sincerely,
      Dudley


      On 11/30/06, Jeffrey Robertson <jeffr@...> wrote:

      Hi:

      I just installed Vim 7.0 on my Windows XP box. I cannot
      force files
      with .txt (or any other extension) to automatically open
      in gvim.
      However, I do have the "edit with vim" option in my
      right-click menu.

      If I try to specify a new program to use for .txt and
      navigate to the
      folder with gvim.exe, even if I select it, it doesn't
      take effect
      (Notepad is still the default).

      I was able to do this on my old Win2K box with Vim
      6.something.

      What's up?

      Thanks,
      Jeff
    • Russell Bateman
      I have had inexplicable and inconsistent trouble with Windoz doing this at least since back in version 98. It s infuriating.
      Message 2 of 9 , Dec 1, 2006
      View Source
      • 0 Attachment
        I have had inexplicable and inconsistent trouble with Windoz doing this
        at least since back in version 98. It's infuriating.




        Jeffrey Robertson wrote:
        > That's just a different way into the same dialog box I used in
        > the first place. It doesn't work for me. Although I can select
        > gvim.exe, it doesn't actually take effect. To be clear:
        > 1) I click Change It says notepad is the default.
        > 2) I click browse, and pick gvim.exe, and click Open.
        > 3) Notepad is still listed as the default.
        >
        > Does gvim have to "register" something with Windows to get recognized
        > as a valid choice?
        >
        > -- Jeff.
        >
        > -----Original Message-----
        > From: Krall, Ed-P27726 [mailto:Ed.Krall@...]
        > Sent: Friday, December 01, 2006 12:45 PM
        > To: Robertson, Jeffrey (CAR:QW32); Dudley Fox; vim@...
        > Subject: RE: I can't make gvim the default application for .txt files in
        > WinXP
        >
        > I have many file types mapped into GVIM: .txt, .lst, .cfg, and others.
        >
        > Go to Windows explorer ("my computer"), tools --> Folder Options, and
        > select the File Types tab. Select the extestion or file type, click
        > the Change button, and select or specify the application.
        >
        >
        > Ed
        >
        >
        >
        >
        >
        > -----Original Message-----
        > From: Jeffrey Robertson [mailto:jeffr@...]
        > Sent: Friday, December 01, 2006 9:08 AM
        > To: Dudley Fox; vim@...
        > Subject: RE: I can't make gvim the default application for .txt files in
        > WinXP
        >
        > Thanks for replying.
        >
        > I do this and it doesn't work.
        >
        > By "gvim", I assume you mean gvim.exe.
        >
        > When I do this, after I select gvim.exe and that dialog closes, the
        > "Open with" dialog still shows Notepad selected. I can't get gvim to
        > show up as an option in the program chooser list. I can get vim, but I
        > want gvim.
        >
        > Any idea what's up?
        >
        >
        > From: Dudley Fox [mailto:dudley.fox@...]
        > Sent: Thursday, November 30, 2006 6:06 PM
        > To: Robertson, Jeffrey (CAR:QW32); vim@...
        > Subject: Re: I can't make gvim the default application for .txt
        > files in WinXP
        >
        >
        > Jeffrey,
        > Try this:
        >
        > 1. Right click on a .txt file
        > 2. Select the "Open With" menu option
        > 3. Select the "Choose Program..." menu option
        > 4. Check the "Always use the selected program to open this kind
        > of file" checkbox
        > 5. Select gvim, you may have to browse to it.
        > 6. Click ok.
        >
        >
        > This should work for you, though you will have to do this for
        > each file type you want gvim to open. If that does not work please let
        > me know. There are other ways to achieve this, but this is the easiest.
        >
        > Sincerely,
        > Dudley
        >
        >
        > On 11/30/06, Jeffrey Robertson <jeffr@...> wrote:
        >
        > Hi:
        >
        > I just installed Vim 7.0 on my Windows XP box. I cannot
        > force files
        > with .txt (or any other extension) to automatically open
        > in gvim.
        > However, I do have the "edit with vim" option in my
        > right-click menu.
        >
        > If I try to specify a new program to use for .txt and
        > navigate to the
        > folder with gvim.exe, even if I select it, it doesn't
        > take effect
        > (Notepad is still the default).
        >
        > I was able to do this on my old Win2K box with Vim
        > 6.something.
        >
        > What's up?
        >
        > Thanks,
        > Jeff
        >
        >
        >
        >
        >
        >
        >
        >
      • Jeffrey Robertson
        No. That s my problem. How does gvim tell Windows to make itself an option in this list? ... From: Sean Plank [mailto:sapsolaris@yahoo.com] Sent: Friday,
        Message 3 of 9 , Dec 1, 2006
        View Source
        • 0 Attachment
          No. That's my problem. How does gvim tell Windows to make itself an
          option in this list?




          -----Original Message-----
          From: Sean Plank [mailto:sapsolaris@...]
          Sent: Friday, December 01, 2006 2:27 PM
          To: vim@...
          Subject: Re: I can't make gvim the default application for .txt files in
          WinXP

          When I use tools --> Folder Options > File Types tab, Select the
          extestion or
          file type, click the Change button, browse to gvim. gvim shows up as "Vi
          Improved - A Text Editor" in the Open with dialog box. Is that what you
          are seeing?

          "Vi Improved - A Text Editor" is gvim

          Sean Plank
          253.815.9626 Home


          ----- Original Message ----
          From: Jeffrey Robertson <jeffr@...>
          To: Dudley Fox <dudley.fox@...>; vim@...
          Sent: Friday, December 1, 2006 10:44:40 AM
          Subject: RE: I can't make gvim the default application for .txt files in
          WinXP


          Doesn't matter whether that box is ticked or not. I can't open with
          gvim.



          ________________________________________________________________________
          ____________
          Do you Yahoo!?
          Everyone is raving about the all-new Yahoo! Mail beta.
          http://new.mail.yahoo.com
        • A.J.Mechelynck
          ... [...] I m not sure; I think it s something in the registry. Maybe the install program should do it. Have you installed Vim from Steve Hall s self-installer
          Message 4 of 9 , Dec 1, 2006
          View Source
          • 0 Attachment
            Jeffrey Robertson wrote:
            > No. That's my problem. How does gvim tell Windows to make itself an
            > option in this list?
            [...]


            I'm not sure; I think it's something in the registry. Maybe the install
            program should do it. Have you installed Vim from Steve Hall's self-installer
            https://sourceforge.net/project/showfiles.php?group_id=43866&package_id=39721
            ? If you haven't, try doing it.

            P.S. Please use bottom-posting or inter-posting in the Vim mailing lists.


            Best regards,
            Tony.
          • Bill McCarthy
            ... Like most of you on Win XP, I build my own Vim and Gvim (for Gvim I specify OLE=yes). From Windows Explorer, when I click on a .txt file, Gvim comes up
            Message 5 of 9 , Dec 12, 2006
            View Source
            • 0 Attachment
              On Tue 12-Dec-06 4:43pm -0600, Jeffrey Robertson wrote:

              > A.J.Mechelynck wrote:

              >> I'm not sure; I think it's something in the registry. Maybe the install
              >> program should do it. Have you installed Vim from Steve Hall's
              >> self-installer
              >> https://sourceforge.net/project/showfiles.php?group_id=43866&package_id=
              >> 39721
              >> ? If you haven't, try doing it.

              > I've now done this, and it's improved things but not fixed them.
              >
              > I get the "open with vim" option in my right-click menu, and this
              > launches
              > the file into gvim, so that's good. But if I simply double click, it
              > launches to regular vim. That is, it opens what looks like a shell
              > window and tries to open the file. It gets confused by spaces in the
              > path, so it never actually succeeds in opening the file.
              >
              > If it go to "Open With..." and specify "Vi Improved - A Text Editor",
              > I get the same results. How can I make "Open With" launch to gvim?
              >
              > For those joining the discussion late, I'm using Windows XP.

              Like most of you on Win XP, I build my own Vim and Gvim (for
              Gvim I specify OLE=yes). From Windows Explorer, when I
              click on a .txt file, Gvim comes up for the file.

              I just tried clicking on a .vim file and received a dialog
              (see ONEofTWO.gif) telling me that Windows cannot open the
              file and asking me to search the web or select the program
              from a list. I picked select the program and got a second
              dialog.

              That dialog (see TWOofTWO.gif) let me pick Gvim and check
              the box to use Gvim for all .vim files.

              After performing these two tasks, Windows Explorer now opens
              Gvim whenever I click on a .vim file.

              I created a directory name with spaces and put a file in
              there with spaces in its name and ending with .vim - it
              opened fine from explorer.

              [Without the attached GIFs]

              --
              Best regards,
              Bill
            • Jeffrey Robertson
              ... install ... https://sourceforge.net/project/showfiles.php?group_id=43866&package_id= ... You say it let you pick Gvim. I assume you mean you selected Vi
              Message 6 of 9 , Dec 13, 2006
              View Source
              • 0 Attachment
                > Jeffrey Robertson wrote:
                >> No. That's my problem. How does gvim tell Windows to make itself an
                >> option in this list?
                > [...]
                >
                >
                > A.J.Mechelynck wrote:
                > I'm not sure; I think it's something in the registry. Maybe the
                install
                > program should do it. Have you installed Vim from Steve Hall's
                > self-installer
                >
                https://sourceforge.net/project/showfiles.php?group_id=43866&package_id=
                > 39721
                > ? If you haven't, try doing it.
                >
                >
                > I've now done this, and it's improved things but not fixed them.
                >
                > I get the "open with vim" option in my right-click menu, and this
                > launches
                > the file into gvim, so that's good. But if I simply double click, it
                > launches to regular vim. That is, it opens what looks like a shell
                > window and tries to open the file. It gets confused by spaces in the
                > path, so it never actually succeeds in opening the file.
                >
                > If it go to "Open With..." and specify "Vi Improved - A Text Editor",
                > I get the same results. How can I make "Open With" launch to gvim?
                >
                > For those joining the discussion late, I'm using Windows XP.

                Bill McCarthy wrote:
                > Like most of you on Win XP, I build my own Vim and Gvim (for
                > Gvim I specify OLE=yes). From Windows Explorer, when I
                > click on a .txt file, Gvim comes up for the file.
                >
                > I just tried clicking on a .vim file and received a dialog
                > (see ONEofTWO.gif) telling me that Windows cannot open the
                > file and asking me to search the web or select the program
                > from a list. I picked select the program and got a second
                > dialog.
                >
                > That dialog (see TWOofTWO.gif) let me pick Gvim and check
                > the box to use Gvim for all .vim files.
                >
                > After performing these two tasks, Windows Explorer now opens
                > Gvim whenever I click on a .vim file.
                >
                > I created a directory name with spaces and put a file in
                > there with spaces in its name and ending with .vim - it
                > opened fine from explorer.

                You say it let you pick Gvim. I assume you mean you selected
                "Vi Improved - A Text Editor". I do the same thing, but
                it launches regular vim, not gvim.

                If this is not what you meant, please clarify. If anyone
                can explain my problems, please do so.

                -- Jeff.
              • Bill McCarthy
                ... That s exactly what I mean. ... Looking through my registry tree, Vi Improved - A Text Editor appears exactly 4 times, 2 each as data in:
                Message 7 of 9 , Dec 13, 2006
                View Source
                • 0 Attachment
                  On Wed 13-Dec-06 9:26am -0600, you wrote:

                  > Bill McCarthy wrote:
                  >> Like most of you on Win XP, I build my own Vim and Gvim (for
                  >> Gvim I specify OLE=yes). From Windows Explorer, when I
                  >> click on a .txt file, Gvim comes up for the file.
                  >>
                  >> I just tried clicking on a .vim file and received a dialog
                  >> (see ONEofTWO.gif) telling me that Windows cannot open the
                  >> file and asking me to search the web or select the program
                  >> from a list. I picked select the program and got a second
                  >> dialog.
                  >>
                  >> That dialog (see TWOofTWO.gif) let me pick Gvim and check
                  >> the box to use Gvim for all .vim files.
                  >>
                  >> After performing these two tasks, Windows Explorer now opens
                  >> Gvim whenever I click on a .vim file.
                  >>
                  >> I created a directory name with spaces and put a file in
                  >> there with spaces in its name and ending with .vim - it
                  >> opened fine from explorer.

                  > You say it let you pick Gvim. I assume you mean you selected
                  > "Vi Improved - A Text Editor". I do the same thing, but
                  > it launches regular vim, not gvim.

                  That's exactly what I mean.

                  > If this is not what you meant, please clarify. If anyone
                  > can explain my problems, please do so.

                  Looking through my registry tree, "Vi Improved - A Text
                  Editor" appears exactly 4 times, 2 each as data in:

                  foo\Microsoft\Windows\ShellNoRoam\MUICache

                  Where "foo" is either:

                  HKEY_CURRENT_USER\Software
                  HKEY_USERS\S1-1-5-21-.... (long Key)

                  The 2 Values are:

                  C:\Vim\vim70\gvim.exe (where I execute from)
                  C:\vim\vim70\src\gvim.exe (where make puts it)

                  Searching my registry tree for any key, value or date
                  containing "vim.exe" I only find things containing gvim.exe.

                  Yes, I have and use vim.exe, but there are no references to
                  it in the registry.

                  --
                  Best regards,
                  Bill
                Your message has been successfully submitted and would be delivered to recipients shortly.