Loading ...
Sorry, an error occurred while loading the content.

different format in NEdit and GVIM

Expand Messages
  • Belinda Zeng
    Hi, all, I am using both NEdit and VIM, and set the tab spacing for both editors to 3. However, if I edit a file using NEdit, which looks fine under NEdit,
    Message 1 of 4 , Nov 28, 2006
    • 0 Attachment
      Hi, all,
      I am using both NEdit and VIM, and set the tab spacing for both
      editors to 3. However, if I edit a file using NEdit, which looks fine
      under NEdit, then open with GVIM, I am seeing all tabs become 8
      characters.
      Wondering if anyone has seen the same behavior? Is this a NEdit
      problem or a VIM problem?
      thank you very much!
      Belinda
    • Yakov Lerner
      ... Apparently you did not set vim tab spacing to 3 yet(:set ts=3 in your ~/.vimrc). Alghough you apparently think that you already did :-). Try this: ... 2.
      Message 2 of 4 , Nov 28, 2006
      • 0 Attachment
        On 11/28/06, Belinda Zeng <Huiwen.Zeng@...> wrote:
        >
        > Hi, all,
        > I am using both NEdit and VIM, and set the tab spacing for both
        > editors to 3. However, if I edit a file using NEdit, which looks fine
        > under NEdit, then open with GVIM, I am seeing all tabs become 8
        > characters.
        > Wondering if anyone has seen the same behavior? Is this a NEdit
        > problem or a VIM problem?

        Apparently you did not set vim tab spacing to 3 yet(:set ts=3 in your
        ~/.vimrc). Alghough you apparently think that you already did :-).
        Try this:
        1. add this command to your ~/.vimrc:
        :set ts=3
        2. Check your setting"
        :verbose ts?
        the expected value is 3. If you see 8, then you did not set ts to 3 yet.

        vim has many more tab-related options. Try :options and go to section
        15 tabs and indenting.

        Yakov
      • Yakov Lerner
        ... This shall be
        Message 3 of 4 , Nov 28, 2006
        • 0 Attachment
          > :verbose ts?
          This shall be
          :verbose set ts?
        • Belinda Zeng
          Thank you Yakov! That certainly works! Belinda ... From: Yakov Lerner [mailto:iler.ml@gmail.com] Sent: Tuesday, November 28, 2006 3:28 PM To: Belinda Zeng Cc:
          Message 4 of 4 , Nov 28, 2006
          • 0 Attachment
            Thank you Yakov! That certainly works!
            Belinda


            -----Original Message-----
            From: Yakov Lerner [mailto:iler.ml@...]
            Sent: Tuesday, November 28, 2006 3:28 PM
            To: Belinda Zeng
            Cc: Vim List
            Subject: Re: different format in NEdit and GVIM

            > :verbose ts?
            This shall be
            :verbose set ts?
          Your message has been successfully submitted and would be delivered to recipients shortly.