Loading ...
Sorry, an error occurred while loading the content.

Agonized by "auto changed cursor to next line when typing".

Expand Messages
  • Shark Wang
    Hi, I was agonized by GVim 7.0, the editor always auto changed my cursor to next line, when I typed with long line ( less than the wrap margin ) or end tag
    Message 1 of 5 , Nov 2, 2006
    • 0 Attachment
      Hi,

      I was agonized by GVim 7.0, the editor always auto changed my cursor
      to next line, when I typed
      with long line ( less than the wrap margin ) or end tag element, such
      as "</table>".

      the following is my vimrc, you could see that I had disabled autoindent :
      =================================================
      "***** display *****
      colo darkblue
      syntax on
      set gfn=Bitstream\ Vera\ Sans\ Mono:h11
      set anti
      set nonu
      "***** wrap and tab *****
      set wm=78
      set ts=2
      set sw=2
      set et
      "***** indent *****
      set noai
      set nosi
      set nocin
      set ic

      What should I do for this issue ? thanks for your help.

      --
      I'm just a bitMaker !
    • A.J.Mechelynck
      ... In gvim, type ... If the reply includes indent:ON , add filetype indent off to your vimrc, then restart gvim. Best regards, Tony.
      Message 2 of 5 , Nov 2, 2006
      • 0 Attachment
        Shark Wang wrote:
        > Hi,
        >
        > I was agonized by GVim 7.0, the editor always auto changed my cursor
        > to next line, when I typed
        > with long line ( less than the wrap margin ) or end tag element, such
        > as "</table>".
        >
        > the following is my vimrc, you could see that I had disabled autoindent :
        > =================================================
        > "***** display *****
        > colo darkblue
        > syntax on
        > set gfn=Bitstream\ Vera\ Sans\ Mono:h11
        > set anti
        > set nonu
        > "***** wrap and tab *****
        > set wm=78
        > set ts=2
        > set sw=2
        > set et
        > "***** indent *****
        > set noai
        > set nosi
        > set nocin
        > set ic
        >
        > What should I do for this issue ? thanks for your help.
        >

        In gvim, type

        :filetype

        If the reply includes "indent:ON", add

        filetype indent off

        to your vimrc, then restart gvim.


        Best regards,
        Tony.
      • Peter Hodge
        ... Hello, If you have wrapmargin or wm set to 78, Vim is going to wrap your text 78 characters *before* the right margin. That means if you have 110
        Message 3 of 5 , Nov 2, 2006
        • 0 Attachment
          --- Shark Wang <sharkwang@...> wrote:

          > Hi,
          >
          > I was agonized by GVim 7.0, the editor always auto changed my cursor
          > to next line, when I typed
          > with long line ( less than the wrap margin ) or end tag element, such
          > as "</table>".
          >
          > the following is my vimrc, you could see that I had disabled autoindent :
          > =================================================
          > "***** display *****
          > colo darkblue
          > syntax on
          > set gfn=Bitstream\ Vera\ Sans\ Mono:h11
          > set anti
          > set nonu
          > "***** wrap and tab *****
          > set wm=78
          > set ts=2
          > set sw=2
          > set et
          > "***** indent *****
          > set noai
          > set nosi
          > set nocin
          > set ic
          >
          > What should I do for this issue ? thanks for your help.

          Hello,

          If you have 'wrapmargin' or 'wm' set to 78, Vim is going to wrap your text 78
          characters *before* the right margin. That means if you have 110 columns of
          screen space, Vim will wrap after just 32 characters. Perhaps 'textwidth' is
          the option you are trying to set in your vimrc where you have:

          set wm=78

          maybe you should use

          set textwidth=78

          See also
          :help 'wm'
          :help 'tw'

          Also, AFAIK indenting options don't insert newlines, they only adjust the
          number of tabs/spaces at the start of the line.

          regards,
          Peter

          Send instant messages to your online friends http://au.messenger.yahoo.com
        • A.J.Mechelynck
          ... Then I don t know what it is. I m forwarding this to the list, so other people may have a try at it.
          Message 4 of 5 , Nov 2, 2006
          • 0 Attachment
            Shark Wang wrote:
            > Dear Mechelynck,
            >
            > thanks for your kindly reply.
            >
            > I use ":filetype" to see the output, it was indent ON. then I add
            > "filetype indent off" in
            > my vimrc and restart gvim, I meet the same issue agine.
            >
            > -Shark

            Then I don't know what it is. I'm forwarding this to the list, so other people
            may have a try at it.

            >
            > On 11/3/06, A.J.Mechelynck <antoine.mechelynck@...> wrote:
            >> Shark Wang wrote:
            >> > Hi,
            >> >
            >> > I was agonized by GVim 7.0, the editor always auto changed my cursor
            >> > to next line, when I typed
            >> > with long line ( less than the wrap margin ) or end tag element, such
            >> > as "</table>".
            >> >
            >> > the following is my vimrc, you could see that I had disabled
            >> autoindent :
            >> > =================================================
            >> > "***** display *****
            >> > colo darkblue
            >> > syntax on
            >> > set gfn=Bitstream\ Vera\ Sans\ Mono:h11
            >> > set anti
            >> > set nonu
            >> > "***** wrap and tab *****
            >> > set wm=78
            >> > set ts=2
            >> > set sw=2
            >> > set et
            >> > "***** indent *****
            >> > set noai
            >> > set nosi
            >> > set nocin
            >> > set ic
            >> >
            >> > What should I do for this issue ? thanks for your help.
            >> >
            >>
            >> In gvim, type
            >>
            >> :filetype
            >>
            >> If the reply includes "indent:ON", add
            >>
            >> filetype indent off
            >>
            >> to your vimrc, then restart gvim.
            >>
            >>
            >> Best regards,
            >> Tony.
            >>
            >
            >
          • Shark Wang
            Yeah..., Peter, I got it ! It s my carelessness & misunderstanding. Thank you all. -Shark ... -- I m just a bitMaker !
            Message 5 of 5 , Nov 2, 2006
            • 0 Attachment
              Yeah..., Peter, I got it ! It's my carelessness & misunderstanding.

              Thank you all.

              -Shark

              On 11/3/06, Peter Hodge <toomuchphp-vim@...> wrote:
              >
              > --- Shark Wang <sharkwang@...> wrote:
              >
              > > Hi,
              > >
              > > I was agonized by GVim 7.0, the editor always auto changed my cursor
              > > to next line, when I typed
              > > with long line ( less than the wrap margin ) or end tag element, such
              > > as "</table>".
              > >
              > > the following is my vimrc, you could see that I had disabled autoindent :
              > > =================================================
              > > "***** display *****
              > > colo darkblue
              > > syntax on
              > > set gfn=Bitstream\ Vera\ Sans\ Mono:h11
              > > set anti
              > > set nonu
              > > "***** wrap and tab *****
              > > set wm=78
              > > set ts=2
              > > set sw=2
              > > set et
              > > "***** indent *****
              > > set noai
              > > set nosi
              > > set nocin
              > > set ic
              > >
              > > What should I do for this issue ? thanks for your help.
              >
              > Hello,
              >
              > If you have 'wrapmargin' or 'wm' set to 78, Vim is going to wrap your text 78
              > characters *before* the right margin. That means if you have 110 columns of
              > screen space, Vim will wrap after just 32 characters. Perhaps 'textwidth' is
              > the option you are trying to set in your vimrc where you have:
              >
              > set wm=78
              >
              > maybe you should use
              >
              > set textwidth=78
              >
              > See also
              > :help 'wm'
              > :help 'tw'
              >
              > Also, AFAIK indenting options don't insert newlines, they only adjust the
              > number of tabs/spaces at the start of the line.
              >
              > regards,
              > Peter
              >
              > Send instant messages to your online friends http://au.messenger.yahoo.com
              >


              --
              I'm just a bitMaker !
            Your message has been successfully submitted and would be delivered to recipients shortly.