Loading ...
Sorry, an error occurred while loading the content.

Re: Command line tab completion

Expand Messages
  • panshizhu@routon.com
    ... No, yours are different from Gary. Your completion does not seem to be working at all and you should check your settings, Gary s completeion works but not
    Message 1 of 12 , Nov 2, 2006
    • 0 Attachment
      Benji Fisher <benji@...> 写于 2006-11-02 22:21:36:
      > I agree with Gary. I tried
      > $ vim -u NONE
      > :set nocp wildmenu wildmode=longest:list
      > :help termi<Tab>
      > :help preser<Tab>
      >
      > I was hoping for "termin" in the first case and "preserve" in the
      > second, but I was stuck with "termi" and "preser".
      >
      > HTH --Benji Fisher
      >
      > P.S. Has there been a patch that affects this? I am still using vim
      > 7.0.000 .

      No, yours are different from Gary. Your completion does not seem to be
      working at all and you should check your settings, Gary's completeion works
      but not as he expected.

      What Gary has said is: when :help preser<Tab> expands to :help :preserve,
      it will fail to expand :help :preservi to :help 'preservindent'.

      My suggestion to Gary: if you want a completion of 'preserveindent', type
      :help 'pres<tab> and it will complete to :help 'preserveindent'
      immediately. that is much easier than :help pres<tab>i<tab>... Don't expect
      the completion to work perfectly when you had ommited the colon or
      quotation mark.

      --
      Sincerely, Pan, Shi Zhu. ext: 2606
    Your message has been successfully submitted and would be delivered to recipients shortly.