Loading ...
Sorry, an error occurred while loading the content.
 

how to make 7.0 behave like 6.4

Expand Messages
  • longraider
    Hi I ve a habit for writing such a code: { s; } In this way: When I m on blank linke, i press: shift-[ enter shift-] up-arrow enter (sometimes tab here)
    Message 1 of 5 , Nov 1, 2006
      Hi
      I've a habit for writing such a code:
      {
      s;
      }
      In this way:
      When I'm on blank linke, i press:
      shift-[ enter shift-] up-arrow enter (sometimes tab here) s ;
      That worked great in vim 6, but now (vim7) I get something like that:
      s;{
      }
      Because after pressing up-arrow, the cursor is placed before the "{", is
      there any way to make it work "the old way" ?

      I've thought of fighting this habit, but it's hard, too hard ;-)

      --
      mati
    • A.J.Mechelynck
      ... Do you mean Shift-[ or do you mean { ? (On my keyboard, { is not Shift-[ but AltGr-ç ). With (in Insert mode) the sequence { } s; I get: {
      Message 2 of 5 , Nov 1, 2006
        longraider wrote:
        > Hi
        > I've a habit for writing such a code:
        > {
        > s;
        > }
        > In this way:
        > When I'm on blank linke, i press:
        > shift-[ enter shift-] up-arrow enter (sometimes tab here) s ;
        > That worked great in vim 6, but now (vim7) I get something like that:
        > s;{
        > }
        > Because after pressing up-arrow, the cursor is placed before the "{", is
        > there any way to make it work "the old way" ?
        >
        > I've thought of fighting this habit, but it's hard, too hard ;-)
        >

        Do you mean Shift-[ or do you mean { ? (On my keyboard, { is not Shift-[ but
        AltGr-ç ).

        With (in Insert mode) the sequence {<Enter>}<Up><Enter>s;
        I get:

        {
        s;
        }


        I'm using Vim 7 and my vimrc includes (among others)

        runtime vimrc_example.vim
        filetype indent off
        set autoindent smartindent


        Best regards,
        Tony.
      • longraider
        ... I mean { of course, that is shift-[ on my standard keyboard (whatever standard mean here ;-) ... The set autoindent smartindent is the solution, thanks
        Message 3 of 5 , Nov 1, 2006
          A.J.Mechelynck wrote:

          > Do you mean Shift-[ or do you mean { ? (On my keyboard, { is not Shift-[
          > but AltGr-ç ).

          I mean { of course, that is shift-[ on my "standard" keyboard (whatever
          "standard" mean here ;-)

          >
          > With (in Insert mode) the sequence {<Enter>}<Up><Enter>s;
          > I get:
          >
          > {
          > s;
          > }
          >
          >
          > I'm using Vim 7 and my vimrc includes (among others)
          >
          > runtime vimrc_example.vim
          > filetype indent off
          > set autoindent smartindent
          >

          The set autoindent smartindent is the solution, thanks a lot.

          --
          mati
        • Charles E Campbell Jr
          ... You know, vim 7.0 hasn t changed the autoindent/smartindent area (except possibly for bug fixes) from v6.4 insofar as I am aware. And I do use autoindent
          Message 4 of 5 , Nov 2, 2006
            longraider wrote:

            >The set autoindent smartindent is the solution, thanks a lot.
            >
            >
            >
            You know, vim 7.0 hasn't changed the autoindent/smartindent area (except
            possibly for bug fixes)
            from v6.4 insofar as I am aware. And I do use autoindent (and cindent).

            So the question in my mind is: why did this change for you when you
            upgraded? One way that
            may have occurred is if you edited the system files and put settings and
            customizations in there.
            If that's what you in fact did, then I suggest that its Much Better (tm)
            to use $HOME/.vimrc and
            $HOME/.vim/ instead for such things. You won't lose your customizations
            that way when you
            upgrade.

            Regards,
            Chip Campbell
          • longraider
            ... I ve started to customize vim after I ve installed the 7.0 version, the 6.4 was used by me as a plain text editor, with default settings. AFAIR I ve
            Message 5 of 5 , Nov 2, 2006
              Charles E Campbell Jr wrote:

              >> The set autoindent smartindent is the solution, thanks a lot.
              >>
              > You know, vim 7.0 hasn't changed the autoindent/smartindent area (except
              > possibly for bug fixes)
              > from v6.4 insofar as I am aware. And I do use autoindent (and cindent).
              >
              > So the question in my mind is: why did this change for you when you
              > upgraded? One way that
              > may have occurred is if you edited the system files and put settings and
              > customizations in there.
              > If that's what you in fact did, then I suggest that its Much Better (tm)
              > to use $HOME/.vimrc and
              > $HOME/.vim/ instead for such things. You won't lose your customizations
              > that way when you
              > upgrade.
              >
              I've started to customize vim after I've installed the 7.0 version, the
              6.4 was used by me as a plain text editor, with default settings.
              AFAIR I've written the "set cindent" someday in the vim, and that worked
              for me, so I suppose that old vim has put the config somewhere, and that
              config was erased when I installed 7. I use gentoo, so it couldn't be
              /etc (the /etc in gentoo is protected), and I don't think that new
              install (or uninstall) could mess with my $HOME.
              But now I get to know vim better, and all of course goes to the $HOME/.vimrc

              --
              mati
            Your message has been successfully submitted and would be delivered to recipients shortly.