Loading ...
Sorry, an error occurred while loading the content.

I cannot install gvim7.0

Expand Messages
  • Zheng Da
    Hello. I try to install vim7.0 But I can t install vim with GUI. It seems that configure automatically looks for a GUI, but it always tells no in my system.
    Message 1 of 8 , Oct 1, 2006
    • 0 Attachment
      Hello.
      I try to install vim7.0
      But I can't install vim with GUI.
      It seems that configure automatically looks for a GUI, but it always
      tells no in my system.
      "checking --enable-gui argument... no GUI support"
      And I'm sure there isn't gvim in my system.
      I read src/INSTALL. It tells me that I need glib and gtk+ at least
      version 1.1.16, but below 2.0.
      I use Debian, and in my system, there are libgtk1.2, libgtk1.2-common,
      libgtk1.2-dev, libglib1.2, libglib1.2-dev.
      So what else do I need?

      --
      With regards
      Zheng Da
    • Yakov Lerner
      ... I think you need gtk2-devel (Debian probably calls it gtk2-dev) Yakov
      Message 2 of 8 , Oct 1, 2006
      • 0 Attachment
        On 10/1/06, Zheng Da <zhengda1936@...> wrote:
        > Hello.
        > I try to install vim7.0
        > But I can't install vim with GUI.
        > It seems that configure automatically looks for a GUI, but it always
        > tells no in my system.
        > "checking --enable-gui argument... no GUI support"
        > And I'm sure there isn't gvim in my system.
        > I read src/INSTALL. It tells me that I need glib and gtk+ at least
        > version 1.1.16, but below 2.0.
        > I use Debian, and in my system, there are libgtk1.2, libgtk1.2-common,
        > libgtk1.2-dev, libglib1.2, libglib1.2-dev.
        > So what else do I need?

        I think you need gtk2-devel (Debian probably calls it gtk2-dev)

        Yakov
      • A.J.Mechelynck
        Message 3 of 8 , Oct 1, 2006
        • 0 Attachment
          Zheng Da wrote:
          > Hello.
          > I try to install vim7.0
          > But I can't install vim with GUI.
          > It seems that configure automatically looks for a GUI, but it always
          > tells no in my system.
          > "checking --enable-gui argument... no GUI support"
          > And I'm sure there isn't gvim in my system.
          > I read src/INSTALL. It tells me that I need glib and gtk+ at least
          > version 1.1.16, but below 2.0.
          > I use Debian, and in my system, there are libgtk1.2, libgtk1.2-common,
          > libgtk1.2-dev, libglib1.2, libglib1.2-dev.
          > So what else do I need?
          >
        • A.J.Mechelynck
          ... That INSTALL file must be really old, it says that GTK2 doesn t work -- it has worked since at least at some patchlevel of 6.3. Check the output of
          Message 4 of 8 , Oct 1, 2006
          • 0 Attachment
            Zheng Da wrote:
            > Hello.
            > I try to install vim7.0
            > But I can't install vim with GUI.
            > It seems that configure automatically looks for a GUI, but it always
            > tells no in my system.
            > "checking --enable-gui argument... no GUI support"
            > And I'm sure there isn't gvim in my system.
            > I read src/INSTALL. It tells me that I need glib and gtk+ at least
            > version 1.1.16, but below 2.0.
            > I use Debian, and in my system, there are libgtk1.2, libgtk1.2-common,
            > libgtk1.2-dev, libglib1.2, libglib1.2-dev.
            > So what else do I need?
            >

            That INSTALL file must be really old, it says that GTK2 doesn't work -- it has
            worked since at least at some patchlevel of 6.3.

            Check the output of configure, where it checks for the various flavours of GUI
            (there is a long list of lines starting "checking"). Apparently it cannot find
            your GTK libs. you may need some argument to tell it where they are found; or
            else maybe you have --disable-gui-gtk-check or something?


            Best regards,
            Tony.
          • moonykily
            Why not use apt-get install vim-full? In Debian Etch and Sid there is this deb package, and it works well on my machine. ... -- novorus@gmail.com
            Message 5 of 8 , Oct 1, 2006
            • 0 Attachment
              Why not use apt-get install vim-full?
              In Debian Etch and Sid there is this deb package, and it works well on my
              machine.

              On Monday 02 October 2006 00:42, Zheng Da wrote:
              > Hello.
              > I try to install vim7.0
              > But I can't install vim with GUI.
              > It seems that configure automatically looks for a GUI, but it always
              > tells no in my system.
              > "checking --enable-gui argument... no GUI support"
              > And I'm sure there isn't gvim in my system.
              > I read src/INSTALL. It tells me that I need glib and gtk+ at least
              > version 1.1.16, but below 2.0.
              > I use Debian, and in my system, there are libgtk1.2, libgtk1.2-common,
              > libgtk1.2-dev, libglib1.2, libglib1.2-dev.
              > So what else do I need?

              --
              novorus@...
            • Tom Purl
              ... I had this same problem, and I think that it was fixed by installing the xwindows dev libraries. The output of ./configure told me what was missing from
              Message 6 of 8 , Oct 1, 2006
              • 0 Attachment
                On Mon, Oct 02, 2006 at 12:42:52AM +0800, Zheng Da wrote:
                > Hello.
                > I try to install vim7.0
                > But I can't install vim with GUI.
                > It seems that configure automatically looks for a GUI, but it always
                > tells no in my system.
                > "checking --enable-gui argument... no GUI support"
                > And I'm sure there isn't gvim in my system.
                > I read src/INSTALL. It tells me that I need glib and gtk+ at least
                > version 1.1.16, but below 2.0.
                > I use Debian, and in my system, there are libgtk1.2, libgtk1.2-common,
                > libgtk1.2-dev, libglib1.2, libglib1.2-dev.
                > So what else do I need?
                >
                > --
                > With regards
                > Zheng Da

                I had this same problem, and I think that it was fixed by installing
                the xwindows dev libraries. The output of ./configure told me what
                was missing from an X11 dev perspective.

                You might also want to try the following to install all of the
                compilation dependencies:

                sudo apt-get build-dep vim-gnome

                HTH!

                Tom Purl
              • Tom Purl
                Please reply to the list so that others can learn from our mistakes :) ... You can also try the `apt-get build-dep` command with the following Debian packages:
                Message 7 of 8 , Oct 2, 2006
                • 0 Attachment
                  Please reply to the list so that others can learn from our mistakes :)

                  > I think it works. But it's really surprising. I run apt-get
                  > build-dep vim-gnome, then run ./configure the same result:"checking
                  > --enable-gui argument... no GUI support".

                  You can also try the `apt-get build-dep` command with the following
                  Debian packages:

                  vim-gtk
                  vim-gui-common

                  > I removed the original source codes, and get a new one from
                  > vim-7.0-extra.tar.gz, vim-7.0-lang.tar.gz, vim-7.0.tar.bz2.

                  You should only require the last file in that list to compile gvim.

                  > Then I can compile vim with GUI. By the way, I run ./configure
                  > without any arguments.

                  This is probably a *big* part of the reason why you can't compile gvim.
                  In order to compile GVIM, it was my understanding that you needed to use
                  some sort of GUI flag when executing the ./configuration step. Try
                  running the following command in the future when compiling vim:

                  ./configure --help | grep GUI

                  This will show you all of the GUI-related flags that you need to
                  consider when compiling gvim.

                  HTH!

                  Tom Purl

                  > On 10/2/06, Tom Purl <tom@...> wrote:
                  >> On Mon, Oct 02, 2006 at 12:42:52AM +0800, Zheng Da wrote:
                  >> > Hello.
                  >> > I try to install vim7.0
                  >> > But I can't install vim with GUI.
                  >> > It seems that configure automatically looks for a GUI, but it always
                  >> > tells no in my system.
                  >> > "checking --enable-gui argument... no GUI support"
                  >> > And I'm sure there isn't gvim in my system.
                  >> > I read src/INSTALL. It tells me that I need glib and gtk+ at least
                  >> > version 1.1.16, but below 2.0.
                  >> > I use Debian, and in my system, there are libgtk1.2, libgtk1.2-common,
                  >> > libgtk1.2-dev, libglib1.2, libglib1.2-dev.
                  >> > So what else do I need?
                  >> >
                  >> > --
                  >> > With regards
                  >> > Zheng Da
                  >>
                  >> I had this same problem, and I think that it was fixed by installing
                  >> the xwindows dev libraries. The output of ./configure told me what
                  >> was missing from an X11 dev perspective.
                  >>
                  >> You might also want to try the following to install all of the
                  >> compilation dependencies:
                  >>
                  >> sudo apt-get build-dep vim-gnome
                  >>
                  >> HTH!
                  >>
                  >> Tom Purl
                  >>
                  >
                  >
                  > --
                  > With regards
                  > Zheng Da
                  >
                • Zheng Da
                  ... I m sorry. I didn t notice. I thought I had posted my letter to the list. ... I need to use Chinese. ... I didn t use any argument of configure, and could
                  Message 8 of 8 , Oct 8, 2006
                  • 0 Attachment
                    On 10/2/06, Tom Purl <tom@...> wrote:
                    > Please reply to the list so that others can learn from our mistakes :)
                    I'm sorry. I didn't notice. I thought I had posted my letter to the list.
                    >
                    > > I think it works. But it's really surprising. I run apt-get
                    > > build-dep vim-gnome, then run ./configure the same result:"checking
                    > > --enable-gui argument... no GUI support".
                    >
                    > You can also try the `apt-get build-dep` command with the following
                    > Debian packages:
                    >
                    > vim-gtk
                    > vim-gui-common
                    >
                    > > I removed the original source codes, and get a new one from
                    > > vim-7.0-extra.tar.gz, vim-7.0-lang.tar.gz, vim-7.0.tar.bz2.
                    >
                    > You should only require the last file in that list to compile gvim.
                    I need to use Chinese.
                    >
                    > > Then I can compile vim with GUI. By the way, I run ./configure
                    > > without any arguments.
                    >
                    > This is probably a *big* part of the reason why you can't compile gvim.
                    > In order to compile GVIM, it was my understanding that you needed to use
                    > some sort of GUI flag when executing the ./configuration step. Try
                    > running the following command in the future when compiling vim:
                    I didn't use any argument of configure, and could still compile gvim.
                    >
                    > ./configure --help | grep GUI
                    >
                    > This will show you all of the GUI-related flags that you need to
                    > consider when compiling gvim.
                    >
                    > HTH!
                    >
                    > Tom Purl
                    >
                    > > On 10/2/06, Tom Purl <tom@...> wrote:
                    > >> On Mon, Oct 02, 2006 at 12:42:52AM +0800, Zheng Da wrote:
                    > >> > Hello.
                    > >> > I try to install vim7.0
                    > >> > But I can't install vim with GUI.
                    > >> > It seems that configure automatically looks for a GUI, but it always
                    > >> > tells no in my system.
                    > >> > "checking --enable-gui argument... no GUI support"
                    > >> > And I'm sure there isn't gvim in my system.
                    > >> > I read src/INSTALL. It tells me that I need glib and gtk+ at least
                    > >> > version 1.1.16, but below 2.0.
                    > >> > I use Debian, and in my system, there are libgtk1.2, libgtk1.2-common,
                    > >> > libgtk1.2-dev, libglib1.2, libglib1.2-dev.
                    > >> > So what else do I need?
                    > >> >
                    > >> > --
                    > >> > With regards
                    > >> > Zheng Da
                    > >>
                    > >> I had this same problem, and I think that it was fixed by installing
                    > >> the xwindows dev libraries. The output of ./configure told me what
                    > >> was missing from an X11 dev perspective.
                    > >>
                    > >> You might also want to try the following to install all of the
                    > >> compilation dependencies:
                    > >>
                    > >> sudo apt-get build-dep vim-gnome
                    > >>
                    > >> HTH!
                    > >>
                    > >> Tom Purl
                    > >>
                    > >
                    > >
                    > > --
                    > > With regards
                    > > Zheng Da
                    > >
                    >
                    >


                    --
                    With regards
                    Zheng Da
                  Your message has been successfully submitted and would be delivered to recipients shortly.