Loading ...
Sorry, an error occurred while loading the content.

Re: Using commands that use unix EDITOR environment variable

Expand Messages
  • Benji Fisher
    ... I think the problem is that, by default, gvim forks and immediately returns control to the calling process. Try setting EDITOR to vim or to gvim
    Message 1 of 3 , Sep 2, 2006
    • 0 Attachment
      On Sat, Sep 02, 2006 at 12:02:02PM +0530, Ujjal Bose wrote:
      > Hi ,
      >
      > in my machine if I set EDITOR as gvim and then try to execute commands
      > like "crontab -e" that invoke editors, I get a gvim window , but it
      > does not open my existing crontab file, nor does it allow me to do any
      > changes. But if I set the EDITOR as vi , everything works. Any clues ?
      >
      > -Ujjal

      I think the problem is that, by default, gvim forks and immediately
      returns control to the calling process. Try setting EDITOR to vim or
      to "gvim --nofork".

      HTH --Benji Fisher
    • Ujjal Bose
      ... Thanks Benji, gvim --nofork works ! Thanks again. -Ujjal
      Message 2 of 3 , Sep 2, 2006
      • 0 Attachment
        > I think the problem is that, by default, gvim forks and immediately
        > returns control to the calling process. Try setting EDITOR to vim or
        > to "gvim --nofork".
        >
        > HTH --Benji Fisher
        >

        Thanks Benji,

        "gvim --nofork" works ! Thanks again.

        -Ujjal
      Your message has been successfully submitted and would be delivered to recipients shortly.