Loading ...
Sorry, an error occurred while loading the content.

Status line in gvim obscured when maximised

Expand Messages
  • James Hales
    Hi, When I maximize Gvim in Gnome, the status line is partially hidden by the gnome panel, which is really annoying. This is because of how Vim resizes itself,
    Message 1 of 5 , Aug 1, 2006
    • 0 Attachment
      Hi,

      When I maximize Gvim in Gnome, the status line is partially hidden by
      the gnome panel, which is really annoying. This is because of how Vim
      resizes itself, i.e. it is constrained to being resized one character
      size at a time. When Gvim is maximized, it is half a character too
      high, so that extra half character, half of the status line, is hidden
      beneath the gnome panel.

      Is there any way to alleviate this problem?

      Thanks very much,
      James Hales
    • Vigil
      I wonder if altering the font slightly would help... ... -- .
      Message 2 of 5 , Aug 2, 2006
      • 0 Attachment
        I wonder if altering the font slightly would help...

        On Wed, 2 Aug 2006, James Hales wrote:

        > When I maximize Gvim in Gnome, the status line is partially hidden by
        > the gnome panel, which is really annoying. This is because of how Vim
        > resizes itself, i.e. it is constrained to being resized one character
        > size at a time. When Gvim is maximized, it is half a character too
        > high, so that extra half character, half of the status line, is hidden
        > beneath the gnome panel.
        >
        > Is there any way to alleviate this problem?

        --

        .
      • Mark Woodward
        Hi James, not a solution but... On Wed, 2 Aug 2006 09:55:40 +0800 ... size the window to how you think maximised should look ... then set a mapping in your
        Message 3 of 5 , Aug 2, 2006
        • 0 Attachment
          Hi James,

          not a solution but...

          On Wed, 2 Aug 2006 09:55:40 +0800
          "James Hales" <jhales.perth@...> wrote:

          > Hi,
          >
          > When I maximize Gvim in Gnome, the status line is partially hidden by
          > the gnome panel, which is really annoying. This is because of how Vim
          > resizes itself, i.e. it is constrained to being resized one character
          > size at a time. When Gvim is maximized, it is half a character too
          > high, so that extra half character, half of the status line, is hidden
          > beneath the gnome panel.
          >
          > Is there any way to alleviate this problem?
          >
          > Thanks very much,
          > James Hales

          size the window to how you think maximised should look
          :set lines? (eg 100)
          :set columns? (eg 195)

          then set a mapping in your .vimrc

          nnoremap <leader>max :set lines=100<cr>:set columns=195<cr>
          (this works but would be far neater in a function)

          then when you want to 'maximise': \max


          cheers,


          --
          Mark
        • A.J.Mechelynck
          ... Do you maximize gvim by OS methods (like [a] clicking the Maximize icon at top right [b] clicking the program icon at top left, then using Maximize or
          Message 4 of 5 , Aug 2, 2006
          • 0 Attachment
            James Hales wrote:
            > Hi,
            >
            > When I maximize Gvim in Gnome, the status line is partially hidden by
            > the gnome panel, which is really annoying. This is because of how Vim
            > resizes itself, i.e. it is constrained to being resized one character
            > size at a time. When Gvim is maximized, it is half a character too
            > high, so that extra half character, half of the status line, is hidden
            > beneath the gnome panel.
            >
            > Is there any way to alleviate this problem?
            >
            > Thanks very much,
            > James Hales
            >
            >

            Do you maximize gvim by "OS methods" (like [a] clicking the Maximize
            icon at top right [b] clicking the program icon at top left, then using
            "Maximize" or [c] ":simalt ~x" on English-language Vim) or by "Vim
            methods" (like ":set lines=9999 columns=9999")? The latter sometimes
            make the Vim screen smaller by one character cell horizontally and/or
            vertically than the former. So, try

            :set lines=9999 columns=9999

            and, if the bottom line is still obscured by the Gnome panel, follow the
            above line by

            :set lines-=1

            Note that setting 'lines' to 9999, then down by 1, is not equivalent to
            setting it to 9998, because Vim will not allow 'lines' or 'columns' to
            exceed what can be displayed. But if ":set lines=1" makes no difference
            when in your vimrc (and makes one when entered manually) you may want to
            delay it until after starting the GUI by replacing it with

            :autocmd VimEnter * set lines-=1


            Best regards,
            Tony.
          • Bram Moolenaar
            ... -- ~ ~ ~ .signature 4 lines, 50 characters written /// Bram Moolenaar -- Bram@Moolenaar.net -- http://www.Moolenaar.net /// sponsor Vim,
            Message 5 of 5 , Aug 12, 2006
            • 0 Attachment
              James Hales wrote:

              > When I maximize Gvim in Gnome, the status line is partially hidden by
              > the gnome panel, which is really annoying. This is because of how Vim
              > resizes itself, i.e. it is constrained to being resized one character
              > size at a time. When Gvim is maximized, it is half a character too
              > high, so that extra half character, half of the status line, is hidden
              > beneath the gnome panel.
              >
              > Is there any way to alleviate this problem?

              Try using the 'guiheadroom' option, e.g.:

              :set guiheadroom=100

              --
              ~
              ~
              ~
              ".signature" 4 lines, 50 characters written

              /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
              /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
              \\\ download, build and distribute -- http://www.A-A-P.org ///
              \\\ help me help AIDS victims -- http://ICCF-Holland.org ///
            Your message has been successfully submitted and would be delivered to recipients shortly.