Loading ...
Sorry, an error occurred while loading the content.

Differences with vim 7

Expand Messages
  • Robert Cussons
    I just installed vim 7 on my linux system at work (more specifically debian sarge running KDE 3.3) and I get a few funny things happening. It is installed in
    Message 1 of 19 , Jul 31, 2006
    • 0 Attachment
      I just installed vim 7 on my linux system at work (more specifically
      debian sarge running KDE 3.3) and I get a few funny things happening. It
      is installed in my home/bin directory as I don't have root permissions.
      All comments seem to come out underlined and the fonts for everything
      including the menus are different to before, I don't know how to check
      the current font setting, but when I type :set, there doesn't seem to be
      anything that would have changed the font listed. Anyone had the same
      problems?

      Many thanks for any help,
      Rob.
    • Yakov Lerner
      ... Yakov
      Message 2 of 19 , Jul 31, 2006
      • 0 Attachment
        On 7/31/06, Robert Cussons <r.cussons@...> wrote:
        > I just installed vim 7 on my linux system at work (more specifically
        > debian sarge running KDE 3.3) and I get a few funny things happening. It
        > is installed in my home/bin directory as I don't have root permissions.
        > All comments seem to come out underlined and the fonts for everything
        > including the menus are different to before, I don't know how to check
        > the current font setting, but when I type :set, there doesn't seem to be
        > anything that would have changed the font listed. Anyone had the same
        > problems?

        :set guifont?

        Yakov
      • Peter Hodge
        Some GUIs will allow you to use the command set guifont=* Which brings up a font selection window. If that works, you can select a font and then use set
        Message 3 of 19 , Jul 31, 2006
        • 0 Attachment
          Some GUIs will allow you to use the command

          set guifont=*

          Which brings up a font selection window. If that works, you can select a font
          and then use

          set guifont

          to find out exactly what to add to your .vimrc

          regards,
          Peter

          --- Yakov Lerner <iler.ml@...> wrote:

          > On 7/31/06, Robert Cussons <r.cussons@...> wrote:
          > > I just installed vim 7 on my linux system at work (more specifically
          > > debian sarge running KDE 3.3) and I get a few funny things happening. It
          > > is installed in my home/bin directory as I don't have root permissions.
          > > All comments seem to come out underlined and the fonts for everything
          > > including the menus are different to before, I don't know how to check
          > > the current font setting, but when I type :set, there doesn't seem to be
          > > anything that would have changed the font listed. Anyone had the same
          > > problems?
          >
          > :set guifont?
          >
          > Yakov
          >


          Send instant messages to your online friends http://au.messenger.yahoo.com
        • Robert Cussons
          ... Thanks Yakov and Peter, it appears that the problem may be more with Vim7 finding the fonts on my system. I had Sans regular 12 on Vim6.3 and the list of
          Message 4 of 19 , Jul 31, 2006
          • 0 Attachment
            Peter Hodge wrote:
            > Some GUIs will allow you to use the command
            >
            > set guifont=*
            >
            > Which brings up a font selection window. If that works, you can select a font
            > and then use
            >
            > set guifont
            >
            > to find out exactly what to add to your .vimrc
            >
            > regards,
            > Peter
            >
            > --- Yakov Lerner <iler.ml@...> wrote:
            >
            >
            >>On 7/31/06, Robert Cussons <r.cussons@...> wrote:
            >>
            >>>I just installed vim 7 on my linux system at work (more specifically
            >>>debian sarge running KDE 3.3) and I get a few funny things happening. It
            >>>is installed in my home/bin directory as I don't have root permissions.
            >>>All comments seem to come out underlined and the fonts for everything
            >>>including the menus are different to before, I don't know how to check
            >>>the current font setting, but when I type :set, there doesn't seem to be
            >>>anything that would have changed the font listed. Anyone had the same
            >>>problems?
            >>
            >>:set guifont?
            >>
            >>Yakov
            >>
            >
            >
            >
            > Send instant messages to your online friends http://au.messenger.yahoo.com
            >

            Thanks Yakov and Peter, it appears that the problem may be more with
            Vim7 finding the fonts on my system. I had Sans regular 12 on Vim6.3 and
            the list of fonts there is greater than that in Vim7, do I need to tell
            Vim where to look for fonts, if so how do I check where Vim 6.3 looks
            and tell Vim 7 to look there as well. I think this is because 6.3 is a
            network wide install and 7 is installed in my home directory.

            Thanks,
            Rob.
          • Robert Cussons
            ... I just discovered that the font is not Sans regular 12 on Vim6.3 because when I use :set guifont=* although that is the font that is highlighted, if I
            Message 5 of 19 , Jul 31, 2006
            • 0 Attachment
              Robert Cussons wrote:
              > Peter Hodge wrote:
              >
              >> Some GUIs will allow you to use the command
              >>
              >> set guifont=*
              >>
              >> Which brings up a font selection window. If that works, you can
              >> select a font
              >> and then use
              >>
              >> set guifont
              >>
              >> to find out exactly what to add to your .vimrc
              >>
              >> regards,
              >> Peter
              >>
              >> --- Yakov Lerner <iler.ml@...> wrote:
              >>
              >>
              >>> On 7/31/06, Robert Cussons <r.cussons@...> wrote:
              >>>
              >>>> I just installed vim 7 on my linux system at work (more specifically
              >>>> debian sarge running KDE 3.3) and I get a few funny things
              >>>> happening. It
              >>>> is installed in my home/bin directory as I don't have root permissions.
              >>>> All comments seem to come out underlined and the fonts for everything
              >>>> including the menus are different to before, I don't know how to check
              >>>> the current font setting, but when I type :set, there doesn't seem
              >>>> to be
              >>>> anything that would have changed the font listed. Anyone had the same
              >>>> problems?
              >>>
              >>>
              >>> :set guifont?
              >>>
              >>> Yakov
              >>>
              >>
              >>
              >>
              >> Send instant messages to your online friends
              >> http://au.messenger.yahoo.com
              >
              >
              > Thanks Yakov and Peter, it appears that the problem may be more with
              > Vim7 finding the fonts on my system. I had Sans regular 12 on Vim6.3 and
              > the list of fonts there is greater than that in Vim7, do I need to tell
              > Vim where to look for fonts, if so how do I check where Vim 6.3 looks
              > and tell Vim 7 to look there as well. I think this is because 6.3 is a
              > network wide install and 7 is installed in my home directory.
              >
              > Thanks,
              > Rob.
              >

              I just discovered that the font is not Sans regular 12 on Vim6.3 because
              when I use :set guifont=* although that is the font that is highlighted,
              if I actually apply it then the font changes (to Sans regular 12) and to
              change it back I have to use :set guifont=
              with no argument, so I guess I must be displaying the default font or
              something?
            • Yakov Lerner
              ... 1. In vim6.3 , try ... and select the font name with mouse 2. In vim7, try ... where xxx if font name as you selected it from vim6.3 If you get the right
              Message 6 of 19 , Jul 31, 2006
              • 0 Attachment
                On 7/31/06, Robert Cussons <r.cussons@...> wrote:
                > Robert Cussons wrote:
                > > Peter Hodge wrote:
                > >
                > >> Some GUIs will allow you to use the command
                > >>
                > >> set guifont=*
                > >>
                > >> Which brings up a font selection window. If that works, you can
                > >> select a font
                > >> and then use
                > >>
                > >> set guifont
                > >>
                > >> to find out exactly what to add to your .vimrc
                > >>
                > >> regards,
                > >> Peter
                > >>
                > >> --- Yakov Lerner <iler.ml@...> wrote:
                > >>
                > >>
                > >>> On 7/31/06, Robert Cussons <r.cussons@...> wrote:
                > >>>
                > >>>> I just installed vim 7 on my linux system at work (more specifically
                > >>>> debian sarge running KDE 3.3) and I get a few funny things
                > >>>> happening. It
                > >>>> is installed in my home/bin directory as I don't have root permissions.
                > >>>> All comments seem to come out underlined and the fonts for everything
                > >>>> including the menus are different to before, I don't know how to check
                > >>>> the current font setting, but when I type :set, there doesn't seem
                > >>>> to be
                > >>>> anything that would have changed the font listed. Anyone had the same
                > >>>> problems?
                > >>>
                > >>>
                > >>> :set guifont?
                > >>>
                > >>> Yakov
                > >>>
                > >>
                > >>
                > >>
                > >> Send instant messages to your online friends
                > >> http://au.messenger.yahoo.com
                > >
                > >
                > > Thanks Yakov and Peter, it appears that the problem may be more with
                > > Vim7 finding the fonts on my system. I had Sans regular 12 on Vim6.3 and
                > > the list of fonts there is greater than that in Vim7, do I need to tell
                > > Vim where to look for fonts, if so how do I check where Vim 6.3 looks
                > > and tell Vim 7 to look there as well. I think this is because 6.3 is a
                > > network wide install and 7 is installed in my home directory.
                > >
                > > Thanks,
                > > Rob.
                > >
                >
                > I just discovered that the font is not Sans regular 12 on Vim6.3 because
                > when I use :set guifont=* although that is the font that is highlighted,
                > if I actually apply it then the font changes (to Sans regular 12) and to
                > change it back I have to use :set guifont=
                > with no argument, so I guess I must be displaying the default font or
                > something?

                1. In vim6.3 , try
                :set guifont?
                and select the font name with mouse
                2. In vim7, try
                :set guifont=xxx
                where xxx if font name as you selected it from vim6.3
                If you get the right font, then put this :set guifont=xxx line into .vimrc

                Yakov
              • Robert Cussons
                ... Hi Yakov, ... yields the same result in both cases: guifont= with no font specified, but the fonts are not the same, hence I think they must be looking at
                Message 7 of 19 , Jul 31, 2006
                • 0 Attachment
                  Yakov Lerner wrote:
                  >
                  >
                  > 1. In vim6.3 , try
                  > :set guifont?
                  > and select the font name with mouse
                  > 2. In vim7, try
                  > :set guifont=xxx
                  > where xxx if font name as you selected it from vim6.3
                  > If you get the right font, then put this :set guifont=xxx line into .vimrc
                  >
                  > Yakov
                  >

                  Hi Yakov,

                  :set guifont?

                  yields the same result in both cases:

                  guifont=

                  with no font specified, but the fonts are not the same, hence I think
                  they must be looking at a different default font somewhere. If I knew
                  what the actual font it was using in vim6.3 was, then I would be able to
                  do something, but I can't see how to find out. Any ideas anyone?

                  Thanks,
                  Rob.
                • Yakov Lerner
                  ... I do not know of other way other than brute-froce searching in ... in my vimrc (this is GTK2 gvim) but font names are different depending on gui flavor of
                  Message 8 of 19 , Jul 31, 2006
                  • 0 Attachment
                    On 7/31/06, Robert Cussons <r.cussons@...> wrote:
                    > Yakov Lerner wrote:
                    > >
                    > >
                    > > 1. In vim6.3 , try
                    > > :set guifont?
                    > > and select the font name with mouse
                    > > 2. In vim7, try
                    > > :set guifont=xxx
                    > > where xxx if font name as you selected it from vim6.3
                    > > If you get the right font, then put this :set guifont=xxx line into .vimrc
                    > >
                    > > Yakov
                    > >
                    >
                    > Hi Yakov,
                    >
                    > :set guifont?
                    >
                    > yields the same result in both cases:
                    >
                    > guifont=
                    >
                    > with no font specified, but the fonts are not the same, hence I think
                    > they must be looking at a different default font somewhere. If I knew
                    > what the actual font it was using in vim6.3 was, then I would be able to
                    > do something, but I can't see how to find out. Any ideas anyone?

                    I do not know of other way other than brute-froce searching in
                    'set guifont=*' for the right name/size. I have:
                    :set guifont=Monospace\ 9
                    in my vimrc (this is GTK2 gvim) but font names are different depending
                    on gui flavor of gvim.

                    Take a look at Antonie's tip
                    http://www.vim.org/tips/tip.php?tip_id=632
                    "Setting the font in the GUI"

                    Yakov
                  • Robert Cussons
                    ... Thanks Yakov, I will look over Antoine s tip in more detail tonight and see if I can t find a solution. Many thanks, Rob.
                    Message 9 of 19 , Jul 31, 2006
                    • 0 Attachment
                      Yakov Lerner wrote:
                      > On 7/31/06, Robert Cussons <r.cussons@...> wrote:
                      >
                      >> Yakov Lerner wrote:
                      >> >
                      >> >
                      >> > 1. In vim6.3 , try
                      >> > :set guifont?
                      >> > and select the font name with mouse
                      >> > 2. In vim7, try
                      >> > :set guifont=xxx
                      >> > where xxx if font name as you selected it from vim6.3
                      >> > If you get the right font, then put this :set guifont=xxx line into
                      >> .vimrc
                      >> >
                      >> > Yakov
                      >> >
                      >>
                      >> Hi Yakov,
                      >>
                      >> :set guifont?
                      >>
                      >> yields the same result in both cases:
                      >>
                      >> guifont=
                      >>
                      >> with no font specified, but the fonts are not the same, hence I think
                      >> they must be looking at a different default font somewhere. If I knew
                      >> what the actual font it was using in vim6.3 was, then I would be able to
                      >> do something, but I can't see how to find out. Any ideas anyone?
                      >
                      >
                      > I do not know of other way other than brute-froce searching in
                      > 'set guifont=*' for the right name/size. I have:
                      > :set guifont=Monospace\ 9
                      > in my vimrc (this is GTK2 gvim) but font names are different depending
                      > on gui flavor of gvim.
                      >
                      > Take a look at Antonie's tip
                      > http://www.vim.org/tips/tip.php?tip_id=632
                      > "Setting the font in the GUI"
                      >
                      > Yakov
                      >

                      Thanks Yakov, I will look over Antoine's tip in more detail tonight and
                      see if I can't find a solution.

                      Many thanks,
                      Rob.
                    • Robert Cussons
                      ... I found out by accident that the font is Monospace 10, so I put the following line in my .vimrc set guifont=Monospace 10 but I still get different fonts,
                      Message 10 of 19 , Jul 31, 2006
                      • 0 Attachment
                        Robert Cussons wrote:
                        >
                        >
                        > Peter Hodge wrote:
                        >
                        >> Some GUIs will allow you to use the command
                        >>
                        >> set guifont=*
                        >>
                        >> Which brings up a font selection window. If that works, you can
                        >> select a font
                        >> and then use
                        >>
                        >> set guifont
                        >>
                        >> to find out exactly what to add to your .vimrc
                        >>
                        >> regards,
                        >> Peter
                        >>
                        >> --- Yakov Lerner <iler.ml@...> wrote:
                        >>
                        >>
                        >>> On 7/31/06, Robert Cussons <r.cussons@...> wrote:
                        >>>
                        >>>> I just installed vim 7 on my linux system at work (more specifically
                        >>>> debian sarge running KDE 3.3) and I get a few funny things
                        >>>> happening. It
                        >>>> is installed in my home/bin directory as I don't have root permissions.
                        >>>> All comments seem to come out underlined and the fonts for everything
                        >>>> including the menus are different to before, I don't know how to check
                        >>>> the current font setting, but when I type :set, there doesn't seem
                        >>>> to be
                        >>>> anything that would have changed the font listed. Anyone had the same
                        >>>> problems?
                        >>>
                        >>>
                        >>> :set guifont?
                        >>>
                        >>> Yakov
                        >>>
                        >>
                        >>
                        >>
                        >> Send instant messages to your online friends
                        >> http://au.messenger.yahoo.com
                        >

                        I found out by accident that the font is Monospace 10, so I put the
                        following line in my .vimrc

                        set guifont=Monospace\ 10

                        but I still get different fonts, I have attached a screenshot of two
                        gvim sessions, lhs is gvim7, rhs is gvim6.3, if you look at the bottom
                        of each window is sets the font as I have just executed :set guifont? in
                        each of the windows. They have both accessed and read the .vimrc it
                        would seem, so what is wrong?

                        Any help would be greatly appreciated, this is becoming mildly
                        frustrating :-)

                        Rob.

                        I just got this e-mail bounced back, turns out I can't send a .png file
                        to the group, don't have any ideas how else to show it to anyone that
                        cares :-( and could help :-)
                      • A.J.Mechelynck
                        ... If you have a home site somewhere where you have upload permissions, load it there, then send the URI to the list in an email. If you don y yet have a home
                        Message 11 of 19 , Jul 31, 2006
                        • 0 Attachment
                          Robert Cussons wrote:
                          > Robert Cussons wrote:
                          >>
                          >>
                          >> Peter Hodge wrote:
                          >>
                          >>> Some GUIs will allow you to use the command
                          >>>
                          >>> set guifont=*
                          >>>
                          >>> Which brings up a font selection window. If that works, you can
                          >>> select a font
                          >>> and then use
                          >>>
                          >>> set guifont
                          >>>
                          >>> to find out exactly what to add to your .vimrc
                          >>>
                          >>> regards,
                          >>> Peter
                          >>>
                          >>> --- Yakov Lerner <iler.ml@...> wrote:
                          >>>
                          >>>
                          >>>> On 7/31/06, Robert Cussons <r.cussons@...> wrote:
                          >>>>
                          >>>>> I just installed vim 7 on my linux system at work (more specifically
                          >>>>> debian sarge running KDE 3.3) and I get a few funny things
                          >>>>> happening. It
                          >>>>> is installed in my home/bin directory as I don't have root
                          >>>>> permissions.
                          >>>>> All comments seem to come out underlined and the fonts for everything
                          >>>>> including the menus are different to before, I don't know how to check
                          >>>>> the current font setting, but when I type :set, there doesn't seem
                          >>>>> to be
                          >>>>> anything that would have changed the font listed. Anyone had the same
                          >>>>> problems?
                          >>>>
                          >>>>
                          >>>> :set guifont?
                          >>>>
                          >>>> Yakov
                          >>>>
                          >>>
                          >>>
                          >>>
                          >>> Send instant messages to your online friends
                          >>> http://au.messenger.yahoo.com
                          >>
                          >
                          > I found out by accident that the font is Monospace 10, so I put the
                          > following line in my .vimrc
                          >
                          > set guifont=Monospace\ 10
                          >
                          > but I still get different fonts, I have attached a screenshot of two
                          > gvim sessions, lhs is gvim7, rhs is gvim6.3, if you look at the bottom
                          > of each window is sets the font as I have just executed :set guifont? in
                          > each of the windows. They have both accessed and read the .vimrc it
                          > would seem, so what is wrong?
                          >
                          > Any help would be greatly appreciated, this is becoming mildly
                          > frustrating :-)
                          >
                          > Rob.
                          >
                          > I just got this e-mail bounced back, turns out I can't send a .png file
                          > to the group, don't have any ideas how else to show it to anyone that
                          > cares :-( and could help :-)
                          >
                          >
                          >
                          >
                          >

                          If you have a home site somewhere where you have upload permissions,
                          load it there, then send the URI to the list in an email.

                          If you don'y yet have a home site, find out if you can get one (for free
                          or for a nominal fee) from your ISP.

                          If you don't yet have an Internet account other than at your job, find
                          out at which conditions you can get one at home. Try your phone company
                          first, and also your cable-TV company if you have one.


                          Best regards,
                          Tony.
                        • Yakov Lerner
                          ... Are those two vims built with same GUI libraries ? I suspect that they are build with different GUIs. Can you send first 4 lines out :version output from
                          Message 12 of 19 , Jul 31, 2006
                          • 0 Attachment
                            On 7/31/06, Robert Cussons <r.cussons@...> wrote:
                            > Robert Cussons wrote:
                            > >
                            > >
                            > > Peter Hodge wrote:
                            > >
                            > >> Some GUIs will allow you to use the command
                            > >>
                            > >> set guifont=*
                            > >>
                            > >> Which brings up a font selection window. If that works, you can
                            > >> select a font
                            > >> and then use
                            > >>
                            > >> set guifont
                            > >>
                            > >> to find out exactly what to add to your .vimrc
                            > >>
                            > >> regards,
                            > >> Peter
                            > >>
                            > >> --- Yakov Lerner <iler.ml@...> wrote:
                            > >>
                            > >>
                            > >>> On 7/31/06, Robert Cussons <r.cussons@...> wrote:
                            > >>>
                            > >>>> I just installed vim 7 on my linux system at work (more specifically
                            > >>>> debian sarge running KDE 3.3) and I get a few funny things
                            > >>>> happening. It
                            > >>>> is installed in my home/bin directory as I don't have root permissions.
                            > >>>> All comments seem to come out underlined and the fonts for everything
                            > >>>> including the menus are different to before, I don't know how to check
                            > >>>> the current font setting, but when I type :set, there doesn't seem
                            > >>>> to be
                            > >>>> anything that would have changed the font listed. Anyone had the same
                            > >>>> problems?
                            > >>>
                            > >>>
                            > >>> :set guifont?
                            > >>>
                            > >>> Yakov
                            > >>>
                            > >>
                            > >>
                            > >>
                            > >> Send instant messages to your online friends
                            > >> http://au.messenger.yahoo.com
                            > >
                            >
                            > I found out by accident that the font is Monospace 10, so I put the
                            > following line in my .vimrc
                            >
                            > set guifont=Monospace\ 10
                            >
                            > but I still get different fonts, I have attached a screenshot of two
                            > gvim sessions, lhs is gvim7, rhs is gvim6.3, if you look at the bottom
                            > of each window is sets the font as I have just executed :set guifont? in
                            > each of the windows. They have both accessed and read the .vimrc it
                            > would seem, so what is wrong?

                            Are those two vims built with same GUI libraries ? I suspect
                            that they are build with different GUIs.
                            Can you send first 4 lines out :version output from each of two vims ?

                            Yakov

                            P.S. I remember that I had similar issue between one Qt-based
                            program and similar Xt-based program. I set same font for them two,
                            but they showed it rather differently. Maybe you'll want to rebuild
                            vim7 to use same GUI as your vim6.3. If you send first 4 lines from
                            both vims :version, we'll know which GUI they are both built with.
                          • Robert Cussons
                            ... VIM - Vi IMproved 7.0 (2006 May 7, compiled Jul 31 2006 08:50:59) Included patches: 1-42 Compiled by ... Huge version with X11-Motif GUI. Features
                            Message 13 of 19 , Jul 31, 2006
                            • 0 Attachment
                              <snip>
                              >
                              >
                              > Are those two vims built with same GUI libraries ? I suspect
                              > that they are build with different GUIs.
                              > Can you send first 4 lines out :version output from each of two vims ?
                              >
                              > Yakov
                              >
                              > P.S. I remember that I had similar issue between one Qt-based
                              > program and similar Xt-based program. I set same font for them two,
                              > but they showed it rather differently. Maybe you'll want to rebuild
                              > vim7 to use same GUI as your vim6.3. If you send first 4 lines from
                              > both vims :version, we'll know which GUI they are both built with.
                              >

                              VIM - Vi IMproved 7.0 (2006 May 7, compiled Jul 31 2006 08:50:59)
                              Included patches: 1-42
                              Compiled by ...
                              Huge version with X11-Motif GUI. Features included (+) or not (-):

                              VIM - Vi IMproved 6.3 (2004 June 7, compiled Jul 30 2005 12:36:01)
                              Included patches: 1-71, 81-82
                              Compiled by ...
                              Big version with GTK2 GUI. Features included (+) or not (-):


                              Seems you have hit the nail on the head Yakov, how would I rebuild Vim7
                              using your script but changing the GUI is it using the --configure options?

                              Many thanks for your help,
                              Rob.
                            • Yakov Lerner
                              ... a) install package openmotif-devel or (motif-dev or what s called) b) ./vim7-install.sh ----enable-gui=motif Caution: you must make sure motif-dev is
                              Message 14 of 19 , Jul 31, 2006
                              • 0 Attachment
                                On 7/31/06, Robert Cussons <r.cussons@...> wrote:
                                > <snip>
                                > >
                                > >
                                > > Are those two vims built with same GUI libraries ? I suspect
                                > > that they are build with different GUIs.
                                > > Can you send first 4 lines out :version output from each of two vims ?
                                > >
                                > > Yakov
                                > >
                                > > P.S. I remember that I had similar issue between one Qt-based
                                > > program and similar Xt-based program. I set same font for them two,
                                > > but they showed it rather differently. Maybe you'll want to rebuild
                                > > vim7 to use same GUI as your vim6.3. If you send first 4 lines from
                                > > both vims :version, we'll know which GUI they are both built with.
                                > >
                                >
                                > VIM - Vi IMproved 7.0 (2006 May 7, compiled Jul 31 2006 08:50:59)
                                > Included patches: 1-42
                                > Compiled by ...
                                > Huge version with X11-Motif GUI. Features included (+) or not (-):
                                >
                                > VIM - Vi IMproved 6.3 (2004 June 7, compiled Jul 30 2005 12:36:01)
                                > Included patches: 1-71, 81-82
                                > Compiled by ...
                                > Big version with GTK2 GUI. Features included (+) or not (-):
                                >
                                >
                                > Seems you have hit the nail on the head Yakov, how would I rebuild Vim7
                                > using your script but changing the GUI is it using the --configure options?

                                a) install package 'openmotif-devel' or (motif-dev or what's called)
                                b) ./vim7-install.sh ----enable-gui=motif

                                Caution: you must make sure motif-dev is instaleld, first.

                                Yakov
                              • Yakov Lerner
                                ... Oops, I misread the data. You ll want to rebuild vim with GTK2, not with motif, right? Then: ./vim7-install.sh ----enable-gui=gtk2 and you ll need
                                Message 15 of 19 , Jul 31, 2006
                                • 0 Attachment
                                  On 7/31/06, Yakov Lerner <iler.ml@...> wrote:
                                  > On 7/31/06, Robert Cussons <r.cussons@...> wrote:
                                  > > <snip>
                                  > > >
                                  > > >
                                  > > > Are those two vims built with same GUI libraries ? I suspect
                                  > > > that they are build with different GUIs.
                                  > > > Can you send first 4 lines out :version output from each of two vims ?
                                  > > >
                                  > > > Yakov
                                  > > >
                                  > > > P.S. I remember that I had similar issue between one Qt-based
                                  > > > program and similar Xt-based program. I set same font for them two,
                                  > > > but they showed it rather differently. Maybe you'll want to rebuild
                                  > > > vim7 to use same GUI as your vim6.3. If you send first 4 lines from
                                  > > > both vims :version, we'll know which GUI they are both built with.
                                  > > >
                                  > >
                                  > > VIM - Vi IMproved 7.0 (2006 May 7, compiled Jul 31 2006 08:50:59)
                                  > > Included patches: 1-42
                                  > > Compiled by ...
                                  > > Huge version with X11-Motif GUI. Features included (+) or not (-):
                                  > >
                                  > > VIM - Vi IMproved 6.3 (2004 June 7, compiled Jul 30 2005 12:36:01)
                                  > > Included patches: 1-71, 81-82
                                  > > Compiled by ...
                                  > > Big version with GTK2 GUI. Features included (+) or not (-):
                                  > >
                                  > >
                                  > > Seems you have hit the nail on the head Yakov, how would I rebuild Vim7
                                  > > using your script but changing the GUI is it using the --configure options?
                                  >
                                  > a) install package 'openmotif-devel' or (motif-dev or what's called)
                                  > b) ./vim7-install.sh ----enable-gui=motif

                                  Oops, I misread the data. You'll want to rebuild vim with GTK2, not
                                  with motif, right? Then:

                                  ./vim7-install.sh ----enable-gui=gtk2

                                  and you'll need gtk2-devel package installed

                                  Yakov
                                • Donald Axel
                                  I should have used my mail-list address, so I excuse for sending this mail twice. Hi Robert-in-search-of-fonts: This thread reminds me of an earlier when I
                                  Message 16 of 19 , Jul 31, 2006
                                  • 0 Attachment
                                    I should have used my mail-list address,
                                    so I excuse for sending this mail twice.


                                    Hi Robert-in-search-of-fonts:

                                    This thread reminds me of an earlier when I wonderer where my
                                    favourite fonts had disappeared.

                                    The "culprit" is the advanced x-fontset feature which GTK uses.
                                    I am not an expert on this GUI nor the other GUIs so I will confine
                                    this posting to a description of my practice after discovering what has
                                    been mentioned in this thread:

                                    1) I cannot find the old 8x16 font, nor -fn 12x24
                                    2) I get 12x24 when i use :set guifont=Fixed\ 12
                                    3) I can rebuild gvim without GTK and then use commandline -fn 12x24
                                    and all the other "old" fonts.

                                    ./configure \
                                    --disable-fontset \
                                    --with-x \
                                    --enable-gui=athena \
                                    --disable-nls \

                                    I must admit, that I prefer the GTK-GUI version and I have accepted
                                    the missing 8x16 because

                                    : set guifont=monospace\ 12

                                    or 14 is pretty much ok. This font seems antialiased, which to me
                                    and some others is a step backwards from the specially designed X11
                                    fonts which use half pixels etc. I am not a specialist but I believe
                                    half pixels are passé, they work only with CRT-screens so fx. 12x24
                                    looks more coarse on an LCD.

                                    Good luck with your search. Inform of your results and find a better
                                    subject line, like "no-fontset in Vim7".

                                    Regards/Donald Axel


                                    On Mon, 31 Jul 2006 14:20:10 +0200
                                    Robert Cussons <r.cussons@...> wrote:

                                    > <snip>
                                    > >
                                    > >
                                    > > Are those two vims built with same GUI libraries ? I suspect
                                    > > that they are build with different GUIs.
                                    > > Can you send first 4 lines out :version output from each of two vims ?
                                    > >
                                    > > Yakov
                                    > >
                                    > > P.S. I remember that I had similar issue between one Qt-based
                                    > > program and similar Xt-based program. I set same font for them two,
                                    > > but they showed it rather differently. Maybe you'll want to rebuild
                                    > > vim7 to use same GUI as your vim6.3. If you send first 4 lines from
                                    > > both vims :version, we'll know which GUI they are both built with.
                                    > >
                                    >
                                    > VIM - Vi IMproved 7.0 (2006 May 7, compiled Jul 31 2006 08:50:59)
                                    > Included patches: 1-42
                                    > Compiled by ...
                                    > Huge version with X11-Motif GUI. Features included (+) or not (-):
                                    >
                                    > VIM - Vi IMproved 6.3 (2004 June 7, compiled Jul 30 2005 12:36:01)
                                    > Included patches: 1-71, 81-82
                                    > Compiled by ...
                                    > Big version with GTK2 GUI. Features included (+) or not (-):
                                    >
                                    >
                                    > Seems you have hit the nail on the head Yakov, how would I rebuild Vim7
                                    > using your script but changing the GUI is it using the --configure options?
                                    >
                                    > Many thanks for your help,
                                    > Rob.


                                    --
                                    http://d-axel.dk/ -- Donald Axel, Consultant -- donald@...
                                  • A.J.Mechelynck
                                    ... :set guifont=Monospace 10 is applicable only to GTK+2 (or GNOME 2). kvim would require :set guifont=Monospace/10 ; other X11 GUIs would require
                                    Message 17 of 19 , Jul 31, 2006
                                    • 0 Attachment
                                      Yakov Lerner wrote:
                                      > On 7/31/06, Robert Cussons <r.cussons@...> wrote:
                                      >> Robert Cussons wrote:
                                      >> >
                                      >> >
                                      >> > Peter Hodge wrote:
                                      >> >
                                      >> >> Some GUIs will allow you to use the command
                                      >> >>
                                      >> >> set guifont=*
                                      >> >>
                                      >> >> Which brings up a font selection window. If that works, you can
                                      >> >> select a font
                                      >> >> and then use
                                      >> >>
                                      >> >> set guifont
                                      >> >>
                                      >> >> to find out exactly what to add to your .vimrc
                                      >> >>
                                      >> >> regards,
                                      >> >> Peter
                                      >> >>
                                      >> >> --- Yakov Lerner <iler.ml@...> wrote:
                                      >> >>
                                      >> >>
                                      >> >>> On 7/31/06, Robert Cussons <r.cussons@...> wrote:
                                      >> >>>
                                      >> >>>> I just installed vim 7 on my linux system at work (more specifically
                                      >> >>>> debian sarge running KDE 3.3) and I get a few funny things
                                      >> >>>> happening. It
                                      >> >>>> is installed in my home/bin directory as I don't have root
                                      >> permissions.
                                      >> >>>> All comments seem to come out underlined and the fonts for
                                      >> everything
                                      >> >>>> including the menus are different to before, I don't know how to
                                      >> check
                                      >> >>>> the current font setting, but when I type :set, there doesn't seem
                                      >> >>>> to be
                                      >> >>>> anything that would have changed the font listed. Anyone had the
                                      >> same
                                      >> >>>> problems?
                                      >> >>>
                                      >> >>>
                                      >> >>> :set guifont?
                                      >> >>>
                                      >> >>> Yakov
                                      >> >>>
                                      >> >>
                                      >> >>
                                      >> >>
                                      >> >> Send instant messages to your online friends
                                      >> >> http://au.messenger.yahoo.com
                                      >> >
                                      >>
                                      >> I found out by accident that the font is Monospace 10, so I put the
                                      >> following line in my .vimrc
                                      >>
                                      >> set guifont=Monospace\ 10
                                      >>
                                      >> but I still get different fonts, I have attached a screenshot of two
                                      >> gvim sessions, lhs is gvim7, rhs is gvim6.3, if you look at the bottom
                                      >> of each window is sets the font as I have just executed :set guifont? in
                                      >> each of the windows. They have both accessed and read the .vimrc it
                                      >> would seem, so what is wrong?
                                      >
                                      > Are those two vims built with same GUI libraries ? I suspect
                                      > that they are build with different GUIs.
                                      > Can you send first 4 lines out :version output from each of two vims ?
                                      >
                                      > Yakov
                                      >
                                      > P.S. I remember that I had similar issue between one Qt-based
                                      > program and similar Xt-based program. I set same font for them two,
                                      > but they showed it rather differently. Maybe you'll want to rebuild
                                      > vim7 to use same GUI as your vim6.3. If you send first 4 lines from
                                      > both vims :version, we'll know which GUI they are both built with.
                                      >
                                      >

                                      ":set guifont=Monospace\ 10" is applicable only to GTK+2 (or GNOME 2).
                                      kvim would require ":set guifont=Monospace/10"; other X11 GUIs would
                                      require something like ":set
                                      guifont=*-monospace-medium-r-normal-*-*-180-*-*-m-*-*"; and non-X11 GUIs
                                      something like ":set guifont=Monospace:h10".

                                      However, IIUC "Monospace" is a generic font name (like "Serif" or
                                      "Sans-serif"). I believe the mapping from such "generic" names to
                                      "actual" fonts (like Courier or Lucida for Monospace, Times or Century
                                      for Serif, Arial or Helvetica for Sans-serif, etc.) can be different
                                      from one system to another.

                                      The OP might want to find one particular fixed-width font that suits him
                                      and try to set that on his several systems. If his version of gvim
                                      allows it, he can try ":set guifont=*" for a start; if it doesn't, he
                                      can paste into his vimrc the following snippet:

                                      if has("gui_running")
                                      if has("gui_gtk2")
                                      set guifont=Courier\ 10
                                      elseif has("gui_kde")
                                      set guifont=Courier/10
                                      elseif has("x11")
                                      let &guifont = "*-courier-medium-r-normal"
                                      \ . "-*-*-100-*-*-m-*-*"
                                      else
                                      set guifont=Courier:h10
                                      endif
                                      endif

                                      where I have intentionally cut the long Xft font name in two to avoid
                                      problems with "beautifying" mail clients. (This assumes 'nocompatible'
                                      is set.)

                                      Then, once the 'guifont' looks "almost right", the value can be edited
                                      on the command-line by means of

                                      :set guifont=<Tab>

                                      which will recall the current value with escaping slashes if and where
                                      required. Edit it on the command line, then hit Enter to accept the
                                      changes or Esc to cancel the changes. Once the value is "just right",
                                      copy it back to the vimrc.

                                      Remember that changing the 'guifont' will usually change the pixel size
                                      of the character cell, which may in turn require setting 'lines' and
                                      'columns' again. If you want gvim to be maximized, use ":set lines=999
                                      columns=999" immediately after every change to 'guifont'.


                                      Best regards,
                                      Tony.
                                    • A.J.Mechelynck
                                      ... See also my HowTo page http://users.skynet.be/antoine.mechelynck/vim/compunix.htm which includes the following bash script #!/bin/bash export
                                      Message 18 of 19 , Jul 31, 2006
                                      • 0 Attachment
                                        Yakov Lerner wrote:
                                        > On 7/31/06, Yakov Lerner <iler.ml@...> wrote:
                                        >> On 7/31/06, Robert Cussons <r.cussons@...> wrote:
                                        >> > <snip>
                                        >> > >
                                        >> > >
                                        >> > > Are those two vims built with same GUI libraries ? I suspect
                                        >> > > that they are build with different GUIs.
                                        >> > > Can you send first 4 lines out :version output from each of two
                                        >> vims ?
                                        >> > >
                                        >> > > Yakov
                                        >> > >
                                        >> > > P.S. I remember that I had similar issue between one Qt-based
                                        >> > > program and similar Xt-based program. I set same font for them two,
                                        >> > > but they showed it rather differently. Maybe you'll want to rebuild
                                        >> > > vim7 to use same GUI as your vim6.3. If you send first 4 lines from
                                        >> > > both vims :version, we'll know which GUI they are both built with.
                                        >> > >
                                        >> >
                                        >> > VIM - Vi IMproved 7.0 (2006 May 7, compiled Jul 31 2006 08:50:59)
                                        >> > Included patches: 1-42
                                        >> > Compiled by ...
                                        >> > Huge version with X11-Motif GUI. Features included (+) or not (-):
                                        >> >
                                        >> > VIM - Vi IMproved 6.3 (2004 June 7, compiled Jul 30 2005 12:36:01)
                                        >> > Included patches: 1-71, 81-82
                                        >> > Compiled by ...
                                        >> > Big version with GTK2 GUI. Features included (+) or not (-):
                                        >> >
                                        >> >
                                        >> > Seems you have hit the nail on the head Yakov, how would I rebuild Vim7
                                        >> > using your script but changing the GUI is it using the --configure
                                        >> options?
                                        >>
                                        >> a) install package 'openmotif-devel' or (motif-dev or what's called)
                                        >> b) ./vim7-install.sh ----enable-gui=motif
                                        >
                                        > Oops, I misread the data. You'll want to rebuild vim with GTK2, not
                                        > with motif, right? Then:
                                        >
                                        > ./vim7-install.sh ----enable-gui=gtk2
                                        >
                                        > and you'll need gtk2-devel package installed
                                        >
                                        > Yakov
                                        >
                                        >

                                        See also my HowTo page
                                        http://users.skynet.be/antoine.mechelynck/vim/compunix.htm which
                                        includes the following bash script

                                        #!/bin/bash
                                        export CONF_OPT_GUI='--enable-gnome-check'
                                        export CONF_OPT_PERL='--enable-perlinterp'
                                        export CONF_OPT_PYTHON='--enable-pythoninterp'
                                        export CONF_OPT_TCL='--enable-tclinterp --with-tcl=tclsh8.4'
                                        export CONF_OPT_RUBY='--enable-rubyinterp'
                                        export CONF_OPT_MZSCHEME='--enable-mzschemeinterp'
                                        export CONF_OPT_CSCOPE='--enable-cscope'
                                        export CONF_OPT_MULTIBYTE='--enable-multibyte'
                                        export CONF_OPT_OUTPUT='--enable-fontset'
                                        export CONF_OPT_FEAT='--with-features=huge'
                                        export CONF_OPT_COMPBY='"--with-compiledby=antoine.mechelynck@..."'

                                        which I source (in bash; "running" it in bash without "source" or "."
                                        doesn't work) to set configure options. IIUC, configure will pick GTK+2
                                        in preference to ther GUIs if it finds that the gtk2-devel package is
                                        installed. You may use that script, and you will want to modify one or
                                        more lines of it (including, at least, the --with-compiledby to put your
                                        name there instead of mine). The result I get is the following (with
                                        -python and -mzscheme even though I enabled them, because I haven't got
                                        the corresponding "development" packages"; pretty much everything else
                                        is included):


                                        VIM - Vi IMproved 7.0 (2006 May 7, compiled Jul 23 2006 22:50:51)
                                        Included patches: 1-42
                                        Compiled by antoine.mechelynck@...
                                        Huge version with GTK2-GNOME GUI. Features included (+) or not (-):
                                        +arabic +autocmd +balloon_eval +browse ++builtin_terms +byte_offset
                                        +cindent +clientserver
                                        +clipboard +cmdline_compl +cmdline_hist +cmdline_info +comments +cryptv
                                        +cscope +cursorshape
                                        +dialog_con_gui +diff +digraphs +dnd -ebcdic +emacs_tags +eval +ex_extra
                                        +extra_search +farsi
                                        +file_in_path +find_in_path +folding -footer +fork() +gettext
                                        -hangul_input +iconv +insert_expand
                                        +jumplist +keymap +langmap +libcall +linebreak +lispindent +listcmds
                                        +localmap +menu +mksession
                                        +modify_fname +mouse +mouseshape +mouse_dec +mouse_gpm -mouse_jsbterm
                                        +mouse_netterm +mouse_xterm
                                        +multi_byte +multi_lang -mzscheme +netbeans_intg -osfiletype +path_extra
                                        +perl +postscript
                                        +printer +profile -python +quickfix +reltime +rightleft +ruby
                                        +scrollbind +signs +smartindent
                                        -sniff +statusline -sun_workshop +syntax +tag_binary +tag_old_static
                                        -tag_any_white +tcl +terminfo
                                        +termresponse +textobjects +title +toolbar +user_commands +vertsplit
                                        +virtualedit +visual
                                        +visualextra +viminfo +vreplace +wildignore +wildmenu +windows
                                        +writebackup +X11 -xfontset +xim
                                        +xsmp_interact +xterm_clipboard -xterm_save
                                        system vimrc file: "$VIM/vimrc"
                                        user vimrc file: "$HOME/.vimrc"
                                        user exrc file: "$HOME/.exrc"
                                        system gvimrc file: "$VIM/gvimrc"
                                        user gvimrc file: "$HOME/.gvimrc"
                                        system menu file: "$VIMRUNTIME/menu.vim"
                                        fall-back for $VIM: "/usr/local/share/vim"
                                        Compilation: gcc -c -I. -Iproto -DHAVE_CONFIG_H -DFEAT_GUI_GTK
                                        -DXTHREADS -D_REENTRANT -DXUSE_MTSAFE_API -I/opt/gnome/include/gtk-2.0
                                        -I/opt/gnome/lib/gtk-2.0/include -I/usr/X11R6/include
                                        -I/opt/gnome/include/atk-1.0 -I/opt/gnome/include/pango-1.0
                                        -I/usr/include/freetype2 -I/usr/include/freetype2/config
                                        -I/opt/gnome/include/glib-2.0 -I/opt/gnome/lib/glib-2.0/include
                                        -DORBIT2=1 -pthread -DXTHREADS -D_REENTRANT -DXUSE_MTSAFE_API
                                        -I/usr/include/libart-2.0 -I/usr/include/libxml2
                                        -I/opt/gnome/include/libgnomeui-2.0 -I/opt/gnome/include/libgnome-2.0
                                        -I/opt/gnome/include/libgnomecanvas-2.0 -I/opt/gnome/include/gtk-2.0
                                        -I/opt/gnome/include/gconf/2 -I/opt/gnome/include/libbonoboui-2.0
                                        -I/opt/gnome/include/glib-2.0 -I/opt/gnome/lib/glib-2.0/include
                                        -I/opt/gnome/include/orbit-2.0 -I/opt/gnome/include/libbonobo-2.0
                                        -I/opt/gnome/include/gnome-vfs-2.0
                                        -I/opt/gnome/lib/gnome-vfs-2.0/include
                                        -I/opt/gnome/include/bonobo-activation-2.0
                                        -I/opt/gnome/include/pango-1.0 -I/usr/include/freetype2
                                        -I/opt/gnome/lib/gtk-2.0/include -I/usr/X11R6/include
                                        -I/opt/gnome/include/atk-1.0 -I/usr/include/freetype2/config -O2
                                        -fno-strength-reduce -Wall -I/usr/X11R6/include -D_REENTRANT
                                        -D_GNU_SOURCE -DTHREADS_HAVE_PIDS -DDEBUGGING -pipe -D_LARGEFILE_SOURCE
                                        -D_FILE_OFFSET_BITS=64
                                        -I/usr/lib/perl5/5.8.6/i586-linux-thread-multi/CORE -I/usr/include
                                        -D_LARGEFILE64_SOURCE=1 -I/usr/lib/ruby/1.8/i686-linux
                                        Linking: gcc -L/opt/gnome/lib -L/usr/X11R6/lib -rdynamic -Wl,-E
                                        -Wl,-rpath,/usr/lib/perl5/5.8.6/i586-linux-thread-multi/CORE
                                        -L/usr/local/lib -o vim -L/opt/gnome/lib -lgtk-x11-2.0 -lgdk-x11-2.0
                                        -latk-1.0 -lgdk_pixbuf-2.0 -lpangoxft-1.0 -lpangox-1.0 -lpango-1.0
                                        -lgobject-2.0 -lgmodule-2.0 -lglib-2.0 -L/opt/gnome/lib
                                        -L/usr/X11R6/lib -lgnomeui-2 -lbonoboui-2 -lxml2 -lz -lgnomecanvas-2
                                        -lgnome-2 -lpopt -lart_lgpl_2 -lpangoft2-1.0 -lgtk-x11-2.0 -lgdk-x11-2.0
                                        -latk-1.0 -lgdk_pixbuf-2.0 -lpangoxft-1.0 -lpangox-1.0 -lpango-1.0
                                        -lgobject-2.0 -lgnomevfs-2 -lbonobo-2 -lgconf-2 -lbonobo-activation
                                        -lORBit-2 -lgmodule-2.0 -lgthread-2.0 -lglib-2.0 -lXt -lncurses -lgpm
                                        -Wl,-E -Wl,-rpath,/usr/lib/perl5/5.8.6/i586-linux-thread-multi/CORE
                                        /usr/lib/perl5/5.8.6/i586-linux-thread-multi/auto/DynaLoader/DynaLoader.a
                                        -L/usr/lib/perl5/5.8.6/i586-linux-thread-multi/CORE -lperl -lutil -lc
                                        -L/usr/lib -ltcl8.4 -lieee -lruby -lm



                                        Best regards,
                                        Tony.
                                      • Robert Cussons
                                        ... Thanks very much to everyone who helped with this, I m afraid I chickened out in the end and asked the network administrator, he backported a vim 7
                                        Message 19 of 19 , Aug 1, 2006
                                        • 0 Attachment
                                          Yakov Lerner wrote:
                                          > On 7/31/06, Robert Cussons <r.cussons@...> wrote:
                                          >
                                          >> <snip>
                                          >> >
                                          >> >
                                          >> > Are those two vims built with same GUI libraries ? I suspect
                                          >> > that they are build with different GUIs.
                                          >> > Can you send first 4 lines out :version output from each of two vims ?
                                          >> >
                                          >> > Yakov
                                          >> >
                                          >> > P.S. I remember that I had similar issue between one Qt-based
                                          >> > program and similar Xt-based program. I set same font for them two,
                                          >> > but they showed it rather differently. Maybe you'll want to rebuild
                                          >> > vim7 to use same GUI as your vim6.3. If you send first 4 lines from
                                          >> > both vims :version, we'll know which GUI they are both built with.
                                          >> >
                                          >>
                                          >> VIM - Vi IMproved 7.0 (2006 May 7, compiled Jul 31 2006 08:50:59)
                                          >> Included patches: 1-42
                                          >> Compiled by ...
                                          >> Huge version with X11-Motif GUI. Features included (+) or not (-):
                                          >>
                                          >> VIM - Vi IMproved 6.3 (2004 June 7, compiled Jul 30 2005 12:36:01)
                                          >> Included patches: 1-71, 81-82
                                          >> Compiled by ...
                                          >> Big version with GTK2 GUI. Features included (+) or not (-):
                                          >>
                                          >>
                                          >> Seems you have hit the nail on the head Yakov, how would I rebuild Vim7
                                          >> using your script but changing the GUI is it using the --configure
                                          >> options?
                                          >
                                          >
                                          > a) install package 'openmotif-devel' or (motif-dev or what's called)
                                          > b) ./vim7-install.sh ----enable-gui=motif
                                          >
                                          > Caution: you must make sure motif-dev is instaleld, first.
                                          >
                                          > Yakov
                                          >

                                          Thanks very much to everyone who helped with this, I'm afraid I
                                          chickened out in the end and asked the network administrator, he
                                          backported a vim 7 compiled with GTK2 GUI onto my machine, which has
                                          solved the problem.

                                          Many thanks again for all the help,
                                          Rob.
                                        Your message has been successfully submitted and would be delivered to recipients shortly.