Loading ...
Sorry, an error occurred while loading the content.

Compiling Vim 7 Using Aap On Kubuntu

Expand Messages
  • Tom Purl
    Hi, I m trying to compile the latest and greatest version of Vim using AAP (since that seems to be the preferred way of doing it), and am getting an odd error.
    Message 1 of 3 , Jul 1, 2006
    • 0 Attachment
      Hi, I'm trying to compile the latest and greatest version of Vim
      using AAP (since that seems to be the preferred way of doing it), and
      am getting an odd error. Here's the process that I'm following:

      1. Create a `vim7` folder in my home dir.
      * mkdir ~/vim7
      * cd ~/vim7
      2. I then run the command that's on the AAP web site:
      * aap -f http://www.a-a-p.org/vim/main.aap CVS=no

      When I do that, I get the following error:

      Aap: Attempting download of "http://www.a-a-p.org/vim/main.aap"
      Aap: Downloaded "http://www.a-a-p.org/vim/main.aap" to "main.aap"
      Aap: Created directory "patches"
      Aap: Internal Error
      Aap: Traceback (most recent call last):
      File "/usr/lib/aap/Process.py", line 1163, in Process
      exec script_string in recdict, recdict
      File "<string>", line 6, in ?
      File "/usr/lib/aap/Commands.py", line 3098, in aap_progsearch
      if " " in prog:
      TypeError: iterable argument required

      Aap: Aborted
      Aap: More info in the logfile: /home/tom/vim7/AAPDIR/log

      ...and here's what the log file says;

      extra: Reading recipe "main.aap"
      info: Created directory "patches"
      extra: Finished reading recipe "main.aap"
      depend: Adding default dependency for "cleanmore"
      depend: Not adding default dependency for "install"
      depend: Not adding default dependency for "uninstall"
      depend: Building the "all" target
      depend: 1 - updating target "all"
      depend: 2 - Using dependency "all : fetch"
      depend: 3 - updating target "fetch"
      depend: 4 - Using dependency "fetch : "
      depend: 3 - Updating "fetch" from "": virtual target
      note: :progsearch did not find any of ['cvs']
      error: Internal Error
      error: Traceback (most recent call last):
      File "/usr/lib/aap/Process.py", line 1164, in Process
      exec script_string in recdict, recdict
      File "<string>", line 6, in ?
      File "/usr/lib/aap/Commands.py", line 3098, in aap_progsearch
      if " " in prog:
      TypeError: iterable argument required

      error: Aborted

      Has anyone else seen anything like this? Do you think that this is
      an AAP problem (and therefore not something I should post on this
      list), or am I just doing it incorrectly?

      Thanks in advance!

      Tom Purl
    • Tom Purl
      Oh duh. I didn t realize hat I didn t have CVS installed on my workstation. Once I installed that via apt-get, my problem was solved.
      Message 2 of 3 , Jul 3, 2006
      • 0 Attachment
        Oh duh. I didn't realize hat I didn't have CVS installed on my
        workstation. Once I installed that via apt-get, my problem was solved.

        On Sat, Jul 01, 2006 at 09:38:02PM -0500, Tom Purl wrote:
        > Hi, I'm trying to compile the latest and greatest version of Vim
        > using AAP (since that seems to be the preferred way of doing it), and
        > am getting an odd error. Here's the process that I'm following:
        >
        > 1. Create a `vim7` folder in my home dir.
        > * mkdir ~/vim7
        > * cd ~/vim7
        > 2. I then run the command that's on the AAP web site:
        > * aap -f http://www.a-a-p.org/vim/main.aap CVS=no
        >
        > When I do that, I get the following error:
        >
        > Aap: Attempting download of "http://www.a-a-p.org/vim/main.aap"
        > Aap: Downloaded "http://www.a-a-p.org/vim/main.aap" to "main.aap"
        > Aap: Created directory "patches"
        > Aap: Internal Error
        > Aap: Traceback (most recent call last):
        > File "/usr/lib/aap/Process.py", line 1163, in Process
        > exec script_string in recdict, recdict
        > File "<string>", line 6, in ?
        > File "/usr/lib/aap/Commands.py", line 3098, in aap_progsearch
        > if " " in prog:
        > TypeError: iterable argument required
        >
        > Aap: Aborted
        > Aap: More info in the logfile: /home/tom/vim7/AAPDIR/log
        >
        > ...and here's what the log file says;
        >
        > extra: Reading recipe "main.aap"
        > info: Created directory "patches"
        > extra: Finished reading recipe "main.aap"
        > depend: Adding default dependency for "cleanmore"
        > depend: Not adding default dependency for "install"
        > depend: Not adding default dependency for "uninstall"
        > depend: Building the "all" target
        > depend: 1 - updating target "all"
        > depend: 2 - Using dependency "all : fetch"
        > depend: 3 - updating target "fetch"
        > depend: 4 - Using dependency "fetch : "
        > depend: 3 - Updating "fetch" from "": virtual target
        > note: :progsearch did not find any of ['cvs']
        > error: Internal Error
        > error: Traceback (most recent call last):
        > File "/usr/lib/aap/Process.py", line 1164, in Process
        > exec script_string in recdict, recdict
        > File "<string>", line 6, in ?
        > File "/usr/lib/aap/Commands.py", line 3098, in aap_progsearch
        > if " " in prog:
        > TypeError: iterable argument required
        >
        > error: Aborted
        >
        > Has anyone else seen anything like this? Do you think that this is
        > an AAP problem (and therefore not something I should post on this
        > list), or am I just doing it incorrectly?
        >
        > Thanks in advance!
        >
        > Tom Purl
      • Bram Moolenaar
        ... This should be solved by getting a more recent version of Aap. This problem was fixed in 1.076. Installing CVS also works, since the list won t be empty
        Message 3 of 3 , Jul 8, 2006
        • 0 Attachment
          Tom Purl wrote:

          > Hi, I'm trying to compile the latest and greatest version of Vim
          > using AAP (since that seems to be the preferred way of doing it), and
          > am getting an odd error. Here's the process that I'm following:
          >
          > 1. Create a `vim7` folder in my home dir.
          > * mkdir ~/vim7
          > * cd ~/vim7
          > 2. I then run the command that's on the AAP web site:
          > * aap -f http://www.a-a-p.org/vim/main.aap CVS=no
          >
          > When I do that, I get the following error:
          >
          > Aap: Attempting download of "http://www.a-a-p.org/vim/main.aap"
          > Aap: Downloaded "http://www.a-a-p.org/vim/main.aap" to "main.aap"
          > Aap: Created directory "patches"
          > Aap: Internal Error
          > Aap: Traceback (most recent call last):
          > File "/usr/lib/aap/Process.py", line 1163, in Process
          > exec script_string in recdict, recdict
          > File "<string>", line 6, in ?
          > File "/usr/lib/aap/Commands.py", line 3098, in aap_progsearch
          > if " " in prog:
          > TypeError: iterable argument required
          >
          > Aap: Aborted
          > Aap: More info in the logfile: /home/tom/vim7/AAPDIR/log

          This should be solved by getting a more recent version of Aap. This
          problem was fixed in 1.076. Installing CVS also works, since the list
          won't be empty then. But Aap should be able to handle an empty list.


          --
          If you had to identify, in one word, the reason why the
          human race has not achieved, and never will achieve, its
          full potential, that word would be "meetings."

          /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
          /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
          \\\ download, build and distribute -- http://www.A-A-P.org ///
          \\\ help me help AIDS victims -- http://ICCF-Holland.org ///
        Your message has been successfully submitted and would be delivered to recipients shortly.