Loading ...
Sorry, an error occurred while loading the content.

Re: Syntax Highlighting: Vim 7, Debian

Expand Messages
  • Chisum Lindauer
    ... Just letting everyone know that I got it working finally. I purged the apt-get vim packages, deleted my own .vimrc and .gvimrc files and installed from
    Message 1 of 7 , May 31 7:45 AM
    • 0 Attachment
      Gregory Margo wrote:

      >On Tue, May 30, 2006 at 02:44:17PM -0400, Chisum Lindauer wrote:
      >
      >
      >>Hello all I've just worked on trying to get this to work a few hours
      >>with no luck, so I thought I'd consult the community.
      >>
      >>In short, my syntax highlighting doesn't work. Not in vim or vim
      >>-g/gvim. I've tried the easy things like :snytax enable or :syntax on
      >>and manually loading a colorscheme but to no effect.
      >>I recently did an apt-get upgrade which broke my X install.
      >>Once I had fixed that and returned to the world of GUI's I found my
      >>syntax highlighting didn't work. The color test shows all the colors
      >>properly however. (Select it from the syntax menu in gvim).
      >>At first I thought it might be because of my terminal, but changing that
      >>using tset and/or setting my TERM environment variable to xterm-color
      >>helped not in the least. It's not just a color problem anyhow, as bold
      >>and italics don't work on syntax either. It's not a colorscheme bug
      >>either, as I've tried using several colorschemes and get the same
      >>results (though it will change the bgcolor an fgcolor in gvim).
      >>
      >>I tried removing and reinstalling gvim as well, but the problem
      >>persists. Needless to say, now that I'm used to syntax highlighting
      >>being without it feels like losing an arm.
      >>
      >>The only error message I've ever seen regarding the syntax is when I
      >>opened up gvim and select on/off for This file under the syntax menu, it
      >>tells me that my colorscheme can not be found when parsing
      >>syntax/synload.vim. This error doesn't happen except when I first load
      >>vim, and only if I don't change the colorscheme before hand. This might
      >>be a clue for someone, but probably not.
      >>
      >>Also if I log into our server ssh -X and use gvim over the network,
      >>syntax highlighting does work, of course, that doesn't say a damn thing
      >>either. It just makes me think that it's probably a configuration file
      >>of some sort...
      >>
      >>I hope someone has an idea, I sure as hell don't.
      >>Thanks,
      >>Chisum Lindauer
      >>
      >>
      >
      >If you have both vim-6 and vim-7 installed, there may be a conflict,
      >especially if you try to share a ~/.vim directory. I'm running under
      >Debian Stable, and have the default vim-6.3.82 installed, and have a
      >locally compiled vim-7.0.15 installed also (with binary name 'vim7').
      >Syntax highlighting works find under either. However,
      >I've kept them seperated with different .vimrc files, and different
      >'runtimepath' variables.
      >
      >Try this: in an xterm (version 4.3.0.dfsg.1-14sarge1) run
      >"/path/to/your/vim7 -u NONE".
      >
      >Now type ":help" - you should see black-n-white help text.
      >Now type ":syntax on" - you should see the help with syntax highlighting.
      >
      >If does not work, it could be the color settings of the xterm itself.
      >
      >Since you mentioned breaking your X setup, could it be that you're
      >running a bleeding edge Debian Unstable (etch) system?
      >
      >
      >
      Just letting everyone know that I got it working finally. I purged the
      apt-get vim packages, deleted my own .vimrc and .gvimrc files and
      installed from source (though it said I had no terminal library so I
      installed ncurses from source as well).

      I think it was a combination of issues, in part it was because I had
      messed with the config files before and I think something was wrong with
      my .vimrc and .gvimrc files, in addition I don't think it had the
      terminal support it needed (as even under different users with default
      .vimrc and .gvimrc files the problem persisted before). Thank you all
      for your help :) vim -u NONE is quite handy, and I learned more about
      vim and debian to boot.

      Thank You,
      Chisum Lindauer
    Your message has been successfully submitted and would be delivered to recipients shortly.