Loading ...
Sorry, an error occurred while loading the content.

Re: console vim on win - double CR's

Expand Messages
  • Yakov Lerner
    ... Can be caused by some options of telnet client, especially option crlf . Try to toggle the option to see it if makes difference: telnet HOST ^]
    Message 1 of 4 , May 3, 2006
    • 0 Attachment
      On 5/3/06, Hugo Ahlenius <fraxinus@...> wrote:
      > Hi,
      >
      > I have vim 6.4 (non cygwin) installed on a couple of Win2k3 servers, running
      > the built in MS telnet server.
      >
      > When I connect using the built-in WinXP/Win2k telnet client I am able to get
      > color in vim console sessions without any problems, and everything seems to
      > be working very well.
      >
      > Except for one (minor) annoyance -- every time I press enter in insert mode
      > I get two line-fees (as if it was pressed twice). This also happens when I
      > start up vim without my _vimrc customizations. It does not happen, though,
      > if I open a remote desktop console to the server and run vim in that
      > session.
      >
      > I'd love to compare and test if this appears in putty (to identy if it is
      > the telnet client that is the problem), but I can't get vim to run through a
      > putty session... :(
      >
      > Any tips?

      Can be caused by some options of telnet client, especially
      option 'crlf'. Try to toggle the option to see it if makes difference:

      telnet HOST
      ^] Press Ctrl-] to client command mode
      unset crlf
      <Enter> Press Enter

      More info at 'man telnet'

      Yakov
    Your message has been successfully submitted and would be delivered to recipients shortly.