Loading ...
Sorry, an error occurred while loading the content.

Re: Line wrapping problem

Expand Messages
  • Tim Chase
    ... Looks kosher...however the easiest way to figure out where it s getting set is to do ... to find out the last place was that this option was munged. It
    Message 1 of 4 , Mar 1 11:48 PM
    • 0 Attachment
      > For some strange reason, all file types are doing strange
      > line wrapping now... and I do not know what has changed
      > to cause this to happen. I have not changed any files in
      > the /vim/vimfiles/indent directory...

      Looks kosher...however the easiest way to figure out where
      it's getting set is to do

      :verbose set wrap

      to find out the last place was that this option was munged.
      It should point you right to your culprit.

      -tim
    • Jeff Lanzarotta
      Hello, For some strange reason, all file types are doing strange line wrapping now... and I do not know what has changed to cause this to happen. I have not
      Message 2 of 4 , Mar 2 5:35 AM
      • 0 Attachment
        Hello,

        For some strange reason, all file types are doing strange line wrapping
        now... and I do not know what has changed to cause this to happen. I
        have not changed any files in the /vim/vimfiles/indent directory...

        In my vimrc file, I have:

        --------8<--------

        " Don't wrap lines at the edge of the screen.
        set nowrap

        " When starting to edit a file:
        " For .txt and .doc files, do not expand tabs to spaces and set tabs
        " to 8.
        " For all other languages, expand tabs to spaces and set tabs to 2.
        " au BufNewFile,BufEnter * set expandtab ts=2 sw=2
        " au BufNewFile,BufEnter *.txt set expandtab ts=3 sw=3 tw=72 wrap wm=72
        " au BufNewFile,BufEnter *.doc set noexpandtab ts=3 sw=3 tw=72 wrap
        wm=72
        " au BufNewFile,BufEnter makefile set noexpandtab

        " Normally don't automatically format 'text' as it is typed, only do
        " this with comments, at 79 characters.
        au BufNewFile,BufEnter *.c,*.h,*.java,*.cpp set formatoptions-=t tw=79

        --------8<--------

        Any idea?

        Regards,

        -Jeff

        -Jeff
      • Jeff Lanzarotta
        Awesome, I will give that a try...
        Message 3 of 4 , Mar 2 5:50 AM
        • 0 Attachment
          Awesome, I will give that a try...

          --- Tim Chase <vim@...> wrote:

          > > For some strange reason, all file types are doing strange
          > > line wrapping now... and I do not know what has changed
          > > to cause this to happen. I have not changed any files in
          > > the /vim/vimfiles/indent directory...
          >
          > Looks kosher...however the easiest way to figure out where
          > it's getting set is to do
          >
          > :verbose set wrap
          >
          > to find out the last place was that this option was munged.
          > It should point you right to your culprit.
          >
          > -tim
          >
          >
          >
          >
        • Benji Fisher
          ... Better make that ... since wrap is a binary option. Otherwise it will have the same effect as ... which is very uninformative. HTH --Benji Fisher
          Message 4 of 4 , Mar 2 8:26 PM
          • 0 Attachment
            On Thu, Mar 02, 2006 at 01:48:34AM -0600, Tim Chase wrote:
            > >For some strange reason, all file types are doing strange
            > >line wrapping now... and I do not know what has changed
            > >to cause this to happen. I have not changed any files in
            > >the /vim/vimfiles/indent directory...
            >
            > Looks kosher...however the easiest way to figure out where
            > it's getting set is to do
            >
            > :verbose set wrap
            >
            > to find out the last place was that this option was munged.
            > It should point you right to your culprit.

            Better make that

            :verbose set wrap?

            since 'wrap' is a binary option. Otherwise it will have the same effect
            as

            :set wrap

            which is very uninformative.

            HTH --Benji Fisher
          Your message has been successfully submitted and would be delivered to recipients shortly.