Loading ...
Sorry, an error occurred while loading the content.

GVim 7.0aa Segfaulting in font dialog

Expand Messages
  • A. S. Budden
    Dear all, Just a bug report here (I assume I m not doing anything stupid, but I might well be...). If I run gvim (--version is included below) and go to the
    Message 1 of 9 , Feb 27, 2006
    • 0 Attachment
      Dear all,

      Just a bug report here (I assume I'm not doing anything stupid, but I
      might well be...). If I run gvim (--version is included below) and go
      to the select font dialog I can choose any font I like, except Lucida
      Console. If I choose Lucida Console, as soon as I click the name of
      the font, gvim crashes with:

      Vim: Caught deadly signal SEGV
      Vim: Finished.
      Segmentation fault

      I've tried this with "gvim -u NONE" as the command line, but it makes
      no difference at all.

      As for me, I'm going to stick with Bitstream Vera Sans Mono for now!

      Cheers,

      Al

      [koshka:1;~]$ vim --version
      VIM - Vi IMproved 7.0aa ALPHA (2006 Feb 23, compiled Feb 27 2006 12:36:14)
      Compiled by A. S. Budden <abudden@...>
      Normal version with GTK2 GUI. Features included (+) or not (-):
      -arabic +autocmd +balloon_eval +browse +builtin_terms +byte_offset +cindent
      +clientserver +clipboard +cmdline_compl +cmdline_hist +cmdline_info +comments
      +cryptv +cscope +cursorshape +dialog_con_gui +diff +digraphs +dnd -ebcdic
      -emacs_tags +eval +ex_extra +extra_search -farsi +file_in_path +find_in_path
      +folding -footer +fork() +gettext -hangul_input +iconv +insert_expand +jumplist
      -keymap -langmap +libcall +linebreak +lispindent +listcmds +localmap +menu
      +mksession +modify_fname +mouse +mouseshape -mouse_dec -mouse_gpm
      -mouse_jsbterm -mouse_netterm +mouse_xterm +multi_byte +multi_lang -mzscheme
      +netbeans_intg -osfiletype +path_extra +perl +postscript +printer -profile
      +python +quickfix -rightleft +ruby +scrollbind +signs +smartindent -sniff
      +statusline -sun_workshop +syntax +tag_binary +tag_old_static -tag_any_white
      -tcl +terminfo +termresponse +textobjects +title +toolbar +user_commands
      +vertsplit +virtualedit +visual +visualextra +viminfo +vreplace +wildignore
      +wildmenu +windows +writebackup +X11 -xfontset +xim +xsmp_interact
      +xterm_clipboard -xterm_save
      system vimrc file: "$VIM/vimrc"
      user vimrc file: "$HOME/.vimrc"
      user exrc file: "$HOME/.exrc"
      system gvimrc file: "$VIM/gvimrc"
      user gvimrc file: "$HOME/.gvimrc"
      system menu file: "$VIMRUNTIME/menu.vim"
      fall-back for $VIM: "/usr/share/vim"
      Compilation: gcc -c -I. -Iproto -DHAVE_CONFIG_H -DFEAT_GUI_GTK
      -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include
      -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0
      -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -march=i686
      -O2 -pipe -D_REENTRANT -D_GNU_SOURCE -DTHREADS_HAVE_PIDS -pipe
      -Wdeclaration-after-statement -I/usr/local/include -D_LARGEFILE_SOURCE
      -D_FILE_OFFSET_BITS=64
      -I/usr/lib/perl5/5.8.8/i686-linux-thread-multi/CORE
      -I/usr/include/python2.4 -pthread -I/usr/lib/ruby/1.8/i686-linux
      Linking: gcc -rdynamic -Wl,-export-dynamic -Wl,-E
      -L/usr/local/lib -o vim -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0
      -lgdk_pixbuf-2.0 -lpangocairo-1.0 -lpango-1.0 -lcairo -lgobject-2.0
      -lgmodule-2.0 -lglib-2.0 -lXt -lncurses -lacl -Wl,-E
      -L/usr/local/lib
      /usr/lib/perl5/5.8.8/i686-linux-thread-multi/auto/DynaLoader/DynaLoader.a
      -L/usr/lib/perl5/5.8.8/i686-linux-thread-multi/CORE -lperl -lutil -lc
      -L/usr/lib/python2.4/config -lpython2.4 -lutil -Xlinker
      -export-dynamic -Wl,-R -Wl,/usr/lib -L/usr/lib -L/usr/lib -lruby -lm
    • Bram Moolenaar
      ... I don t have this font. The other Lucida fonts I have work fine. Can you try compiling with -g instead of -O2 and use gdb to find out where the crash
      Message 2 of 9 , Feb 27, 2006
      • 0 Attachment
        Al Budden wrote:

        > Just a bug report here (I assume I'm not doing anything stupid, but I
        > might well be...). If I run gvim (--version is included below) and go
        > to the select font dialog I can choose any font I like, except Lucida
        > Console. If I choose Lucida Console, as soon as I click the name of
        > the font, gvim crashes with:
        >
        > Vim: Caught deadly signal SEGV
        > Vim: Finished.
        > Segmentation fault
        >
        > I've tried this with "gvim -u NONE" as the command line, but it makes
        > no difference at all.
        >
        > As for me, I'm going to stick with Bitstream Vera Sans Mono for now!

        I don't have this font. The other Lucida fonts I have work fine.

        Can you try compiling with "-g" instead of "-O2" and use gdb to find out
        where the crash occurs? If it still happens without optimizer...

        You may have to disable Perl and Python to get sensible debugging info,
        multi-threading makes this difficult.

        --
        Bad fashion can discourage normal people from interacting with the engineer
        and talking about the cute things their children do.
        (Scott Adams - The Dilbert principle)

        /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
        /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
        \\\ download, build and distribute -- http://www.A-A-P.org ///
        \\\ help me help AIDS victims -- http://www.ICCF.nl ///
      • A. S. Budden
        ... Does this help? Program received signal SIGSEGV, Segmentation fault. 0xb7751fd8 in pango_fc_font_create_metrics_for_context () from
        Message 3 of 9 , Feb 27, 2006
        • 0 Attachment
          On 27/02/06, Bram Moolenaar <Bram@...> wrote:
          >
          > Al Budden wrote:
          >
          > > Just a bug report here (I assume I'm not doing anything stupid, but I
          > > might well be...). If I run gvim (--version is included below) and go
          > > to the select font dialog I can choose any font I like, except Lucida
          > > Console. If I choose Lucida Console, as soon as I click the name of
          > > the font, gvim crashes with:
          > >
          > > Vim: Caught deadly signal SEGV
          > > Vim: Finished.
          > > Segmentation fault
          > >
          > > I've tried this with "gvim -u NONE" as the command line, but it makes
          > > no difference at all.
          > >
          > > As for me, I'm going to stick with Bitstream Vera Sans Mono for now!
          >
          > I don't have this font. The other Lucida fonts I have work fine.
          >
          > Can you try compiling with "-g" instead of "-O2" and use gdb to find out
          > where the crash occurs? If it still happens without optimizer...
          >
          > You may have to disable Perl and Python to get sensible debugging info,
          > multi-threading makes this difficult.

          Does this help?

          Program received signal SIGSEGV, Segmentation fault.
          0xb7751fd8 in pango_fc_font_create_metrics_for_context () from
          /usr/lib/libpangoft2-1.0.so.0

          [koshka:1;~]$ vim --version
          VIM - Vi IMproved 7.0aa ALPHA (2006 Feb 23, compiled Feb 27 2006 19:11:54)
          Compiled by al@koshka
          Normal version with GTK2 GUI. Features included (+) or not (-):
          -arabic +autocmd +balloon_eval +browse +builtin_terms +byte_offset +cindent
          +clientserver +clipboard +cmdline_compl +cmdline_hist +cmdline_info +comments
          +cryptv +cscope +cursorshape +dialog_con_gui +diff +digraphs +dnd -ebcdic
          -emacs_tags +eval +ex_extra +extra_search -farsi +file_in_path +find_in_path
          +folding -footer +fork() +gettext -hangul_input +iconv +insert_expand +jumplist
          -keymap -langmap +libcall +linebreak +lispindent +listcmds +localmap +menu
          +mksession +modify_fname +mouse +mouseshape -mouse_dec -mouse_gpm
          -mouse_jsbterm -mouse_netterm +mouse_xterm +multi_byte +multi_lang -mzscheme
          +netbeans_intg -osfiletype +path_extra -perl +postscript +printer -profile
          -python +quickfix -rightleft -ruby +scrollbind +signs +smartindent -sniff
          +statusline -sun_workshop +syntax +tag_binary +tag_old_static -tag_any_white
          -tcl +terminfo +termresponse +textobjects +title +toolbar +user_commands
          +vertsplit +virtualedit +visual +visualextra +viminfo +vreplace +wildignore
          +wildmenu +windows +writebackup +X11 -xfontset +xim +xsmp_interact
          +xterm_clipboard -xterm_save
          system vimrc file: "$VIM/vimrc"
          user vimrc file: "$HOME/.vimrc"
          user exrc file: "$HOME/.exrc"
          system gvimrc file: "$VIM/gvimrc"
          user gvimrc file: "$HOME/.gvimrc"
          system menu file: "$VIMRUNTIME/menu.vim"
          fall-back for $VIM: "/usr/share/vim"
          Compilation: gcc -c -I. -Iproto -DHAVE_CONFIG_H -DFEAT_GUI_GTK
          -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include
          -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0
          -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -g
          Linking: gcc -L/usr/local/lib -o vim -lgtk-x11-2.0 -lgdk-x11-2.0
          -latk-1.0 -lgdk_pixbuf-2.0 -lm -lpangocairo-1.0 -lpango-1.0 -lcairo
          -lgobject-2.0 -lgmodule-2.0 -lglib-2.0 -lXt -lncurses -lacl
        • Bram Moolenaar
          ... I m afraid not. Well, at least it shows that the optimizer was not the problem. It could be a problem in the pango library, the way Vim invokes pango, or
          Message 4 of 9 , Feb 27, 2006
          • 0 Attachment
            Al Budden wrote:

            > > > Just a bug report here (I assume I'm not doing anything stupid, but I
            > > > might well be...). If I run gvim (--version is included below) and go
            > > > to the select font dialog I can choose any font I like, except Lucida
            > > > Console. If I choose Lucida Console, as soon as I click the name of
            > > > the font, gvim crashes with:
            > > >
            > > > Vim: Caught deadly signal SEGV
            > > > Vim: Finished.
            > > > Segmentation fault
            > > >
            > > > I've tried this with "gvim -u NONE" as the command line, but it makes
            > > > no difference at all.
            > > >
            > > > As for me, I'm going to stick with Bitstream Vera Sans Mono for now!
            > >
            > > I don't have this font. The other Lucida fonts I have work fine.
            > >
            > > Can you try compiling with "-g" instead of "-O2" and use gdb to find out
            > > where the crash occurs? If it still happens without optimizer...
            > >
            > > You may have to disable Perl and Python to get sensible debugging info,
            > > multi-threading makes this difficult.
            >
            > Does this help?
            >
            > Program received signal SIGSEGV, Segmentation fault.
            > 0xb7751fd8 in pango_fc_font_create_metrics_for_context () from
            > /usr/lib/libpangoft2-1.0.so.0

            I'm afraid not. Well, at least it shows that the optimizer was not the
            problem.

            It could be a problem in the pango library, the way Vim invokes pango,
            or in the font data (although pango should be able to handle that
            gracefully).

            --
            I learned the customs and mannerisms of engineers by observing them, much the
            way Jane Goodall learned about the great apes, but without the hassle of
            grooming.
            (Scott Adams - The Dilbert principle)

            /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
            /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
            \\\ download, build and distribute -- http://www.A-A-P.org ///
            \\\ help me help AIDS victims -- http://www.ICCF.nl ///
          • panshizhu@routon.com
            ... Lucida Console is provided with all Windows distributions, If he mentioned the font Lucida Console , I think he is running Windows, so, gdb may not be
            Message 5 of 9 , Feb 28, 2006
            • 0 Attachment
              Bram@... wrote on 2006.02.28 00:30:04:
              > > Console. If I choose Lucida Console, as soon as I click the name of
              > > the font, gvim crashes with:
              > >
              > > Vim: Caught deadly signal SEGV
              > > Vim: Finished.
              > > Segmentation fault
              > >
              > > I've tried this with "gvim -u NONE" as the command line, but it makes
              > > no difference at all.
              > >
              > > As for me, I'm going to stick with Bitstream Vera Sans Mono for now!
              >
              > I don't have this font. The other Lucida fonts I have work fine.
              >
              > Can you try compiling with "-g" instead of "-O2" and use gdb to find out
              > where the crash occurs? If it still happens without optimizer...
              >
              > You may have to disable Perl and Python to get sensible debugging info,
              > multi-threading makes this difficult.


              "Lucida Console" is provided with all Windows distributions, If he
              mentioned the font "Lucida Console", I think he is running Windows, so, gdb
              may not be available.
            • A. J. Mechelynck
              ... A similar-looking font is called lucidatypewriter on Linux; but the actual binary font file might be different. OTOH I don t see Bitstream Vera Sans Mono
              Message 6 of 9 , Feb 28, 2006
              • 0 Attachment
                panshizhu@... wrote:
                > Bram@... wrote on 2006.02.28 00:30:04:
                >>> Console. If I choose Lucida Console, as soon as I click the name of
                >>> the font, gvim crashes with:
                >>>
                >>> Vim: Caught deadly signal SEGV
                >>> Vim: Finished.
                >>> Segmentation fault
                >>>
                >>> I've tried this with "gvim -u NONE" as the command line, but it makes
                >>> no difference at all.
                >>>
                >>> As for me, I'm going to stick with Bitstream Vera Sans Mono for now!
                >> I don't have this font. The other Lucida fonts I have work fine.
                >>
                >> Can you try compiling with "-g" instead of "-O2" and use gdb to find out
                >> where the crash occurs? If it still happens without optimizer...
                >>
                >> You may have to disable Perl and Python to get sensible debugging info,
                >> multi-threading makes this difficult.
                >
                >
                > "Lucida Console" is provided with all Windows distributions, If he
                > mentioned the font "Lucida Console", I think he is running Windows, so, gdb
                > may not be available.
                >
                >
                >
                >
                >

                A similar-looking font is called lucidatypewriter on Linux; but the
                actual binary font file might be different. OTOH I don't see "Bitstream
                Vera Sans Mono" on my XP distribution so I thought the OP was on Unix
                and had maybe downloaded a "Lucida Console" font from third-party
                source. Actually I don't know.

                There is a native-W32 gdb for MinGW and also a gdb for Cygwin using the
                cygwin1.dll. It is often better to debug with the debugger that came
                with whatever compiler was used (gdb with gcc, Turbo Debug with the
                Borland compiler, etc.). Since Cygwin gcc for native-Windows can be
                regarded as a cross-compiler, it might be an exception.


                Best regards,
                Tony.
              • A. S. Budden
                ... Sorry for the confusion everyone: I use Arch Linux, but have a dual boot to Windows and always kinda liked the Lucida Console font, so I copied it across
                Message 7 of 9 , Mar 1, 2006
                • 0 Attachment
                  On 01/03/06, A. J. Mechelynck <antoine.mechelynck@...> wrote:
                  > panshizhu@... wrote:
                  > > Bram@... wrote on 2006.02.28 00:30:04:
                  > >>> Console. If I choose Lucida Console, as soon as I click the name of
                  > >>> the font, gvim crashes with:
                  > >>>
                  > >>> Vim: Caught deadly signal SEGV
                  > >>> Vim: Finished.
                  > >>> Segmentation fault
                  > >>>
                  > >>> I've tried this with "gvim -u NONE" as the command line, but it makes
                  > >>> no difference at all.
                  > >>>
                  > >>> As for me, I'm going to stick with Bitstream Vera Sans Mono for now!
                  > >> I don't have this font. The other Lucida fonts I have work fine.
                  > >>
                  > >> Can you try compiling with "-g" instead of "-O2" and use gdb to find out
                  > >> where the crash occurs? If it still happens without optimizer...
                  > >>
                  > >> You may have to disable Perl and Python to get sensible debugging info,
                  > >> multi-threading makes this difficult.
                  > >
                  > >
                  > > "Lucida Console" is provided with all Windows distributions, If he
                  > > mentioned the font "Lucida Console", I think he is running Windows, so, gdb
                  > > may not be available.
                  > >
                  > >
                  > >
                  > >
                  > >
                  >
                  > A similar-looking font is called lucidatypewriter on Linux; but the
                  > actual binary font file might be different. OTOH I don't see "Bitstream
                  > Vera Sans Mono" on my XP distribution so I thought the OP was on Unix
                  > and had maybe downloaded a "Lucida Console" font from third-party
                  > source. Actually I don't know.
                  >
                  > There is a native-W32 gdb for MinGW and also a gdb for Cygwin using the
                  > cygwin1.dll. It is often better to debug with the debugger that came
                  > with whatever compiler was used (gdb with gcc, Turbo Debug with the
                  > Borland compiler, etc.). Since Cygwin gcc for native-Windows can be
                  > regarded as a cross-compiler, it might be an exception.

                  Sorry for the confusion everyone: I use Arch Linux, but have a dual
                  boot to Windows and always kinda liked the Lucida Console font, so I
                  copied it across to the other partition.

                  Al
                • A. J. Mechelynck
                  A. S. Budden wrote: [...] ... So it s a Windows font on a Linux system. Maybe that s the problem. Try using the lucidatypewriter (or maybe Lucida Typewriter)
                  Message 8 of 9 , Mar 1, 2006
                  • 0 Attachment
                    A. S. Budden wrote:
                    [...]
                    > Sorry for the confusion everyone: I use Arch Linux, but have a dual
                    > boot to Windows and always kinda liked the Lucida Console font, so I
                    > copied it across to the other partition.
                    >
                    > Al
                    >
                    >
                    >

                    So it's a Windows font on a Linux system. Maybe that's the problem. Try
                    using the "lucidatypewriter" (or maybe Lucida Typewriter) font instead,
                    it's often available out-of-the-box on Linux, and it is almost identical
                    to what Windows calls Lucida Console. If you don't already have it
                    installed, try to find it on your Linux install disks (or whatever your
                    Linux distro came on).


                    Best regards,
                    Tony.
                  • Frank Marx
                    ... Hi: I use `Lucida Console # *from my win32 partition* without any problems. I.e., I don t even copy it, i just add a symlink to `/c/fonts to
                    Message 9 of 9 , Mar 2, 2006
                    • 0 Attachment
                      On Wed, 01 Mar 2006 11:05:36 +0100, "A. J. Mechelynck" <antoine.mechelynck@...> wrote:
                      >
                      >
                      >A. S. Budden wrote:
                      >[...]
                      >> Sorry for the confusion everyone: I use Arch Linux, but have a dual
                      >> boot to Windows and always kinda liked the Lucida Console font, so I
                      >> copied it across to the other partition.
                      >>
                      >> Al
                      >>
                      >>
                      >>
                      >
                      >So it's a Windows font on a Linux system. Maybe that's the problem. Try
                      >using the "lucidatypewriter" (or maybe Lucida Typewriter) font instead,
                      >it's often available out-of-the-box on Linux, and it is almost identical
                      >to what Windows calls Lucida Console. If you don't already have it
                      >installed, try to find it on your Linux install disks (or whatever your
                      >Linux distro came on).
                      >
                      >
                      >Best regards,
                      >Tony.
                      >
                      >
                      Hi:

                      I use `Lucida\ Console\ #' *from my win32 partition* without any problems.
                      I.e., I don't even copy it, i just add a symlink to `/c/fonts' to
                      `/usr/share/fonts', and add that (symlinked) directory to 'xorg.conf':

                      Section "Files"
                      FontPath "/usr/share/fonts/truetype"
                      .
                      .
                      .
                      EndSection

                      In both gui-vim, and in both rxvt and xterm.

                      Is your local copy possible corrupt?

                      /frank
                      ------------------------------------------------------------------------
                      f.g.marx <fmarx@...>
                    Your message has been successfully submitted and would be delivered to recipients shortly.