Loading ...
Sorry, an error occurred while loading the content.

Read-only Options?

Expand Messages
  • Vigil
    How can I disable all scripts, such as those in /usr/share/vim/vim63/indent/, /syntax/, etc, so that only commands in my ~/.vimrc are used? Assume I don t have
    Message 1 of 4 , Nov 1, 2005
    • 0 Attachment
      How can I disable all scripts, such as those in /usr/share/vim/vim63/indent/,
      /syntax/, etc, so that only commands in my ~/.vimrc are used? Assume I don't
      have root so I can't remove or chmod system-wide files.

      Alternatively, how can I make options in my ~/.vimrc read-only, so that nothing
      in the above scripts can later override them? e.g. vim's perl.vim overrides
      my formatoptions unless I create a ~/.vim/after/ftplugin/perl.vim.

      --

      .
    • Anders Th√łgersen
      ... A start for this is using set noloadplugins Then only pugins you specifically want loaded are loaded. /Anders
      Message 2 of 4 , Nov 1, 2005
      • 0 Attachment
        On 11:00 Tue 01 Nov , Vigil wrote:
        > How can I disable all scripts, such as those in
        > /usr/share/vim/vim63/indent/, /syntax/, etc, so that only commands in my
        > ~/.vimrc are used? Assume I don't have root so I can't remove or chmod
        > system-wide files.


        A start for this is using

        set noloadplugins

        Then only pugins you specifically want loaded are loaded.

        /Anders
      • A. J. Mechelynck
        ... also - :filetype off which will suppress filetype detection, thus you won t have syntax-related highlighting, filetype-dependent indenting, and
        Message 3 of 4 , Nov 1, 2005
        • 0 Attachment
          Anders Th√łgersen wrote:
          > On 11:00 Tue 01 Nov , Vigil wrote:
          >> How can I disable all scripts, such as those in
          >> /usr/share/vim/vim63/indent/, /syntax/, etc, so that only commands in my
          >> ~/.vimrc are used? Assume I don't have root so I can't remove or chmod
          >> system-wide files.
          >
          >
          > A start for this is using
          >
          > set noloadplugins
          >
          > Then only pugins you specifically want loaded are loaded.
          >
          > /Anders
          >
          >
          >
          >

          also
          - ":filetype off" which will suppress filetype detection, thus you won't
          have syntax-related highlighting, filetype-dependent indenting, and
          filetype-plugins
          - ":aunmenu *" to remove all menus from gvim

          Best regards,
          Tony.
        • Vigil
          Thanks, both. -- .
          Message 4 of 4 , Nov 1, 2005
          • 0 Attachment
            Thanks, both.

            --

            .
          Your message has been successfully submitted and would be delivered to recipients shortly.