Loading ...
Sorry, an error occurred while loading the content.
 

Re: file permissions with cygwin and gvim.bat

Expand Messages
  • adah@netstd.com
    ... No way to change it unless you build gvim by yourself, as Tony says. NTFS does have fine-grained control on file permissions, but certainly a non-Cygwin
    Message 1 of 3 , Sep 29, 2005
      > Hi,
      >
      > I've installed Vim 6.3 on Windows XP. I often run gvim.bat (located
      > in C:\WINDOWS) to get the graphical version of Vim. However when I do
      > this, the file it creates has the permissions 770. I would prefer
      > that it use my umask or just not be executable.
      >
      > Does anyone know how to change this behavior?

      No way to change it unless you build gvim by yourself, as Tony says.
      NTFS does have fine-grained control on file permissions, but certainly a
      non-Cygwin build of gvim knows nothing of the Cygwin umask, which is
      really a Unixy hack on the Windows ACL. I believe the files created by
      gvim just inherits the privileges of the directory, unless you change it
      (in Windows Explorer, for example) manually.

      I personally use `set CYGWIN=nontsec', and do not use the UNIX chmod at
      all. If you use the default setting of Cygwin (ntsec), and create a
      `normal' text file that has not `execution bit' set, this file cannot be
      opened in Windows with `start'. I am more at ease to let Cygwin let
      loose of the Windows privileges and determine a file's execution status
      `smartly', though it is slower.

      Best regards,

      Yongwei
    Your message has been successfully submitted and would be delivered to recipients shortly.