Loading ...
Sorry, an error occurred while loading the content.

Re: Japanese text in vim?

Expand Messages
  • adah@netstd.com
    ... Others have answered the more on-topic part of your message, and I am trying to answer the remaining part. Mostly likely your mail message encoding was
    Message 1 of 5 , Aug 28, 2005
    • 0 Attachment
      c.lina@... wrote:
      > Another related, but even more off-topic: I am using
      > sylpheed with vim as external editor to write emails. When
      > copy-pasting text into and email edited with vim and then
      > saving, I can see the japanese fonts in sylpheeds's
      > mail-window. After I sent the email to myself and opened it,
      > the kanjis were gone, and only ______ is left where the
      > Japanese text should be.

      Others have answered the more on-topic part of your message, and I am
      trying to answer the remaining part. Mostly likely your mail message
      encoding was still set to something like ISO-8859-1, and to send
      Japanese correctly, you need to find some option to set it to UTF-8 or
      SJIS, which contains code points to encode Japanese characters.

      If you cannot find the option to set the message encoding, the mailer
      possibly is not ready for international use. If you set the encoding
      correctly and still you cannot read it, it is possibly a font problem.

      Best regards,

      Yongwei
    Your message has been successfully submitted and would be delivered to recipients shortly.