Loading ...
Sorry, an error occurred while loading the content.

Re: vim syntax highlighting

Expand Messages
  • A. J. Mechelynck
    ... The official way to do it would be to define a colorscheme, changing the :highlight commands for all the groups which are now underlined in order to
    Message 1 of 4 , May 2, 2005
    • 0 Attachment
      S M.C Butler wrote:
      > Hi, can someone tell me how to change my vim syntx highlighting to make
      > strings displayed in an italic font rather than being underlined… all those
      > underlines are sending me cross-eyed, too busy!!
      >
      >
      > Rgds,
      >
      >
      >
      >
      >
      The "official" way to do it would be to define a colorscheme, changing
      the ":highlight" commands for all the groups which are now underlined in
      order to make them italic (or something; maybe you would still want to
      distinguish HtmlItalic, HtmlUnderline, and HtmlItalicUnderline from each
      other?).

      There might also be a "hack" in non-GUI VIM, changing the termcap
      settings so that when Vim thinks it is setting underlines, it actually
      sets italics on the terminal. (see ":help :set-termcap")


      Best regards,
      Tony.
    • Eric Arnold
      I ve changed the highlighting bits that I didn t like by sticking these changes at the end of my .gvimrc. Changing the nasty dim blue highlighting:
      Message 2 of 4 , May 2, 2005
      • 0 Attachment
        I've changed the highlighting bits that I didn't like by sticking these
        changes at the end of my .gvimrc.


        " Changing the nasty dim blue highlighting:
        " Default:
        " Special xxx term=bold ctermfg=12 guifg=#0000ff
        " NonText xxx term=bold ctermfg=9 gui=bold guifg=Blue
        autocmd GUIEnter * hi nontext guifg=magenta
        autocmd GUIEnter * hi special guifg=magenta
        " Other existing magenta entries:
        " Title xxx term=bold ctermfg=13 gui=bold guifg=Magenta
        " DiffChange xxx term=bold ctermbg=5 guibg=DarkMagenta
        "
        " hightlight group user1 is for statusline hightlighting
        autocmd GUIEnter * hi user1 gui=reverse guifg=magenta guibg=fg
        "
        " For re-executing:
        " hi nontext guifg=magenta
        " hi special guifg=magenta
        " hi user1 gui=reverse guifg=magenta guibg=fg



        " old:
        " highlight Folded guibg=grey guifg=blue
        " highlight FoldColumn guibg=darkgrey guifg=white
        autocmd GUIEnter * highlight Folded term=standout ctermfg=11 ctermbg=8
        guifg=white guibg=darkgreen
        autocmd GUIEnter * highlight FoldColumn term=standout ctermfg=11 ctermbg=8
        guifg=white guibg=darkgreen


        --- "A. J. Mechelynck" <antoine.mechelynck@...> wrote:
        > S M.C Butler wrote:
        > > Hi, can someone tell me how to change my vim syntx highlighting to make
        > > strings displayed in an italic font rather than being underlined� all those
        > > underlines are sending me cross-eyed, too busy!!
        > >
        > >
        > > Rgds,
        > >
        > >
        > >
        > >
        > >
        > The "official" way to do it would be to define a colorscheme, changing
        > the ":highlight" commands for all the groups which are now underlined in
        > order to make them italic (or something; maybe you would still want to
        > distinguish HtmlItalic, HtmlUnderline, and HtmlItalicUnderline from each
        > other?).
        >
        > There might also be a "hack" in non-GUI VIM, changing the termcap
        > settings so that when Vim thinks it is setting underlines, it actually
        > sets italics on the terminal. (see ":help :set-termcap")
        >
        >
        > Best regards,
        > Tony.
        >
        >
      Your message has been successfully submitted and would be delivered to recipients shortly.