Loading ...
Sorry, an error occurred while loading the content.

Problem trying to type a #

Expand Messages
  • Sean C. Hubbell
    Hello, I was wondering if I could get some advice, I cannot type in a # while connecting to a sun machine from Exceed. Has anyone else had this problem? I
    Message 1 of 8 , Feb 9, 2005
    • 0 Attachment
      Hello,

      I was wondering if I could get some advice, I cannot type in a # while
      connecting to a sun machine from Exceed. Has anyone else had this problem? I
      checked my mappings and did not see anything ...

      Thanks in advance,

      Sean

      Sean C. Hubbell
      (256) 881-9933 Ext. 316
      (256) 426-8957 (Cell)
      Ternion Corporation
      3325 Triana Boulevard
      Huntsville, Alabama 35805
    • Antoine J. Mechelynck
      ... Not every (national) keyboard has that character, and some have it on unusual keys. Other key combinations which produce the same effect in Insert mode
      Message 2 of 8 , Feb 9, 2005
      • 0 Attachment
        Sean C. Hubbell wrote:
        > Hello,
        >
        > I was wondering if I could get some advice, I cannot type in a # while
        > connecting to a sun machine from Exceed. Has anyone else had this problem? I
        > checked my mappings and did not see anything ...
        >
        > Thanks in advance,
        >
        > Sean
        >
        > Sean C. Hubbell
        > (256) 881-9933 Ext. 316
        > (256) 426-8957 (Cell)
        > Ternion Corporation
        > 3325 Triana Boulevard
        > Huntsville, Alabama 35805

        Not every (national) keyboard has that character, and some have it on
        "unusual" keys. Other key combinations which produce the same effect in
        Insert mode are:

        ^V035
        ^KNb

        where ^V is Ctrl-V (or Ctrl-Q if your Ctrl-V pastes), and ^K is Ctrl-K

        see
        :help i_CTRL-V_digit
        :help digraphs-use
        :help digraph-table

        If you have a key labeled # on your keyboard, but Vim sees it as
        something else, a way to determine what Vim sees is to press Ctrl-V (or
        Ctrl-Q) in Insert mode, followed by the key in question.

        see
        :help i_CTRL-V

        HTH,
        Tony.
      • Sean C. Hubbell
        Thanks, I will give this a try. Sean
        Message 3 of 8 , Feb 9, 2005
        • 0 Attachment
          Thanks, I will give this a try.

          Sean

          > -----Original Message-----
          > From: Antoine J. Mechelynck [mailto:antoine.mechelynck@...]
          > Sent: Wednesday, February 09, 2005 2:37 PM
          > To: Sean C. Hubbell
          > Cc: Vim
          > Subject: Re: Problem trying to type a #
          >
          >
          > Sean C. Hubbell wrote:
          > > Hello,
          > >
          > > I was wondering if I could get some advice, I cannot type in a # while
          > > connecting to a sun machine from Exceed. Has anyone else had
          > this problem? I
          > > checked my mappings and did not see anything ...
          > >
          > > Thanks in advance,
          > >
          > > Sean
          > >
          > > Sean C. Hubbell
          > > (256) 881-9933 Ext. 316
          > > (256) 426-8957 (Cell)
          > > Ternion Corporation
          > > 3325 Triana Boulevard
          > > Huntsville, Alabama 35805
          >
          > Not every (national) keyboard has that character, and some have it on
          > "unusual" keys. Other key combinations which produce the same effect in
          > Insert mode are:
          >
          > ^V035
          > ^KNb
          >
          > where ^V is Ctrl-V (or Ctrl-Q if your Ctrl-V pastes), and ^K is Ctrl-K
          >
          > see
          > :help i_CTRL-V_digit
          > :help digraphs-use
          > :help digraph-table
          >
          > If you have a key labeled # on your keyboard, but Vim sees it as
          > something else, a way to determine what Vim sees is to press Ctrl-V (or
          > Ctrl-Q) in Insert mode, followed by the key in question.
          >
          > see
          > :help i_CTRL-V
          >
          > HTH,
          > Tony.
          >
          >
        • Tim Chase
          I also seem to remember reading somewhere that in some terminal settings, the # is used as either a backspace or a delete (sorry my memory is a bit fuzzy on
          Message 4 of 8 , Feb 9, 2005
          • 0 Attachment
            I also seem to remember reading somewhere that in some terminal
            settings, the "#" is used as either a backspace or a delete
            (sorry my memory is a bit fuzzy on this, and it's not the sorta
            thing one can easily goggle to confirm). You don't mention
            whether it's just in vim that you experience this, or if it
            applies in other places...at the command line, in other apps, etc.

            Either way, you might also investigate your term settings, both
            in Vim, and at the prompt.

            I wish I could provide further details, but this might trigger
            somebody else's synapses leading to a more concrete answer.

            -tim
          • Antoine J. Mechelynck
            ... I forgot to say that after entering whatever the key labeled # (if any) produces in Vim, you can examine what you got by placing the cursor on it in Normal
            Message 5 of 8 , Feb 9, 2005
            • 0 Attachment
              Sean C. Hubbell wrote:
              > Thanks, I will give this a try.
              >
              > Sean

              I forgot to say that after entering whatever the key labeled # (if any)
              produces in Vim, you can examine what you got by placing the cursor on
              it in Normal mode and entering ga

              This is useful for "strange" characters or characters not in your font
              (which it would show as ? or as a hollow box).

              Best regards,
              Tony.
              >
              >
              >>-----Original Message-----
              >>From: Antoine J. Mechelynck [mailto:antoine.mechelynck@...]
              >>Sent: Wednesday, February 09, 2005 2:37 PM
              >>To: Sean C. Hubbell
              >>Cc: Vim
              >>Subject: Re: Problem trying to type a #
              >>
              >>
              >>Sean C. Hubbell wrote:
              >>
              >>>Hello,
              >>>
              >>> I was wondering if I could get some advice, I cannot type in a # while
              >>>connecting to a sun machine from Exceed. Has anyone else had
              >>
              >>this problem? I
              >>
              >>>checked my mappings and did not see anything ...
              >>>
              >>>Thanks in advance,
              >>>
              >>>Sean
              >>>
              >>>Sean C. Hubbell
              >>>(256) 881-9933 Ext. 316
              >>>(256) 426-8957 (Cell)
              >>>Ternion Corporation
              >>>3325 Triana Boulevard
              >>>Huntsville, Alabama 35805
              >>
              >>Not every (national) keyboard has that character, and some have it on
              >>"unusual" keys. Other key combinations which produce the same effect in
              >>Insert mode are:
              >>
              >>^V035
              >>^KNb
              >>
              >>where ^V is Ctrl-V (or Ctrl-Q if your Ctrl-V pastes), and ^K is Ctrl-K
              >>
              >>see
              >> :help i_CTRL-V_digit
              >> :help digraphs-use
              >> :help digraph-table
              >>
              >>If you have a key labeled # on your keyboard, but Vim sees it as
              >>something else, a way to determine what Vim sees is to press Ctrl-V (or
              >>Ctrl-Q) in Insert mode, followed by the key in question.
              >>
              >>see
              >> :help i_CTRL-V
              >>
              >>HTH,
              >>Tony.
              >>
              >>
              >
              >
              >
              >
              >
              >
            • Sean C. Hubbell
              Yes, the # is acting as a backspace as well. Sean
              Message 6 of 8 , Feb 9, 2005
              • 0 Attachment
                Yes, the # is acting as a backspace as well.

                Sean

                > -----Original Message-----
                > From: Tim Chase [mailto:vim@...]
                > Sent: Wednesday, February 09, 2005 2:55 PM
                > To: Sean C. Hubbell
                > Cc: Vim
                > Subject: Re: Problem trying to type a #
                >
                >
                > I also seem to remember reading somewhere that in some terminal
                > settings, the "#" is used as either a backspace or a delete
                > (sorry my memory is a bit fuzzy on this, and it's not the sorta
                > thing one can easily goggle to confirm). You don't mention
                > whether it's just in vim that you experience this, or if it
                > applies in other places...at the command line, in other apps, etc.
                >
                > Either way, you might also investigate your term settings, both
                > in Vim, and at the prompt.
                >
                > I wish I could provide further details, but this might trigger
                > somebody else's synapses leading to a more concrete answer.
                >
                > -tim
                >
                >
                >
                >
                >
                >
              • Matthew Winn
                ... On early versions of Unix -- the ones intended for use with hardcopy terminals -- the erase key was set to # by default. This can be checked with stty
                Message 7 of 8 , Feb 10, 2005
                • 0 Attachment
                  On Wed, Feb 09, 2005 at 02:54:32PM -0600, Tim Chase wrote:
                  > I also seem to remember reading somewhere that in some terminal
                  > settings, the "#" is used as either a backspace or a delete
                  > (sorry my memory is a bit fuzzy on this, and it's not the sorta
                  > thing one can easily goggle to confirm). You don't mention
                  > whether it's just in vim that you experience this, or if it
                  > applies in other places...at the command line, in other apps, etc.

                  On early versions of Unix -- the ones intended for use with hardcopy
                  terminals -- the erase key was set to "#" by default. This can be
                  checked with "stty -a". If it is set to "#" it can be changed to
                  backspace with "stty erase \^H".
                • Antony Scriven
                  ... And, if that is the case, @ may well be set to act as the kill character; you may want to change that to ^U while you re at it (although ISTR that vim will
                  Message 8 of 8 , Feb 10, 2005
                  • 0 Attachment
                    Matthew Winn wrote:

                    > On Wed, Feb 09, 2005 at 02:54:32PM -0600, Tim Chase wrote:
                    > > I also seem to remember reading somewhere that in some
                    > > terminal settings, the "#" is used as either a
                    > > backspace or a delete (sorry my memory is a bit fuzzy
                    > > on this, and it's not the sorta thing one can easily
                    > > goggle to confirm). You don't mention whether it's
                    > > just in vim that you experience this, or if it applies
                    > > in other places...at the command line, in other apps,
                    > > etc.
                    >
                    > On early versions of Unix -- the ones intended for use
                    > with hardcopy terminals -- the erase key was set to "#"
                    > by default. This can be checked with "stty -a". If it
                    > is set to "#" it can be changed to backspace with "stty
                    > erase \^H".

                    And, if that is the case, @ may well be set to act as the
                    kill character; you may want to change that to ^U while
                    you're at it (although ISTR that vim will ignore the shell
                    for that one).

                    Antony
                  Your message has been successfully submitted and would be delivered to recipients shortly.