Loading ...
Sorry, an error occurred while loading the content.

getting the [unix] selection into clipboard

Expand Messages
  • Scott C
    vimmers-- i have two ways i usually telnet to our unix and linux boxes at work: using putty and x-windows for both these methods, getting the selection into
    Message 1 of 5 , Jan 3, 2005
    • 0 Attachment
      vimmers--

      i have two ways i usually telnet to our unix and linux
      boxes at work: using putty and x-windows

      for both these methods, getting the selection into
      clipboard from 'vi' is as easy as creating a selection
      with the mouse (assuming unix only -- in linuxland
      there is no vi -- it's vim, and creates the problem
      there too) -- stuff is automatically put into
      clipboard, it's the unix way

      but if i use vim, *nothing* i have tried puts it in
      clipboard, and i've even tried things like "*27yy

      any help will be appreciated

      scott




      __________________________________
      Do you Yahoo!?
      Yahoo! Mail - You care about security. So do we.
      http://promotions.yahoo.com/new_mail
    • Keith Roberts
      ... Under X11, + may be what you want. -Keith
      Message 2 of 5 , Jan 4, 2005
      • 0 Attachment
        >-----Original Message-----
        >From: Scott C [mailto:scott2237@...]
        >Sent: Monday, January 03, 2005 11:39 AM
        >To: vim@...
        >Subject: getting the [unix] selection into clipboard
        >
        >vimmers--
        >
        >i have two ways i usually telnet to our unix and linux boxes
        >at work: using putty and x-windows
        >
        >for both these methods, getting the selection into clipboard
        >from 'vi' is as easy as creating a selection with the mouse
        >(assuming unix only -- in linuxland there is no vi -- it's
        >vim, and creates the problem there too) -- stuff is
        >automatically put into clipboard, it's the unix way
        >
        >but if i use vim, *nothing* i have tried puts it in clipboard,
        >and i've even tried things like "*27yy
        >
        >any help will be appreciated
        >
        >scott

        :h clipboard
        :h 'clipboard'

        Under X11, "+ may be what you want.

        -Keith
      • David Rock
        ... I have found similar issues with nested connections (ssh to something to something else, blah, blah ...) and what seems to work for me is to use the shift
        Message 3 of 5 , Jan 4, 2005
        • 0 Attachment
          * Keith Roberts <kroberts@...> [2005-01-04 09:04]:
          > >-----Original Message-----
          > >From: Scott C [mailto:scott2237@...]
          > >Sent: Monday, January 03, 2005 11:39 AM
          > >To: vim@...
          > >Subject: getting the [unix] selection into clipboard
          > >
          > >vimmers--
          > >
          > >i have two ways i usually telnet to our unix and linux boxes
          > >at work: using putty and x-windows
          > >
          > >for both these methods, getting the selection into clipboard
          > >from 'vi' is as easy as creating a selection with the mouse
          > >(assuming unix only -- in linuxland there is no vi -- it's
          > >vim, and creates the problem there too) -- stuff is
          > >automatically put into clipboard, it's the unix way
          > >
          > >but if i use vim, *nothing* i have tried puts it in clipboard,
          > >and i've even tried things like "*27yy
          > >
          > >any help will be appreciated
          > >
          > >scott
          >
          > :h clipboard
          > :h 'clipboard'
          >
          > Under X11, "+ may be what you want.

          I have found similar issues with nested connections (ssh to something to
          something else, blah, blah ...) and what seems to work for me is to use
          the shift key when pressing the paste button on the mouse. The button
          varies from system to system (right mouse on putty/WinXP, middle mouse
          on xterm/linux) but using the shift key seems to work in most cases. I
          don't know why, I'm not even sure how I found it in the first place.

          --
          David Rock
          david@...
        • Antoine J. Mechelynck
          ... Just in case this hasn t been said yet: under X11 there are two slightly different clipboard registers : * and + (in the Windows GUI they are
          Message 4 of 5 , Jan 7, 2005
          • 0 Attachment
            Scott C wrote:
            > vimmers--
            >
            > i have two ways i usually telnet to our unix and linux
            > boxes at work: using putty and x-windows
            >
            > for both these methods, getting the selection into
            > clipboard from 'vi' is as easy as creating a selection
            > with the mouse (assuming unix only -- in linuxland
            > there is no vi -- it's vim, and creates the problem
            > there too) -- stuff is automatically put into
            > clipboard, it's the unix way
            >
            > but if i use vim, *nothing* i have tried puts it in
            > clipboard, and i've even tried things like "*27yy
            >
            > any help will be appreciated
            >
            > scott

            Just in case this hasn't been said yet: under X11 there are two slightly
            different clipboard "registers": "* and "+ (in the Windows GUI they are
            equivalent). If it doesn't work with the one, try the other, for
            instance "+y in Visual mode.

            The behaviour you mention under "it's the unix way" actually depends on
            a user-settable Vim option.

            But in all cases you need a clipboard-aware Vim to be able to use the
            clipboard (the answer to :echo has("clipboard") will tell you: a zero
            value means the feature isn't compiled-in).

            See
            :help x11-selection
            :help 'clipboard'
            :help +clipboard

            HTH,
            Tony.
          • Kamaraju Kusumanchi
            ... Hi David, the shift key solution you suggested really rocks. That is a cool trick. Thanks for sharing it with us. -- Kamaraju S Kusumanchi Cornell
            Message 5 of 5 , Feb 27, 2005
            • 0 Attachment
              On Tue, 4 Jan 2005 11:23:14 -0600, David Rock <david@...> wrote:
              > I have found similar issues with nested connections (ssh to something to
              > something else, blah, blah ...) and what seems to work for me is to use
              > the shift key when pressing the paste button on the mouse. The button
              > varies from system to system (right mouse on putty/WinXP, middle mouse
              > on xterm/linux) but using the shift key seems to work in most cases. I
              > don't know why, I'm not even sure how I found it in the first place.
              >

              Hi David,
              the shift key solution you suggested really rocks. That is a cool
              trick. Thanks for sharing it with us.

              --
              Kamaraju S Kusumanchi
              Cornell University
              http://people.cornell.edu/pages/kk288/
              http://groups.yahoo.com/group/flumech/
            Your message has been successfully submitted and would be delivered to recipients shortly.