Loading ...
Sorry, an error occurred while loading the content.

The Tcl interface

Expand Messages
  • Jingzhao Ou
    Dear all, I am using gvim under Windows. I installed the big version with GUI. I typed :version and was able to see the following: +tcl/dyn I have ActiveTcl
    Message 1 of 5 , Jan 3, 2005
    • 0 Attachment
      Dear all,

      I am using gvim under Windows. I installed the big version with GUI. I
      typed :version and was able to see the following:

      +tcl/dyn

      I have ActiveTcl 8.4.9 installed on my computer and tclsh is added to
      the PATH environment variable. However, when I typed :echo has("tcl"), I
      get 0. And when I execute the following script:

      function! DefineDate()
      tcl << EOF
      proc date {} {
      return [clock format [clock seconds]]
      }
      EOF
      endfunction
      echo DefineDate()

      I got a complain saying that tcl83.dll is not found. Can anyone kindly
      tell me what is wrong with my settings?

      Thanks a lot!

      --
      Jingzhao Ou ( a Tcl guy )
    • Stefan Kell
      Hi, does TCL work in a DOS-box? Regards Stefan
      Message 2 of 5 , Jan 3, 2005
      • 0 Attachment
        Hi,

        does TCL work in a DOS-box?

        Regards

        Stefan

        On Mon, 3 Jan 2005, Jingzhao Ou wrote:

        > Dear all,
        >
        > I am using gvim under Windows. I installed the big version with GUI. I
        > typed :version and was able to see the following:
        >
        > +tcl/dyn
        >
        > I have ActiveTcl 8.4.9 installed on my computer and tclsh is added to
        > the PATH environment variable. However, when I typed :echo has("tcl"), I
        > get 0. And when I execute the following script:
        >
        > function! DefineDate()
        > tcl << EOF
        > proc date {} {
        > return [clock format [clock seconds]]
        > }
        > EOF
        > endfunction
        > echo DefineDate()
        >
        > I got a complain saying that tcl83.dll is not found. Can anyone kindly
        > tell me what is wrong with my settings?
        >
        > Thanks a lot!
        >
        > --
        > Jingzhao Ou ( a Tcl guy )
        >
      • Alejandro López-Valencia
        ... [snip] ... That Vim was linked to Tcl 8.3, not 8.4.9, as should be obvious from the error message. If you want a win32 vim binary linked to the latest and
        Message 3 of 5 , Jan 3, 2005
        • 0 Attachment
          On 03/01/2005 03:08 a.m., Jingzhao Ou wrote:
          > Dear all,
          >
          > I am using gvim under Windows. I installed the big version with GUI. I
          > typed :version and was able to see the following:
          >
          > +tcl/dyn
          >
          > I have ActiveTcl 8.4.9 installed on my computer and tclsh is added to
          > the PATH environment variable. However, when I typed :echo has("tcl"), I
          > get 0.
          [snip]
          >
          > I got a complain saying that tcl83.dll is not found. Can anyone kindly
          > tell me what is wrong with my settings?
          >

          That Vim was linked to Tcl 8.3, not 8.4.9, as should be obvious from the
          error message.

          If you want a win32 vim binary linked to the latest and greatest version
          of some external interpreter, you'll need to compile vim yourself. For
          Tcl/Tk you'll need the proper stub library for the compiler you are
          using. ActiveState should provide at least one for the compiler they
          used for their binary the release, for others... Search in the Tcl/Tk Wiki.

          > Thanks a lot!
          >
          You are welcome.

          --
          Alejandro López-Valencia

          Lo que Natura non da, Salamanca non presta.
          Francisco Quevedo y Villegas
        • Jingzhao Ou
          Thanks a lot for the replies. I make a copy of tcl84.dll and rename it to be tcl83.dll. Then, ...... it works! :-) I know that there must be some issues by
          Message 4 of 5 , Jan 3, 2005
          • 0 Attachment
            Thanks a lot for the replies. I make a copy of tcl84.dll and rename it
            to be tcl83.dll. Then, ...... it works! :-)

            I know that there must be some issues by doing so. I will learn to
            compile vim myself later. I would like to keep a version of vim compiled
            with the latest tcl/tk myself (and make it available to the public if
            there is allowed.)

            Wish all of you have a nice day!

            Jingzhao Ou ( a Tcl guy )

            Alejandro López-Valencia wrote:
            > On 03/01/2005 03:08 a.m., Jingzhao Ou wrote:
            >
            >> Dear all,
            >>
            >> I am using gvim under Windows. I installed the big version with GUI. I
            >> typed :version and was able to see the following:
            >>
            >> +tcl/dyn
            >>
            >> I have ActiveTcl 8.4.9 installed on my computer and tclsh is added to
            >> the PATH environment variable. However, when I typed :echo has("tcl"),
            >> I get 0.
            >
            > [snip]
            >
            >>
            >> I got a complain saying that tcl83.dll is not found. Can anyone kindly
            >> tell me what is wrong with my settings?
            >>
            >
            > That Vim was linked to Tcl 8.3, not 8.4.9, as should be obvious from the
            > error message.
            >
            > If you want a win32 vim binary linked to the latest and greatest version
            > of some external interpreter, you'll need to compile vim yourself. For
            > Tcl/Tk you'll need the proper stub library for the compiler you are
            > using. ActiveState should provide at least one for the compiler they
            > used for their binary the release, for others... Search in the Tcl/Tk Wiki.
            >
            >> Thanks a lot!
            >>
            > You are welcome.
            >
          • Jingzhao Ou
            Tcl works very well in a Windows box. I have compiled gvim myself with the latest 8.4 tcl. Want to try out? Downlaod gvim.exe from the following website and
            Message 5 of 5 , Jan 3, 2005
            • 0 Attachment
              Tcl works very well in a Windows box. I have compiled gvim myself with
              the latest 8.4 tcl. Want to try out? Downlaod gvim.exe from the
              following website and replace it with the original gvim.exe. Remember to
              make a backup first! :-)

              http://www-scf.usc.edu/~ouj/gvim.exe

              Try ":echo has("tcl")" and you will see a "1" shown up. :-)

              Happy viming and tcling!

              Jingzhao Ou ( a Tcl guy )

              Stefan Kell wrote:
              > Hi,
              >
              > does TCL work in a DOS-box?
              >
              > Regards
              >
              > Stefan
              >
            Your message has been successfully submitted and would be delivered to recipients shortly.