Loading ...
Sorry, an error occurred while loading the content.

RE: Why my gvim cannot be used with "Open With" after upgrading to WinXP SP2?

Expand Messages
  • David Fishburn
    ... I had the same problem. When I upgraded to WinXP SP2, any program that was associated with Vim was no longer associated with it. If I right clicked and
    Message 1 of 8 , Nov 18, 2004
    • 0 Attachment
      > -----Original Message-----
      > From: Paul Y. Peng [mailto:ypeng@...]
      > Sent: Monday, October 25, 2004 11:03 PM
      > To: Juan Lanus
      > Cc: vim@...
      > Subject: Re: Why my gvim cannot be used with "Open With"
      > after upgrading to WinXP SP2?
      >
      > Dear Juan,
      >
      > Thank you for sharing your experience with me and your
      > suggestion of using SendTo to get around this problem
      > temporarily. Fortunately in my Windows Explorer context menu,
      > I still have "Open with Vim" created by Vim installer and it
      > still works. So to open a file with Vim, I can right-click it
      > every time and choose "Open with Vim".
      >
      > The problem hasn't been solved yet. It seems that this is a
      > problem of MS-Windows and Microsoft should have a fix for it.
      > Unfortunately I could not find any way to contact Microsoft
      > about this problem. As you have seen, I received a suggestion
      > from Hugo and I am still trying to understand his suggestion.
      > I am not sure whether it will fix my problem or not. But one
      > thing that I do not like in this suggestion is to use the
      > full path of Vim. That means whenever I upgrade my vim to a
      > newer version, I have to do the same thing again in the registry tree.


      I had the same problem.
      When I upgraded to WinXP SP2, any program that was associated with Vim was
      no longer associated with it.

      If I right clicked and choose:
      "Open With" -> Choose Program

      Then hit the browse button, found c:\vim\vim63\gvim.exe and checked the
      "Always use the selected program to open this kind of file" it still would
      not associate gvim.exe with that file.

      I had to update 1 registry key (which I had specifically changed in the past
      BEFORE WinXP SP2):

      HKEY_CURRENT_USER\Software\Classes\Applications\gvim.exe\shell\open\command

      Mine was (stopped working):
      gvim.exe "%1"

      And is now (does work with SP2):
      c:\vim\vim63\gvim.exe "%1"


      I did not have to reboot.
      But I *did* have to:

      Right click (from explorer) and chose:
      "Open With" -> Choose Program

      Then hit the browse button, found c:\vim\vim63\gvim.exe and checked the
      "Always use the selected program to open this kind of file".

      Once I did that again, I saw the icon (shown in explorer) change, which was
      a visual sign this worked this time.
      After double clicking on the file, it did indeed launch gvim.exe for that
      file.

      Dave

      --
      Do you use Vim to edit SQL?
      <Plug>
      Check the description of these plugins:
      dbext.vim - Provides database access to 10 databases (Oracle, Sybase, SQL
      Server, MySQL,...) (http://www.vim.org/scripts/script.php?script_id=356)
      SQLUtilities - Formatting SQL, generate - columns lists, procedures for
      databases (http://www.vim.org/scripts/script.php?script_id=492)
      sql.vim - SQL indent file for Sybase ASA and Oracle
      (http://www.vim.org/scripts/script.php?script_id=495)
      Intellisense for Vim : SQL, C++, CSharp, Java, JSP, XML, HTML
      (http://www.vim.org/scripts/script.php?script_id=747)
      </Plug>
    Your message has been successfully submitted and would be delivered to recipients shortly.